Results 1 to 3 of 3

Thread: Conky disappears when I click on desktop when compiz is enabled

  1. #1
    Join Date
    Mar 2013
    Beans
    8

    Conky disappears when I click on desktop when compiz is enabled

    Problem:
    When I have Compiz enabled Conky disappears when I click anywhere on the desktop.

    Distro:
    Linux Voyager (xubuntu xfce 12.10)

    I have tried to search Google for a solution. I added some exceptions in compiz settings manager for window rules, I tried to put conky into compiz's widget layer and I have tried to change lines in ~/.conkyrc but nothing ever changes. I'm not even sure that conky reads the .conkyrc file as I don't see any changes (after logging out and logging in again, or restarting conky from terminal). It keeps disappearing when I click on the desktop no matter what I do. On application auto-start conky also seems to have a short delay on it, which doesn't seem to solve the problem either.

    Now I am clueless on what to try next, thus I registered here to post a thread and ask about the matter.

    My .conkyrc at the moment looks like this:
    Code:
    own_window yes
    own_window_class Conky
    own_window_transparent yes
    own_window_type override
    Sorry if this is the wrong place, but I didn't find any sub-forums under absolute beginners.
    Last edited by ShawnHeim; March 28th, 2013 at 03:37 PM. Reason: problem solved

  2. #2
    wojox is offline I Ubuntu, Therefore, I Am
    Join Date
    Apr 2009
    Beans
    8,630

    Re: Conky disappears when I click on desktop when compiz is enabled

    Try these values:
    Code:
    own_window_type normal
    own_window_transparent no
    own_window_hints undecorated

  3. #3
    Join Date
    Mar 2013
    Beans
    8

    Re: Conky disappears when I click on desktop when compiz is enabled

    Quote Originally Posted by wojox View Post
    Try these values:
    Code:
    own_window_type normal
    own_window_transparent no
    own_window_hints undecorated
    Thanks for suggestion,
    the problem persists though.

    edit:
    okay, it appears that conky wasn't reading the ~./conkyrc file at all, or it was overridden by a file in ~./conky/conky/conky16/TimeFull, which seems to be a conky settings file for that particular conky item that I have been trying to display.

    now I'm using the following configuration:
    Code:
    own_window yes
    own_window_transparent yes
    own_window_type normal
    own_window_hints undecorated, skip_taskbar
    and it displays pretty much the way I want it to and now it does not seem to disappear when I click on desktop, but now for some reason, it only appears in one workspace. How can I make it display on every workspace?

    edit2:
    solved it by adding sticky in own_window_hints

    ended up using this configuration:
    Code:
    own_window yes
    own_window_transparent yes
    own_window_type normal
    own_window_hints undecorated, below, skip_taskbar, skip_pager, sticky
    So, to sum things up the problem was that I was editing the wrong file. Apparently it doesn't matter what you put in ~/.conkyrc when the item specific values override it under ~/.conky/.
    Last edited by ShawnHeim; March 28th, 2013 at 03:31 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •