Page 1 of 16 12311 ... LastLast
Results 1 to 10 of 158

Thread: I have as of yet to see my desktop

Hybrid View

  1. #1
    Join Date
    Mar 2013
    Location
    Texas
    Beans
    89
    Distro
    Ubuntu 12.10 Quantal Quetzal

    I have as of yet to see my desktop

    Working with a Toshiba satelite. Has AMD Turion(tm) II Dual-Core Mobile M500 for its CPU.

    Recently acquired the book Ubuntu Unleashed and it came with an install disk for Ubuntu 12.10, I wanted to try this on one of the machines I have laying around. Went through the process, and it installed Ubuntu on the Toshiba, eliminating windows in the process, unfortunately now when I start it up it goes to the GNU GRUB menu. This gives me the options Ubuntu, Advanced options for Ubuntu, as well as two memory tests. So, being the new user that I am, the obvious choice is Ubuntu. Select that and I get a black screen with a flashing _ symbol. if I let this sit for awhile i will eventualy receive
    [ 7.808320] sp5100_tco: mmio address 0xfec000f0 already in use

    My question here is how would I go about correcting this issue?

  2. #2
    Join Date
    Nov 2006
    Beans
    388
    Distro
    Xubuntu

    Re: I have as of yet to see my desktop

    There are bug reports involving the sp5100 module (for example https://bugs.launchpad.net/ubuntu/+s...x/+bug/1055096), and some people reported that blacklisting that module solved their problems.

    Get to a terminal window: try ctrl+alt+F2 from your black screen & see if that gets you to a command line prompt. If so, login there. If that doesn't work reboot and select recovery mode from the grub menu and then choose "drop to root shell".

    Run this command:
    Code:
    printf "blacklist sp5100_tco" | sudo tee /etc/modprobe.d/blacklist-sp5100.conf
    (In a root shell you can omit the word sudo.)

    That will create a file /etc/modprobe.d/blacklist-sp5100.conf containing the line blacklist sp5100_tco which should prevent the sp5100 module from loading. Reboot & see if that helps. If not, you can easily delete that file.

  3. #3
    Join Date
    Mar 2013
    Location
    Texas
    Beans
    89
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: I have as of yet to see my desktop

    Quote Originally Posted by r.stiltskin View Post
    There are bug reports involving the sp5100 module (for example https://bugs.launchpad.net/ubuntu/+s...x/+bug/1055096), and some people reported that blacklisting that module solved their problems.

    Get to a terminal window: try ctrl+alt+F2 from your black screen & see if that gets you to a command line prompt. If so, login there. If that doesn't work reboot and select recovery mode from the grub menu and then choose "drop to root shell".

    Run this command:
    Code:
    printf "blacklist sp5100_tco" | sudo tee /etc/modprobe.d/blacklist-sp5100.conf
    (In a root shell you can omit the word sudo.)

    That will create a file /etc/modprobe.d/blacklist-sp5100.conf containing the line blacklist sp5100_tco which should prevent the sp5100 module from loading. Reboot & see if that helps. If not, you can easily delete that file.
    ctrl alt f2 did nothing from the black screen.

    The only way i see to access the command line is to have one of the options, such as recovery mode highlighted and then hit c. Typed in what you posted and received:
    error: can't find command 'printf'

    I have at no point seen anything which allows me to select an option 'drop to root shell'

    There has to be something that I am missing.

    When I select the recovery mode I am given a black screen with a decent quantity of information scrolling on it that ends at

    [ 5.099871] toshiba_acpi : Toshiba Laptop Acpi Extras version 0.19

    On this black screen Amidst the provided information I do see

    [ 5.011652] microcode ; failed to load file amd-ucode/microcode_amd.bin

    Could this have something to do with my problem? Or is it something that will be a problem later on?

  4. #4
    Join Date
    Nov 2006
    Beans
    388
    Distro
    Xubuntu

    Re: I have as of yet to see my desktop

    Quote Originally Posted by Mecharius View Post
    ctrl alt f2 did nothing from the black screen.

    The only way i see to access the command line is to have one of the options, such as recovery mode highlighted and then hit c. Typed in what you posted and received:
    error: can't find command 'printf'

    I have at no point seen anything which allows me to select an option 'drop to root shell'

    There has to be something that I am missing.

    When I select the recovery mode I am given a black screen with a decent quantity of information scrolling on it that ends at

    [ 5.099871] toshiba_acpi : Toshiba Laptop Acpi Extras version 0.19

    On this black screen Amidst the provided information I do see

    [ 5.011652] microcode ; failed to load file amd-ucode/microcode_amd.bin

    Could this have something to do with my problem? Or is it something that will be a problem later on?
    Yes there is something you're missing.

    When you highlighted recovery mode and then hit 'c', you were opening a grub command line, not a complete linux shell, so you didn't have all of the normal bash commands available. What I wanted you to do is highlight recovery mode and hit enter -- in other words boot into recovery mode, and at the end of that process, after all the scrolling lines, you should be presented with a menu and among the selections is "drop to root shell".

    Do you not see that menu? If not, what is the last thing you see when you boot in recovery mode?

    Also, please eliminate one mystery: exactly which model of Toshiba Satellite is this?

    One more thing: can you boot Ubuntu directly from the CD using the "try Ubuntu" selection from the initial screen?
    Last edited by r.stiltskin; March 28th, 2013 at 03:56 PM.

  5. #5
    Join Date
    Mar 2013
    Location
    Texas
    Beans
    89
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: I have as of yet to see my desktop

    Quote Originally Posted by r.stiltskin View Post
    Yes there is something you're missing.

    When you highlighted recovery mode and then hit 'c', you were opening a grub command line, not a complete linux shell, so you didn't have all of the normal bash commands available. What I wanted you to do is highlight recovery mode and hit enter -- in other words boot into recovery mode, and at the end of that process, after all the scrolling lines, you should be presented with a menu and among the selections is "drop to root shell".

    Do you not see that menu? If not, what is the last thing you see when you boot in recovery mode?

    Also, please eliminate one mystery: exactly which model of Toshiba Satellite is this?

    One more thing: can you boot Ubuntu directly from the CD using the "try Ubuntu" selection from the initial screen?
    The machine does not have which model it is written on it, so I would not know how to check beyond that. I acquired this one off of one of my coworkers when he upgraded. It started off with windows seven on it, if that is in any way helpful. I did understand that there was supposed to be a menu at the end of recovery mode, but no such thing appeared. The last line presented in this was:

    [ 5.099871] toshiba_acpi : Toshiba Laptop Acpi Extras version 0.19

    try ubuntu is not an available option when I start up the machine with the disk in. As far as I can tell, the only way to access said disk is by hitting f12 and getting into the boot options. From there selecting boot from disk. When I go by this boot option, it begins to load and then freezes at the purple screen with two or three of the circles illuminated below the word UBUNTU.

  6. #6
    Join Date
    Mar 2013
    Location
    Texas
    Beans
    89
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: I have as of yet to see my desktop

    Quote Originally Posted by r.stiltskin View Post
    There are bug reports involving the sp5100 module (for example https://bugs.launchpad.net/ubuntu/+s...x/+bug/1055096), and some people reported that blacklisting that module solved their problems.

    Get to a terminal window: try ctrl+alt+F2 from your black screen & see if that gets you to a command line prompt. If so, login there. If that doesn't work reboot and select recovery mode from the grub menu and then choose "drop to root shell".

    Run this command:
    Code:
    printf "blacklist sp5100_tco" | sudo tee /etc/modprobe.d/blacklist-sp5100.conf
    (In a root shell you can omit the word sudo.)

    That will create a file /etc/modprobe.d/blacklist-sp5100.conf containing the line blacklist sp5100_tco which should prevent the sp5100 module from loading. Reboot & see if that helps. If not, you can easily delete that file.
    Since, apparently, blacklisting is not working, then should I just delete it?

  7. #7
    Join Date
    Jul 2010
    Location
    ozarks, Arkansas, USA
    Beans
    11,095
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: I have as of yet to see my desktop

    Mecharius;
    Still hang'n with you.
    Double check this:
    cat /etc/modprobe.d/blacklist-sp5100.conf
    does indeed result in this:
    The cat command gave me:

    blacklist sp5100_tcogeist@geist-Satellite-L505D:~$
    as the config line should only be "blacklist sp5100_tco".

    just check'n on where things stand
    THE current(cy) in Documentation:
    https://help.ubuntu.com/community/PopularPages

    Happy ubuntu'n !

  8. #8
    Join Date
    Jun 2009
    Location
    SW Forida
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: I have as of yet to see my desktop

    You probably do not have nVidia, but nomodeset sometimes works for other video issues. But it sounds like you may need other boot options.

    How to set NOMODESET and other kernel boot options in grub2
    http://ubuntuforums.org/showthread.php?t=1613132
    https://help.ubuntu.com/community/BootOptions


    http://www.mjmwired.net/kernel/Docum...parameters.txt
    noapic nolapic noapci noirqpoll nosmp irqpoll
    http://www.kernel.org/doc/Documentat...parameters.txt
    Check BIOS for settings:
    try to boot with acpi=off or nomodeset=0 on the boot line
    https://help.ubuntu.com/community/BinaryDriverHowto
    For more info on UEFI boot install & repair - Regularly Updated :
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to change to [Solved] when/if answered completely.

  9. #9
    Join Date
    Oct 2009
    Location
    england
    Beans
    245
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: I have as of yet to see my desktop

    Quote Originally Posted by oldfred View Post
    You probably do not have nVidia, but nomodeset sometimes works for other video issues. But it sounds like you may need other boot options.

    How to set NOMODESET and other kernel boot options in grub2
    http://ubuntuforums.org/showthread.php?t=1613132
    https://help.ubuntu.com/community/BootOptions
    Try the post from oldfed, I had tried to install on a old Toshiba and had similar troubles.
    The above solved my problem
    yes i'm a nood



  10. #10
    Join Date
    Mar 2013
    Location
    Texas
    Beans
    89
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: I have as of yet to see my desktop

    Quote Originally Posted by goldshirt9 View Post
    Try the post from oldfed, I had tried to install on a old Toshiba and had similar troubles.
    The above solved my problem
    I was past the need for nomodeset, but then i managed to mess something up when I was in as root. Already tried going back to using that but it did nothing for me now.

Page 1 of 16 12311 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •