Results 1 to 3 of 3

Thread: Struggling with apt-get

  1. #1
    Join Date
    Nov 2012
    Beans
    23

    Struggling with apt-get

    Okay, I want to get a package so I can use the header ncurses when programming in c.
    I looked into it, and I need to get the package libncurses5-dev.

    I load the terminal and typed: 'sudo apt-cache search libncurses5-dev', then, sure enough, it's there (output is: libncurses5-dev - developer's libraries for ncurses).
    I then tried 'sudo apt-get libncurses5-dev', but to no avail. It gives an output of: E: Invalid operation libncurses5-dev
    This seems like I'm probably making a very basic error, but I'm not seeing it.

    Any help would be appreciated.
    Last edited by usernamer; March 29th, 2013 at 01:35 AM.

  2. #2
    Join Date
    Dec 2009
    Location
    Fareham, UK
    Beans
    1,864
    Distro
    Ubuntu

    Re: Struggling with apt-get

    Code:
    sudo apt-get install libncurses5-dev
    should install the package for you and possibly drag in any dependencies.

  3. #3
    Join Date
    Nov 2012
    Location
    Halloween Town
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: Struggling with apt-get

    You can always get the package directly from UbuntuUpdates.org.

    Here's the link for the download.
    And the APT-INSTALL link.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •