Results 1 to 4 of 4

Thread: Low latency in PureData(Pd) with Jack in Ubuntu Studio 12.04

  1. #1
    Join Date
    Mar 2013
    Beans
    11

    Low latency in PureData(Pd) with Jack in Ubuntu Studio 12.04

    I´m having trouble to make PureData(Pd) to work at low latency in Ubuntu Studio 12.04.
    I get Pd and Jack to work together with my Audio Interface (Alesis IO4) but only at a frames/Period of 1024, which means a latency of 45.2 ms.
    As soon as I try to lower the Frames/period to lower the latency, I get an Audio I/O error from Pd.
    I tried to mess around with the oder parameters, but the only one who appears to affect Pd (and the latency) is the Frames/Period.
    I also tried to use the configuration explained here: https://help.ubuntu.com/community/Ho...KConfiguration , but it doesn´t work either. I really need to get the lowest latency possible, because I work with live instruments and proccesing.
    Any thoughts that may help?

  2. #2
    Join Date
    Feb 2009
    Beans
    592

    Re: Low latency in PureData(Pd) with Jack in Ubuntu Studio 12.04

    I dont know much that could help you here, but have you checked that yours "Periods/buffer" is set to 3 (I believe that is what is required for USB interfaces).

    Cheers

  3. #3
    Join Date
    Jun 2008
    Beans
    1,139
    Distro
    Ubuntu Studio

    Re: Low latency in PureData(Pd) with Jack in Ubuntu Studio 12.04

    What is your CPU? Is it set to performance governour?

  4. #4
    Join Date
    Oct 2012
    Location
    Gothenburg, Sweden
    Beans
    95
    Distro
    Ubuntu Studio Development Release

    Re: Low latency in PureData(Pd) with Jack in Ubuntu Studio 12.04

    Quote Originally Posted by calimastrusia View Post
    I´m having trouble to make PureData(Pd) to work at low latency in Ubuntu Studio 12.04.
    I get Pd and Jack to work together with my Audio Interface (Alesis IO4) but only at a frames/Period of 1024, which means a latency of 45.2 ms.
    As soon as I try to lower the Frames/period to lower the latency, I get an Audio I/O error from Pd.
    I tried to mess around with the oder parameters, but the only one who appears to affect Pd (and the latency) is the Frames/Period.
    I also tried to use the configuration explained here: https://help.ubuntu.com/community/Ho...KConfiguration , but it doesn´t work either. I really need to get the lowest latency possible, because I work with live instruments and proccesing.
    Any thoughts that may help?
    Make sure you are on linux-lowlatency.
    Code:
    $ uname -r
    3.8.0-14-lowlatency
    Much depending on your audio device, you should be able to set frames/pediod as low as 64. This is what I would recommend for live audio (this is what I use myself with pd).

    Also, you can start pd in realtime, with the flag -rt

    I would not be fully concerned about errors, as long you don't hear anything.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •