Hi,

Thinking about turning to Ubuntu completely - only thing holding me back, is the horrible printer support (by printer manufactors that is). My current printer should be supported (well working at least) in Ubuntu 11 according to this thread. However that was some time ago, and what I can read from that thread, is that it probably won't be working in the current version.

So: Has anyone the Canon MP620 working in current Ubuntu? And bonus question: If I wanted to get a new multi-functional (scan/print) network printer, which to buy? Are there a printer hardware compatibility list somewhere? I only managed to find some old lists to follow...

Thanks.

--