Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: software-centre fails to run

  1. #1
    Join Date
    Oct 2008
    Beans
    3,509

    software-centre fails to run

    Software-centre fails to run if chrome is installed.
    Appears to be a python 2.7 error.
    https://bugs.launchpad.net/ubuntu/+s...7/+bug/1159636
    Last edited by stinkeye; March 25th, 2013 at 08:47 PM. Reason: Update fixed.

  2. #2
    Join Date
    Dec 2007
    Location
    green bay, wi
    Beans
    2,188
    Distro
    Lubuntu 14.04 Trusty Tahr

    Lightbulb Re: software-centre fails to run

    tks for the headsup. have same problem

  3. #3
    Join Date
    Jul 2009
    Location
    New York, NY
    Beans
    1,092
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: software-centre fails to run

    Same here...just tried to open it...synaptic package manager is fine...ubuntu software center is "no go"...

  4. #4
    Join Date
    Sep 2005
    Location
    Portugal
    Beans
    23
    Distro
    Dapper Drake Testing/

    Re: software-centre fails to run

    Same here also.

  5. #5
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: software-centre fails to run

    if you run it from a terminal, which error(s) do you get ?

  6. #6
    Join Date
    Jan 2013
    Beans
    10

    Re: software-centre fails to run

    Same here. THis is the error from the terminal:chris@linux:~/.cache$ sudo software-center
    Traceback (most recent call last):
    File "/usr/bin/software-center", line 128, in <module>
    from softwarecenter.ui.gtk3.app import SoftwareCenterAppGtk3
    File "/usr/share/software-center/softwarecenter/ui/gtk3/app.py", line 37, in <module>
    import webbrowser
    File "/usr/lib/python2.7/webbrowser.py", line 505, in <module>
    register_X_browsers()
    File "/usr/lib/python2.7/webbrowser.py", line 489, in register_X_browsers
    register(browser, None, Chrome(browser))
    NameError: global name 'Chrome' is not defined

  7. #7
    Join Date
    Sep 2010
    Location
    Beta Testing in Canada
    Beans
    5,435
    Distro
    Ubuntu Development Release

    Re: software-centre fails to run

    Todays updates gave me an error also about software center .. failure to download certain items .. but it still works.
    This is Rolling Release
    Warnings for New Beta Testers& Helpful Terminal Commands:
    Running Trusty /devel/@ 5.120GHz32bit/ Please put [ prefix] on New Threads!

  8. #8
    Join Date
    Jun 2007
    Beans
    12,946

    Re: software-centre fails to run

    fixed in python2.7 (2.7.4~rc1-2ubuntu2)

  9. #9
    Join Date
    Jan 2013
    Beans
    10

    Re: software-centre fails to run

    Uninstalling Chrome (which I never use anyway) fixes it

  10. #10
    Join Date
    Jul 2009
    Location
    New York, NY
    Beans
    1,092
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: software-centre fails to run

    Quote Originally Posted by mc4man View Post
    fixed in python2.7 (2.7.4~rc1-2ubuntu2)
    Yep...ran some afternoon updates and the fix was there...software center working fine again...
    debian testing was never like this...if something broke, it might not be fixed for quite a long time...you usually had to end up trying to fix it yourself...

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •