Results 1 to 10 of 10

Thread: ATI, OpenGL and Steam problem

  1. #1
    Join Date
    May 2008
    Location
    Moonlight Hill Zone
    Beans
    638
    Distro
    Ubuntu 14.04 Trusty Tahr

    ATI, OpenGL and Steam problem

    Hey guys, I have Ubuntu 12.10 with an ATI Radeon HD 5770.

    I've installed Steam so I could play Team Fortress 2. However, After installing Steam, and trying to launch Team Fortress 2, I get this message: Screenshot from 2013-03-19 21:09:56.jpg

    Any help will be thanked.

  2. #2
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    17,619
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: ATI, OpenGL and Steam problem

    Make sure to install the latest restricted driver: https://wiki.ubuntu.com/Valve#AMD.2BAC8-ATI_Graphics
    elementary OS Luna
    My Screenshot

  3. #3
    Join Date
    Jan 2013
    Beans
    525

    Re: ATI, OpenGL and Steam problem

    AI, I don't think Steam has the best advice. It suggests enabling the Pre-Release Repo in Ubuntu. That could be trouble.

  4. #4
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    17,619
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: ATI, OpenGL and Steam problem

    If the default restricted driver doesn't work, he could give it try.
    elementary OS Luna
    My Screenshot

  5. #5
    Join Date
    May 2008
    Location
    Moonlight Hill Zone
    Beans
    638
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: ATI, OpenGL and Steam problem

    When I use the restricted drivers, I get no unity when I log back in.

  6. #6
    Join Date
    Jan 2013
    Beans
    525

    Re: ATI, OpenGL and Steam problem

    The only other option is xorg-edgers if you are up to it.

  7. #7
    Join Date
    May 2008
    Location
    Moonlight Hill Zone
    Beans
    638
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: ATI, OpenGL and Steam problem

    Would I need to use Synaptic Package Manager to do that?

  8. #8
    Join Date
    Jan 2013
    Beans
    525

    Re: ATI, OpenGL and Steam problem

    Here, be aware you could get the same error as before or worse. This is bleeding edge software:

    sudo add-apt-repository ppaorg-edgers/ppa
    sudo apt-get update
    sudo apt-get remove --purge nvidia-current AND/OR sudo apt-get remove --purge nvidia-current-updates
    sudo apt-get install nvidia-313

    There.

    Edit: I'm an idiot. Thats for Nvidia, not ATI. Unfortunately I have no experience installing an ATI driver. BUT Xorg-Edgers will help. I swear, it has the ATI driver in it.
    Last edited by ManamiVixen; March 25th, 2013 at 12:37 AM. Reason: Was being stupid and did Nvidia instead of ATI.

  9. #9
    Join Date
    Jan 2013
    Beans
    525

    Re: ATI, OpenGL and Steam problem

    Yeah just ignore me. I'm going to curl in a corner now.

  10. #10
    Join Date
    Oct 2004
    Location
    Denmark - Scandinavia
    Beans
    17,619
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: ATI, OpenGL and Steam problem

    According to this guy on steam, it requires it a bit of tweaking to get Team Fortress 2 to work with an ATI HD card: http://steamcommunity.com/app/221410.../?l=english#p1

    and http://steamcommunity.com/app/221410...6717055843/#p2 with the same card as you.

    To sum it up; Seems to be a hit or miss regarding Team Fortress 2 if you're using ATI card.


    EDIT: ManamiVixen I also got Nvidia card
    elementary OS Luna
    My Screenshot

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •