Results 1 to 4 of 4

Thread: sony vaio s with insydeh20 bios install problem

  1. #1
    Join Date
    May 2007
    Beans
    49
    Distro
    Ubuntu

    sony vaio s with insydeh20 bios install problem

    Update, new problem:

    I disabled secure boot and for some reason wasnt hit with the read-only error when writing to /EFI/Boot/. Following these steps http://www.hackourlife.com/sony-vaio...-04-dual-boot/ I was able to load grub,
    Thats the good news. The BAD news is that in order to get it to work i had to overwrite "EFI/Microsoft/Boot/bootmgfw.efi" with grubx64.efi. I made a backup of the original file but its just gone. I dont know if i failed to copy it or if it was overwritten somehow but its lost now anyways.

    Without it windows wont boot. is there anyway to to fix this? or will i have to reinstall windows to get the original bootloader restored?



    ------------------------------
    Hi, Ive been trying to set up ubuntu (12.10 64bit) dual boot with windows8 on my sony vaio laptop (SVS1312K3EW) without much luck.

    Ive followed these instructions: https://help.ubuntu.com/community/UEFI
    I could not find any options in my bios interface to disable QuickBoot/FastBoot or Intel Smart Response (step 2) so i did not perform that step.

    After rebooting, my laptop will not load grub but just boot straight into windows8. Ive run the boot-repair tool (http://paste.ubuntu.com/5643853/) but it wasnt able to fix it.

    I tried to move the grub efi file to EFI/Boot but i was hit with an error like this one:

    Code:
    cp: cannot create regular file Read-only file system
    This bugreport describes it further: https://bugs.launchpad.net/ubuntu/+s...2/+bug/1091477

    I have yet to try the workaround posted there though.

    Ill continue to tinker with it but im hoping someone has already come up with a fix.
    Last edited by The Squig; March 24th, 2013 at 11:58 PM.

  2. #2
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: sony vaio s with insydeh20 bios install problem

    Did you overwrite file before running Boot-Repair as it makes backup of everything.

    You have both the efi partition sda3 and a recovery partition sda1 that show/EFI/Microsoft/Boot/bootmgfw.efi, did you overwrite both?

    Also
    copy of Windows efi boot files:

    Windows UEFI install should have backup of bootmgfw.efi here:
    C:\Windows\Boot\EFI\bootmgfw.efi from a working Windows x86_64 installation.
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.




  3. #3
    Join Date
    May 2007
    Beans
    49
    Distro
    Ubuntu

    Re: sony vaio s with insydeh20 bios install problem

    Thank you very much! mounted my windows partition and made a copy from the backup you listed. both windows and ubuntu boots fine now


    Did you overwrite file before running Boot-Repair as it makes backup of everything.
    no but i ran the boot-repair from a usb live session so im not sure where it would have saved it.

    You have both the efi partition sda3 and a recovery partition sda1 that show/EFI/Microsoft/Boot/bootmgfw.efi, did you overwrite both?
    no I did not touch the recovery partition, only sda3.
    Last edited by The Squig; March 24th, 2013 at 10:29 PM.

  4. #4
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: sony vaio s with insydeh20 bios install problem

    Glad you got it working.

    I would backup efi partition and all of Windows. And make a Windows repair flash drive.

    Backup windows before install - post by Mark Phelps
    http://ubuntuforums.org/showthread.php?t=2040149
    http://ubuntuforums.org/showthread.php?t=1626990
    http://www.macrium.com/reflectfree.asp
    Another suggestion by srs5694
    http://www.runtime.org/driveimage-xml.htm


    Windows 8 UEFI repair USB must be FAT32
    http://www.eightforums.com/tutorials...ndows-8-a.html
    http://social.msdn.microsoft.com/For...-166dddf32205/
    http://www.ghacks.net/2012/11/01/how...m-repair-disc/
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.




Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •