Results 1 to 5 of 5

Thread: Would like to install labyrinth from Github

  1. #1
    Join Date
    May 2006
    Location
    Copenhagen
    Beans
    160
    Distro
    Xubuntu 13.04 Raring Ringtail

    Would like to install labyrinth from Github

    I would like to install the mind mappring software from Github https://github.com/labyrinth-team/labyrinth/zipball/0.6

    I have actually succeeded once before, but can not remember how I did it. Can anybody help?

    I am aware that 4.0 is in the ubuntu repositories, but the progress is significant so I would really like the latest. Anybody who can help?

  2. #2
    Join Date
    Jul 2011
    Location
    South-Africa
    Beans
    678
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Would like to install labyrinth from Github

    Hay,

    The read me file supplies all the needed info:

    From the top directory of the package, run the command::

    ./labyrinth

    You can also install Labyrinth with ``python setup.py install``, and
    ``./install_data_files.sh`` for icons and translations. It can then be run as
    ``labyrinth``.
    If you have a specific issue, please ask that rather for a better helpful answer.

    Cheers
    Switched away from windows XP to Ubuntu 9.04. Never turned around to look back.

  3. #3
    Join Date
    May 2006
    Location
    Copenhagen
    Beans
    160
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: Would like to install labyrinth from Github

    Hi I read the installation instructions. As far as I understand them is,

    Open terminal

    Move to the folder

    type comment python setup.py install

    And hit enter

    That does not get me the result

    The other instruction I understand as

    Open terminal

    Move to the folder

    type comment ./labyrinth

    And hit enter

    That does not give any result either.

    So I must not be able to understand how to use the install instructions.

    t.

  4. #4
    Join Date
    Dec 2006
    Beans
    7,305

    Re: Would like to install labyrinth from Github

    Is there an error message when you type:
    Code:
    ./labyrinth
    from the source directory? Bear in mind there are some requirements:

    Code:
    Requirements
    ------------
    
    * Python >= 2.6
    * gtk+
    * pygtk
    * pygobject
    * pycairo
    * PyXDG
    You think that's air you're breathing now?

  5. #5
    Join Date
    May 2006
    Location
    Copenhagen
    Beans
    160
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: Would like to install labyrinth from Github

    Hi I have not installed any extra, so I might possibly be missing some of the requirements.

    The error I get is

    Traceback (most recent call last):
    File "./labyrinth", line 35, in <module>
    from labyrinth_lib import utils
    File "/home/thorbjrn/Downloads/labyrinth/labyrinth_lib/utils.py", line 30, in <module>
    from numpy import array
    ImportError: No module named numpy

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •