Results 1 to 4 of 4

Thread: Why is Aptitude holding some packages at current version?

  1. #1
    Join Date
    Oct 2009
    Beans
    14

    Why is Aptitude holding some packages at current version?

    In the past, I've always updated my system using the GUI or with "sudo aptitude safe-upgrade". Recently I discovered the interactive CLI mode of aptitude, and started playing with it. I notice that a few packages have the status "held at current version. Can anyone shed some light as to why these packages are being held? I never chose that intentionally. Maybe I did it by mistake. These are the packages:

    apparmor 2.7.102-0ubunt
    apt 0.8.16~exp12ub
    apt-transport-https 0.8.16~exp12ub
    apt-utils 0.8.16~exp12ub
    libapt-inst1.4 0.8.16~exp12ub
    libapt-pkg4.12 0.8.16~exp12ub


  2. #2
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    7,140

    Re: Why is Aptitude holding some packages at current version?

    I usually update/upgrade with apt-get, which is similar to aptitude. Sometimes I let the auto-started GUI interface do the job.

    Read the detailed description in
    Code:
    man apt-get
    and
    Code:
    man aptitude
    Code:
    sudo apt-get update
    sudo apt-get upgrade         # install most packages
    sudo apt-get dist-upgrade    # try to install packages held back by upgrade
    Try this and report back

  3. #3
    Join Date
    Oct 2009
    Beans
    14

    Re: Why is Aptitude holding some packages at current version?

    I'm reluctant to use apt-get because everything I've read says aptitude is the newer, better version.
    I ran aptitude dist-upgrade and most packages were installed, except one. Details:

    Code:
    $aptitude show apparmor
    Package: apparmor
    State: installed [held]
    Automatically installed: no
    Version: 2.7.102-0ubuntu3.7
    Priority: standard
    Section: admin
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Architecture: amd64
    Uncompressed Size: 1,081 k
    Depends: libc6 (>= 2.14), debconf (>= 0.5) | debconf-2.0, python, lsb-base,
             initramfs-tools, debconf
    PreDepends: dpkg (>= 1.15.7.2)
    Suggests: apparmor-profiles, apparmor-docs, apparmor-utils
    Conflicts: apparmor
    Breaks: apparmor-utils (< 2.6.1-4ubuntu1), apparmor-utils (< 2.6.1-4ubuntu1),
            libapache2-mod-apparmor (< 2.5.1-0ubuntu3), libapache2-mod-apparmor (<
            2.5.1-0ubuntu3)
    Replaces: apparmor-parser, apparmor-parser, apparmor-utils (< 2.6.1-4ubuntu1),
              apparmor-utils (< 2.6.1-4ubuntu1), libapache2-mod-apparmor (<
              2.5.1-0ubuntu3), libapache2-mod-apparmor (< 2.5.1-0ubuntu3)
    Description: User-space parser utility for AppArmor
     This provides the system initialization scripts needed to use the AppArmor
     Mandatory Access Control system, including the AppArmor Parser which is
     required to convert AppArmor text profiles into machine-readable policies that
     are loaded into the kernel for use with the AppArmor Linux Security Module.
    Homepage: http://apparmor.net/

  4. #4
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    7,140

    Re: Why is Aptitude holding some packages at current version?

    Maybe apparmor is not ready to upgrade because it is waiting for some library, that must be upgraded too. But I am not used to aptitude, so I am not good at decrypting its messages.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •