Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: 12.04 Package system broken, can't update or install apps

  1. #1
    Join Date
    Mar 2009
    Location
    Birmingham, AL
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    12.04 Package system broken, can't update or install apps

    Hi,

    I have been unable to install updates for several months. When I click on the Update Manager icon at the top of my screen, which right now is a red circle with a horizontal white line in it, I get the following error message:

    The package system is broken

    Check if you are using third party repositories. If so disable them, since they are a common source of problems.
    Furthermore run the following command in a Terminal: apt-get install -f

    Details:

    The following packages have unmet dependencies:
    linux-image-generic: Depends: linux-image-3.2.0-31-generic but it is not installed

    So I run
    Code:
    apt-get install -f
    as it tells me to, and this is what I get:

    Code:
    xxxxx@xxxxx-xxxxxx:~$ sudo apt-get install -f
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
      linux-headers-3.2.0-26-generic screen-resolution-extra
      gstreamer0.10-fluendo-mp3:i386 linux-headers-3.2.0-25 linux-headers-3.2.0-26
      linux-headers-3.2.0-25-generic liboil0.3:i386
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
      linux-generic linux-image-generic
    The following packages will be upgraded:
      linux-generic linux-image-generic
    2 upgraded, 0 newly installed, 0 to remove and 438 not upgraded.
    2 not fully installed or removed.
    Need to get 0 B/4,310 B of archives.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    dpkg: dependency problems prevent configuration of linux-image-generic:
     linux-image-generic depends on linux-image-3.2.0-31-generic; however:
      Package linux-image-3.2.0-31-generic is not installed.
    dpkg: error processing linux-image-generic (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
                              dpkg: dependency problems prevent configuration of linux-generic:
     linux-generic depends on linux-image-generic (= 3.2.0.31.34); however:
      Package linux-image-generic is not configured yet.
    dpkg: error processing linux-generic (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
                              Errors were encountered while processing:
     linux-image-generic
     linux-generic
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    So what can I do to update my OS?

  2. #2
    Join Date
    Apr 2009
    Location
    Mangalore India
    Beans
    802
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: 12.04 Package system broken, can't update or install apps

    sudo apt-get -f install ; sudo dpkg --configure -a
    Try this command in terminal and update the OS. Let me know the outcome
    With regards
    Dr Kurian
    Microsoft gives you Windows... Linux gives you the whole house.

  3. #3
    Join Date
    Mar 2009
    Location
    Birmingham, AL
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 Package system broken, can't update or install apps

    Here is the result:

    Code:
    xxxxxx@xxxxxx-xxxxxxx:~$ sudo apt-get -f install; sudo dpkg --configure -a
    [sudo] password for xxxxxx: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following packages were automatically installed and are no longer required:
      linux-headers-3.2.0-26-generic screen-resolution-extra
      gstreamer0.10-fluendo-mp3:i386 linux-headers-3.2.0-25 linux-headers-3.2.0-26
      linux-headers-3.2.0-25-generic liboil0.3:i386
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
      linux-generic linux-image-generic
    The following packages will be upgraded:
      linux-generic linux-image-generic
    2 upgraded, 0 newly installed, 0 to remove and 443 not upgraded.
    2 not fully installed or removed.
    Need to get 0 B/4,310 B of archives.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    dpkg: dependency problems prevent configuration of linux-image-generic:
     linux-image-generic depends on linux-image-3.2.0-31-generic; however:
      Package linux-image-3.2.0-31-generic is not installed.
    dpkg: error processing linux-image-generic (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
                              dpkg: dependency problems prevent configuration of linux-generic:
     linux-generic depends on linux-image-generic (= 3.2.0.31.34); however:
      Package linux-image-generic is not configured yet.
    dpkg: error processing linux-generic (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
                              Errors were encountered while processing:
     linux-image-generic
     linux-generic
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    dpkg: dependency problems prevent configuration of linux-image-generic:
     linux-image-generic depends on linux-image-3.2.0-31-generic; however:
      Package linux-image-3.2.0-31-generic is not installed.
    dpkg: error processing linux-image-generic (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of linux-generic:
     linux-generic depends on linux-image-generic (= 3.2.0.31.34); however:
      Package linux-image-generic is not configured yet.
    dpkg: error processing linux-generic (--configure):
     dependency problems - leaving unconfigured
    Errors were encountered while processing:
     linux-image-generic
     linux-generic

  4. #4
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

  5. #5
    Join Date
    Apr 2009
    Location
    Mangalore India
    Beans
    802
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: 12.04 Package system broken, can't update or install apps

    As per the error message, the linux image generic is not configured because linux-image-generic depends on linux-image-3.2.0-31-generic.
    linux-image-3.2.0-31-generic is available here. Click the option "apt install"

    I think this should solve the problem
    With regards
    Dr Kurian
    Microsoft gives you Windows... Linux gives you the whole house.

  6. #6
    Join Date
    Mar 2009
    Location
    Birmingham, AL
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 Package system broken, can't update or install apps

    Quote Originally Posted by Bucky Ball View Post
    Code:
    sudo apt-get autoremove
    and try again.
    Code:
    xxxxxx@xxxxxx-xxxxxxx:~$ sudo apt-get autoremove
    [sudo] password for xxxxxx: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
     linux-image-generic : Depends: linux-image-3.2.0-31-generic but it is not installed
    E: Unmet dependencies. Try using -f.
    buddy@buddy-N68S3B:~$ sudo apt-get autoremove -f
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Correcting dependencies... Done
    The following extra packages will be installed:
      linux-generic linux-image-generic
    The following packages will be REMOVED:
      gstreamer0.10-fluendo-mp3:i386 liboil0.3:i386 linux-headers-3.2.0-25
      linux-headers-3.2.0-25-generic linux-headers-3.2.0-26
      linux-headers-3.2.0-26-generic screen-resolution-extra
    The following packages will be upgraded:
      linux-generic linux-image-generic
    2 upgraded, 0 newly installed, 7 to remove and 443 not upgraded.
    2 not fully installed or removed.
    Need to get 0 B/4,310 B of archives.
    After this operation, 136 MB disk space will be freed.
    Do you want to continue [Y/n]? y
    (Reading database ... 336654 files and directories currently installed.)
    Removing gstreamer0.10-fluendo-mp3:i386 ...
    Removing liboil0.3:i386 ...
    Removing linux-headers-3.2.0-25-generic ...
    Removing linux-headers-3.2.0-25 ...
    Removing linux-headers-3.2.0-26-generic ...
    Removing linux-headers-3.2.0-26 ...
    Removing screen-resolution-extra ...
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    dpkg: dependency problems prevent configuration of linux-image-generic:
     linux-image-generic depends on linux-image-3.2.0-31-generic; however:
      Package linux-image-3.2.0-31-generic is not installed.
    dpkg: error processing linux-image-generic (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
                              dpkg: dependency problems prevent configuration of linux-generic:
     linux-generic depends on linux-image-generic (= 3.2.0.31.34); however:
      Package linux-image-generic is not configured yet.
    dpkg: error processing linux-generic (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
                              Errors were encountered while processing:
     linux-image-generic
     linux-generic
    E: Sub-process /usr/bin/dpkg returned an error code (1)

  7. #7
    Join Date
    Mar 2009
    Location
    Birmingham, AL
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 Package system broken, can't update or install apps

    Quote Originally Posted by drpjkurian View Post
    As per the error message, the linux image generic is not configured because linux-image-generic depends on linux-image-3.2.0-31-generic.
    linux-image-3.2.0-31-generic is available here. Click the option "apt install"

    I think this should solve the problem
    I clicked on the Apt Install button at that link and here is what I got:

    Code:
    Items cannot be installed or removed until the package catalog is repaired. Do you want to repair it now?
    
    Once Update Manager has finished the repairs, you can close it and return to the store.
    I clicked Repair

    Then I got the error message

    Code:
    Package operation failed
    The installation or removal of a software package failed.
    Details:
    installArchives() failed: dpkg: dependency problems prevent configuration of linux-image-generic:
     linux-image-generic depends on linux-image-3.2.0-31-generic; however:
      Package linux-image-3.2.0-31-generic is not installed.
    dpkg: error processing linux-image-generic (--configure):
     dependency problems - leaving unconfigured
    No apport report written because the error message indicates its a followup error from a previous failure.
    dpkg: dependency problems prevent configuration of linux-generic:
     linux-generic depends on linux-image-generic (= 3.2.0.31.34); however:
      Package linux-image-generic is not configured yet.
    dpkg: error processing linux-generic (--configure):
     dependency problems - leaving unconfigured
    No apport report written because MaxReports is reached already
    Errors were encountered while processing:
     linux-image-generic
     linux-generic
    Error in function: 
    SystemError: E:Sub-process /usr/bin/dpkg returned an error code (1)
    dpkg: dependency problems prevent configuration of linux-image-generic:
     linux-image-generic depends on linux-image-3.2.0-31-generic; however:
      Package linux-image-3.2.0-31-generic is not installed.
    dpkg: error processing linux-image-generic (--configure):
     dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of linux-generic:
     linux-generic depends on linux-image-generic (= 3.2.0.31.34); however:
      Package linux-image-generic is not configured yet.
    dpkg: error processing linux-generic (--configure):
     dependency problems - leaving unconfigured

  8. #8
    Join Date
    Mar 2013
    Beans
    4

    Re: 12.04 Package system broken, can't update or install apps

    I have experienced a problem like that, but eventually I gave up, and what I did was reinstall my ubuntu..

  9. #9
    Join Date
    Apr 2007
    Location
    Hamden, CT
    Beans
    649
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 Package system broken, can't update or install apps

    What happens when you run these commands?

    Code:
    sudo apt-get update
    sudo apt-get upgrade
    I saw this thread earlier this week, and was convinced that 'sudo apt-get update' was going to fix it for you, but I guess it didn't. I'll jump on board and see if we can figure this out.

    Also keep in mind that when you run these commands in terminal, you must NOT have any other windows that pertain to install/upgrading the system .. i.e. don't run the commands when you have the 'Update Manager' or 'Ubuntu Software Center' open.

  10. #10
    Join Date
    Mar 2009
    Location
    Birmingham, AL
    Beans
    115
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 Package system broken, can't update or install apps

    Quote Originally Posted by LuisGMarine View Post
    What happens when you run these commands?

    Code:
    sudo apt-get update
    sudo apt-get upgrade
    I saw this thread earlier this week, and was convinced that 'sudo apt-get update' was going to fix it for you, but I guess it didn't. I'll jump on board and see if we can figure this out.

    Also keep in mind that when you run these commands in terminal, you must NOT have any other windows that pertain to install/upgrading the system .. i.e. don't run the commands when you have the 'Update Manager' or 'Ubuntu Software Center' open.
    Code:
    xxxxxx@xxxxxx-xxxxxxx:~$ sudo apt-get update
    [sudo] password for xxxxxx: 
    Ign http://dl.google.com stable InRelease
    Ign http://dl.google.com stable InRelease                                      
    Ign http://security.ubuntu.com precise-security InRelease                      
    Ign http://us.archive.ubuntu.com precise InRelease                             
    Ign http://us.archive.ubuntu.com precise-updates InRelease                     
    Ign http://us.archive.ubuntu.com precise-backports InRelease                   
    Ign http://archive.canonical.com precise InRelease                             
    Hit http://dl.google.com stable Release.gpg                                    
    Ign http://extras.ubuntu.com precise InRelease                                 
    Hit http://security.ubuntu.com precise-security Release.gpg                    
    Hit http://us.archive.ubuntu.com precise Release.gpg                           
    Hit http://dl.google.com stable Release.gpg                                    
    Hit http://security.ubuntu.com precise-security Release                        
    Hit http://us.archive.ubuntu.com precise-updates Release.gpg                   
    Hit http://dl.google.com stable Release                                        
    Hit http://archive.canonical.com precise Release.gpg                           
    Hit http://extras.ubuntu.com precise Release.gpg                               
    Hit http://us.archive.ubuntu.com precise-backports Release.gpg                 
    Hit http://security.ubuntu.com precise-security/main Sources                   
    Hit http://us.archive.ubuntu.com precise Release                               
    Hit http://archive.canonical.com precise Release                               
    Hit http://extras.ubuntu.com precise Release                                   
    Hit http://security.ubuntu.com precise-security/restricted Sources             
    Hit http://security.ubuntu.com precise-security/universe Sources               
    Hit http://security.ubuntu.com precise-security/multiverse Sources             
    Hit http://security.ubuntu.com precise-security/main amd64 Packages            
    Hit http://security.ubuntu.com precise-security/restricted amd64 Packages      
    Hit http://security.ubuntu.com precise-security/universe amd64 Packages        
    Hit http://security.ubuntu.com precise-security/multiverse amd64 Packages      
    Hit http://security.ubuntu.com precise-security/main i386 Packages             
    Hit http://security.ubuntu.com precise-security/restricted i386 Packages       
    Hit http://security.ubuntu.com precise-security/universe i386 Packages         
    Hit http://us.archive.ubuntu.com precise-updates Release                       
    Hit http://archive.canonical.com precise/partner amd64 Packages                
    Hit http://us.archive.ubuntu.com precise-backports Release                     
    Hit http://extras.ubuntu.com precise/main Sources                              
    Hit http://us.archive.ubuntu.com precise/main Sources                          
    Hit http://us.archive.ubuntu.com precise/restricted Sources                    
    Hit http://us.archive.ubuntu.com precise/universe Sources                      
    Hit http://us.archive.ubuntu.com precise/multiverse Sources                    
    Hit http://us.archive.ubuntu.com precise/main amd64 Packages                   
    Hit http://dl.google.com stable Release                                        
    Hit http://us.archive.ubuntu.com precise/restricted amd64 Packages             
    Hit http://us.archive.ubuntu.com precise/universe amd64 Packages               
    Hit http://us.archive.ubuntu.com precise/multiverse amd64 Packages             
    Hit http://us.archive.ubuntu.com precise/main i386 Packages                    
    Hit http://archive.canonical.com precise/partner i386 Packages                 
    Ign http://archive.canonical.com precise/partner TranslationIndex              
    Hit http://us.archive.ubuntu.com precise/restricted i386 Packages              
    Hit http://us.archive.ubuntu.com precise/universe i386 Packages                
    Hit http://us.archive.ubuntu.com precise/multiverse i386 Packages              
    Hit http://us.archive.ubuntu.com precise/main TranslationIndex                 
    Hit http://us.archive.ubuntu.com precise/multiverse TranslationIndex           
    Hit http://us.archive.ubuntu.com precise/restricted TranslationIndex           
    Hit http://us.archive.ubuntu.com precise/universe TranslationIndex             
    Hit http://us.archive.ubuntu.com precise-updates/main Sources                  
    Hit http://us.archive.ubuntu.com precise-updates/restricted Sources            
    Hit http://us.archive.ubuntu.com precise-updates/universe Sources              
    Hit http://us.archive.ubuntu.com precise-updates/multiverse Sources            
    Hit http://us.archive.ubuntu.com precise-updates/main amd64 Packages           
    Hit http://us.archive.ubuntu.com precise-updates/restricted amd64 Packages     
    Hit http://us.archive.ubuntu.com precise-updates/universe amd64 Packages       
    Hit http://us.archive.ubuntu.com precise-updates/multiverse amd64 Packages     
    Hit http://us.archive.ubuntu.com precise-updates/main i386 Packages            
    Hit http://us.archive.ubuntu.com precise-updates/restricted i386 Packages      
    Hit http://us.archive.ubuntu.com precise-updates/universe i386 Packages        
    Hit http://us.archive.ubuntu.com precise-updates/multiverse i386 Packages      
    Hit http://us.archive.ubuntu.com precise-updates/main TranslationIndex         
    Hit http://us.archive.ubuntu.com precise-updates/multiverse TranslationIndex   
    Hit http://us.archive.ubuntu.com precise-updates/restricted TranslationIndex   
    Hit http://us.archive.ubuntu.com precise-updates/universe TranslationIndex     
    Hit http://us.archive.ubuntu.com precise-backports/main Sources                
    Hit http://us.archive.ubuntu.com precise-backports/restricted Sources          
    Hit http://us.archive.ubuntu.com precise-backports/universe Sources            
    Hit http://extras.ubuntu.com precise/main amd64 Packages                       
    Hit http://extras.ubuntu.com precise/main i386 Packages                        
    Ign http://extras.ubuntu.com precise/main TranslationIndex                     
    Hit http://us.archive.ubuntu.com precise-backports/multiverse Sources          
    Hit http://us.archive.ubuntu.com precise-backports/main amd64 Packages         
    Hit http://us.archive.ubuntu.com precise-backports/restricted amd64 Packages   
    Hit http://us.archive.ubuntu.com precise-backports/universe amd64 Packages     
    Hit http://us.archive.ubuntu.com precise-backports/multiverse amd64 Packages   
    Hit http://us.archive.ubuntu.com precise-backports/main i386 Packages          
    Hit http://us.archive.ubuntu.com precise-backports/restricted i386 Packages    
    Hit http://us.archive.ubuntu.com precise-backports/universe i386 Packages      
    Hit http://us.archive.ubuntu.com precise-backports/multiverse i386 Packages    
    Hit http://us.archive.ubuntu.com precise-backports/main TranslationIndex       
    Hit http://us.archive.ubuntu.com precise-backports/multiverse TranslationIndex 
    Hit http://us.archive.ubuntu.com precise-backports/restricted TranslationIndex 
    Hit http://us.archive.ubuntu.com precise-backports/universe TranslationIndex   
    Hit http://us.archive.ubuntu.com precise/main Translation-en                   
    Hit http://us.archive.ubuntu.com precise/multiverse Translation-en             
    Hit http://us.archive.ubuntu.com precise/restricted Translation-en             
    Hit http://us.archive.ubuntu.com precise/universe Translation-en               
    Hit http://us.archive.ubuntu.com precise-updates/main Translation-en           
    Hit http://us.archive.ubuntu.com precise-updates/multiverse Translation-en     
    Ign http://archive.canonical.com precise/partner Translation-en_US             
    Ign http://archive.canonical.com precise/partner Translation-en                
    Ign http://extras.ubuntu.com precise/main Translation-en_US                    
    Hit http://dl.google.com stable/main amd64 Packages                            
    Hit http://dl.google.com stable/main i386 Packages                             
    Ign http://dl.google.com stable/main TranslationIndex                          
    Hit http://dl.google.com stable/main amd64 Packages                            
    Hit http://dl.google.com stable/main i386 Packages                             
    Ign http://extras.ubuntu.com precise/main Translation-en                       
    Hit http://us.archive.ubuntu.com precise-updates/restricted Translation-en     
    Hit http://us.archive.ubuntu.com precise-updates/universe Translation-en
    Hit http://us.archive.ubuntu.com precise-backports/main Translation-en
    Hit http://us.archive.ubuntu.com precise-backports/multiverse Translation-en
    Hit http://us.archive.ubuntu.com precise-backports/restricted Translation-en
    Hit http://us.archive.ubuntu.com precise-backports/universe Translation-en
    Ign http://dl.google.com stable/main TranslationIndex                
    Ign http://dl.google.com stable/main Translation-en_US
    Ign http://dl.google.com stable/main Translation-en
    Ign http://dl.google.com stable/main Translation-en_US
    Ign http://dl.google.com stable/main Translation-en
    Hit http://security.ubuntu.com precise-security/multiverse i386 Packages
    Hit http://security.ubuntu.com precise-security/main TranslationIndex
    Hit http://security.ubuntu.com precise-security/multiverse TranslationIndex
    Hit http://security.ubuntu.com precise-security/restricted TranslationIndex
    Hit http://security.ubuntu.com precise-security/universe TranslationIndex
    Hit http://security.ubuntu.com precise-security/main Translation-en
    Hit http://security.ubuntu.com precise-security/multiverse Translation-en
    Hit http://security.ubuntu.com precise-security/restricted Translation-en
    Hit http://security.ubuntu.com precise-security/universe Translation-en
    Reading package lists... Done
    xxxxxx@xxxxxx-xxxxxxx:~$ sudo apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    You might want to run 'apt-get -f install' to correct these.
    The following packages have unmet dependencies:
     linux-image-generic : Depends: linux-image-3.2.0-31-generic but it is not installed
    E: Unmet dependencies. Try using -f.
    xxxxxx@xxxxxx-xxxxxxx:~$

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •