Results 1 to 6 of 6

Thread: Wireless Broadcom doesn't function

Threaded View

  1. #1
    Join Date
    Mar 2013
    Beans
    11

    Wireless Broadcom doesn't function

    Hello guys,
    I'm so excited for this new operating system (Linux), I come from Windows OS, but now I'm really satisfied.
    Please have patience with me, because I'm still learning the basics of Linux.
    I have a small/big problem. The wireless does not work.
    I followed this little guide (which also corresponds to the one mentioned, but to no avail) :
    http://community.linuxmint.com/tutorial/view/796

    Because it corresponds exactly to my wireless card:
    04:00.0 Network controller [0280]: Broadcom Corporation BCM4312 802.11b/g LP-PHY [14e4:4315] (rev 01)
    that is to say:
    sudo apt-get install firmware-b43-installer
    gave error, then I gave:
    sudo apt-get install firmware-b43-lpphy-installer
    and now he seems to see the wifi card, based on what iwconfig says:
    wlan0....IEEE 802.11bg..ESSID : off/any
    ..........Mode:Managed..Access Point: Not-Associated...Tx-Power=0 dBm
    ..........Retry long limit:7...RTSthr: off...Fragment thr: off
    ..........Power Management: on
    I also gave him:
    sudo lshw -C network
    ..*-network
    .......description: Network controller
    .......product: BCM4312 802.11b/g LP-PHY
    .......vendor: Broadcom Corporation
    .......physical id: 0
    .......bus info: pci@0000:04:00.0
    .......version: 01
    .......width: 64 bits
    .......clock: 33MHz
    .......capabilities: pm msi pciexpress bus_master cap_list
    .......configuration: driver=b43-pci-bridge latency=0
    .......resources: irq:18 memory:9c200000-9c203fff
    ..*-network
    .......description: Ethernet interface
    .......product: RTL8111/8168B PCI Express Gigabit Ethernet controller
    .......vendor: Realtek Semiconductor Co., Ltd.
    .......physical id: 0
    .......bus info: pci@0000:05:00.0
    .......logical name: eth0
    .......version: 02
    .......serial: 00:1e:ec:bb:0f:de
    .......size: 100Mbit/s
    .......capacity: 1Gbit/s
    .......width: 64 bits
    .......clock: 33MHz
    .......capabilities: pm msi pciexpress msix vpd bus_master cap_list rom ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
    .......configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=full ip=192.168.2.100 latency=0 link=yes multicast=yes port=MII speed=100Mbit/s
    .......resources: irq:48 ioport:3000(size=256) memory:96010000-96010fff memory:96000000-9600ffff memory:96020000-9602ffff
    ..*-network DISABLED
    .......description: Wireless interface
    .......physical id: 2
    .......logical name: wlan0
    .......serial: 00:21:00:68:52:8f
    .......capabilities: ethernet physical wireless
    .......configuration: broadcast=yes driver=b43 driverversion=3.5.0-17-generic firmware=N/A link=no multicast=yes wireless=IEEE 802.11bg
    I copied the complete answer of dmesg in dmesg.txt and is uploaded here: http://www.fileconvoy.com/dfl.php?id...cddbd722747744
    My computer is an Hp pavilion dv4-1190el and I installed Linux Mint 14 Xfce 32bit all codecs (so it's an ubuntu like)(I use Mint because unbuntu, doesn't starts, all release, lots off error, I don't know why, anyway).
    Thanks in advance, best regards.
    Antony
    Last edited by Artificial Intelligence; March 26th, 2013 at 05:05 AM. Reason: prefix Solved

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •