Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 21

Thread: Brightness control doesn't work

  1. #11
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Brightness control doesn't work

    Quote Originally Posted by sugarat View Post
    I'll give those a try. Silly question - when I edit /boot/grub/grub.cfg, - do those parameters actually need a dash in front of them, or is that just your formatting?
    Its just formatting. Use the parameters without the leading dashes. But you shouldn't edit /boot/grub/grub.cfg, instead edit /etc/default/grub. Add the parameter to the line starting GRUB_CMDLINE_LINUX, save the file, then run:
    Code:
    sudo update-grub
    Code:
    root@adam-PC:/boot/grub# cd /sys/class/backlight && grep . */*
    intel_backlight/actual_brightness:4393
    intel_backlight/bl_power:0
    intel_backlight/brightness:4393
    grep: intel_backlight/device: Is a directory
    intel_backlight/max_brightness:4882
    grep: intel_backlight/power: Is a directory
    grep: intel_backlight/subsystem: Is a directory
    intel_backlight/type:raw
    Does the following command decrease brightness?
    Code:
    echo 2400 | sudo tee /sys/class/backlight/intel_backlight/brightness

  2. #12
    Join Date
    Nov 2005
    Beans
    59

    Re: Brightness control doesn't work

    Ok. I have tried booting with each of those parameters but there is no change.

    Similarly, echo 2400 | sudo tee /sys/class/backlight/intel_backlight/brightness is having no effect...

  3. #13
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Brightness control doesn't work

    Quote Originally Posted by sugarat View Post
    Ok. I have tried booting with each of those parameters but there is no change.

    Similarly, echo 2400 | sudo tee /sys/class/backlight/intel_backlight/brightness is having no effect...
    Which kernel parameters were you using when you ran that command:
    Code:
    cat /proc/cmdline
    Did you have the same one backlight interface?
    Code:
    cd /sys/class/backlight && grep . */*

  4. #14
    Join Date
    Nov 2005
    Beans
    59

    Re: Brightness control doesn't work

    I'm not sure what I was running in the past.

    Right now I have the following:

    Code:
    adam@adam-PC:~$ cat /proc/cmdline
    BOOT_IMAGE=/boot/vmlinuz-3.5.0-26-generic root=UUID=c2c89696-4712-46fa-b99c-af9aac981777 ro quiet splash "acpi_osi=!Windows 2012" acpi_backlight=vendor vt.handoff=7
    And

    Code:
    adam@adam-PC:~$ cd /sys/class/backlight && grep . */*
    intel_backlight/actual_brightness:4882
    intel_backlight/bl_power:0
    intel_backlight/brightness:4882
    grep: intel_backlight/device: Is a directory
    intel_backlight/max_brightness:4882
    grep: intel_backlight/power: Is a directory
    grep: intel_backlight/subsystem: Is a directory
    intel_backlight/type:raw

  5. #15
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Brightness control doesn't work

    Can you post back the contents of your /etc/default/grub file? Something doesn't look right in there.

  6. #16
    Join Date
    Nov 2005
    Beans
    59

    Re: Brightness control doesn't work

    Sure, here it is:

    Code:
    # If you change this file, run 'update-grub' afterwards to update
    # /boot/grub/grub.cfg.
    # For full documentation of the options in this file, see:
    #   info -f grub -n 'Simple configuration'
    
    GRUB_DEFAULT=0
    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    GRUB_TIMEOUT=10
    GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=\"!Windows 2012\" acpi_backlight=vendor"
    GRUB_CMDLINE_LINUX=""
    
    # Uncomment to enable BadRAM filtering, modify to suit your needs
    # This works with Linux (no patch required) and with any kernel that obtains
    # the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
    #GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"
    
    # Uncomment to disable graphical terminal (grub-pc only)
    #GRUB_TERMINAL=console
    
    # The resolution used on graphical terminal
    # note that you can use only modes which your graphic card supports via VBE
    # you can see them in real GRUB with the command `vbeinfo'
    #GRUB_GFXMODE=640x480
    
    # Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
    #GRUB_DISABLE_LINUX_UUID=true
    
    # Uncomment to disable generation of recovery mode menu entries
    #GRUB_DISABLE_RECOVERY="true"
    
    # Uncomment to get a beep at grub start
    #GRUB_INIT_TUNE="480 440 1"

  7. #17
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Brightness control doesn't work

    Change this line:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=\"!Windows 2012\" acpi_backlight=vendor"
    ...to read:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=\"!Windows 2012\""
    ...then run:
    Code:
    sudo update-grub
    ...and reboot.

    Once rebooted, post back again:
    Code:
    cat /proc/cmdline
    ...and
    Code:
    cd /sys/class/backlight && grep . */*
    ...and test brightness.

  8. #18
    Join Date
    Nov 2005
    Beans
    59

    Re: Brightness control doesn't work

    Okay, I now have

    Code:
    BOOT_IMAGE=/boot/vmlinuz-3.5.0-26-generic root=UUID=c2c89696-4712-46fa-b99c-af9aac981777 ro quiet splash "acpi_osi=!Windows 2012" vt.handoff=7
    Code:
    intel_backlight/actual_brightness:3222
    intel_backlight/bl_power:0
    intel_backlight/brightness:3222
    grep: intel_backlight/device: Is a directory
    intel_backlight/max_brightness:4882
    grep: intel_backlight/power: Is a directory
    grep: intel_backlight/subsystem: Is a directory
    intel_backlight/type:raw

  9. #19
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Brightness control doesn't work

    Do the brightness keys work?

    Does the following command affect brightness:
    Code:
    echo 2400 | sudo tee /sys/class/backlight/intel_backlight/brightness
    Can I see your dmesg log?
    Code:
    pastebinit /var/log/dmesg
    ...and post back the link that is generated.

  10. #20
    Join Date
    Nov 2005
    Beans
    59

    Re: Brightness control doesn't work

    I don't have any brightness keys on my keyboard, so I have loaded the 'Brightness and Lock' program from Settings. When I drag the slider down from its default 'full on' position, the brightness does not change.

    Running the code you gave has no effect.

    http://paste.ubuntu.com/5658969/

Page 2 of 3 FirstFirst 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •