Results 1 to 6 of 6

Thread: Samba and Sharing with Windows...broken *again*?

  1. #1
    Join Date
    May 2008
    Location
    bay area, california
    Beans
    196
    Distro
    Ubuntu

    Samba and Sharing with Windows...broken *again*?

    OK, so after yet another kernel and samba update in 12.04 now my ability to share between Ubuntu and Windows is broken again, for no apparent reason. I go into Samba and it tells me the server is in WORKGROUP and description "%h server (Samba, Ubuntu)" - same as always, worked before. Only Ubuntu sees absolutely nothing in the Windows network. The "Personal File Sharing" thing continues to be a bad joke because the right packages are never installed - what's the point of even having it there? But that is a different matter.

    I uninstalled and re-installed Samba in case some sub-package was broken... still no luck.

    Honestly this stuff seemed to work more reliably back in 10.04 and even 8.04.

    Any guides on how to troubleshoot Samba?

  2. #2
    Join Date
    Mar 2008
    Beans
    1,219

    Re: Samba and Sharing with Windows...broken *again*?

    Are you sure you didn't overwrite your your smb.conf during the update?

  3. #3
    Join Date
    May 2008
    Location
    bay area, california
    Beans
    196
    Distro
    Ubuntu

    Re: Samba and Sharing with Windows...broken *again*?

    Positively sure - it is still there.

  4. #4
    Join Date
    May 2008
    Location
    bay area, california
    Beans
    196
    Distro
    Ubuntu

    Re: Samba and Sharing with Windows...broken *again*?

    This issue may make me give up on using Ubuntu in my home network. It is getting too frustrating to synch media files.

    I hope the Ubuntu community finds a way to make this more inituitive - the "Personal File Sharing" setup shoould be made to work. And Samba should be as easy as entering the Windows Workgroup name and be done.

    Based on every Samba guide I see (and there are many, and they are inconsistent) my setup should be working.

  5. #5
    Join Date
    Dec 2009
    Beans
    5,355

    Re: Samba and Sharing with Windows...broken *again*?

    From what information you posted it doesn't sound like a Samba issue but a Networking or a name resolution issue. There's an easy way to find out. Run the following command:
    Code:
    nautilus smb://192.168.0.100
    Change 192.168.0.100 to the ip address of the Windows machine.

    If you can get through then Samba is working just fine.

    As far a seeing your Windows machine by name in Nautilus there's really only a number of things that can get in the way:

    ** Can't browse by name unless all the machines are in the same subnet so check your ip addresses and see if they are in the same subnet.

    ** Some or all of the samba dependent services aren't running so check them and if they are not started start them:
    Code:
    sudo service smbd start
    sudo service nmbd start
    ** Firewall is in the way so temporarily stop it:
    Code:
    sudo ufw disable
    ** The default mechanism to convert netbios names to ip addresses is being foiled by "wins".

    Linux and Windows will both default to broadcasting their names to one another but on Linux it gets messed up but Samba allows you to prioritize this by adding an option - right under the workgroup line in /etc/samba/smb.conf:
    Code:
    name resolve order = bcast host lmhosts wins
    Then restart smbd and nmbd again.

    But I tell you life is short so if you keep having issues with Samba / Networking then why not set the Windows machine to have a static ip address and access it that way. You can bookmark it in Nautilus when you get access so you don't have to remember it's address.

    I just set up a home network for someone with Win / Lin / OSX / iOS components and the easiest thing is to add the following utility to the Windows machine: http://support.apple.com/kb/DL999 . And make sure port 5353/udp is open.

    Despite it's name what it does is install the Windows equivalent of Avahi ( Bonjour in Apple products ). From that point on you access it by it's host-name.local regardless of it's ip address at that moment and then bookmark that if you want:
    Code:
    nautlus smb://host-name.local
    Linux and OSX respond to *.local queries by default and with the added package so will Windows.
    Last edited by Morbius1; March 23rd, 2013 at 11:56 PM.

  6. #6
    Join Date
    Dec 2009
    Beans
    5,355

    Re: Samba and Sharing with Windows...broken *again*?

    ERROR - for the life of me I can't figure out how to delete this extra post.
    Last edited by Morbius1; March 23rd, 2013 at 11:57 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •