Results 1 to 6 of 6

Thread: Firefox spell-check keeps changing language

  1. #1
    Join Date
    May 2008
    Location
    United Kingdom
    Beans
    4,265
    Distro
    Ubuntu 12.04 Precise Pangolin

    Firefox spell-check keeps changing language

    I am in the UK, and so I have my Firefox spell-checker set to "English (United Kingdom)".

    However, frequently I find a word highlighted as misspelled, and discover that Firefox has reset my spell-checker to "English (Canadian)". (Frustratingly, it has just done it again!)

    This is only a minor irritation, of course, but how can I stop Firefox from doing this?
    Firefox spell-checker.png
    Last edited by Paddy Landau; March 23rd, 2013 at 01:38 PM.
    Problems with WINE?
    Full Circle Magazine :: Confused "allot"? :: Cheap Linux stickers
    In my day, we had outdoors in which to run, play, and socialise. Now we have computers to do those.

  2. #2
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,505
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Firefox spell-check keeps changing language

    Quote Originally Posted by Paddy Landau View Post
    I am in the UK, and so I have my Firefox spell-checker set to "English (United Kingdom)".

    However, frequently I find a word highlighted as misspelled, and discover that Firefox has reset my spell-checker to "English (Canadian)". (Frustratingly, it has just done it again!)

    This is only a minor irritation, of course, but how can I stop Firefox from doing this?
    Firefox spell-checker.png
    Code:
    Edit-Preferences-Content-Languages
    And delete the ones you don't want.
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  3. #3
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,505
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Firefox spell-check keeps changing language

    Quote Originally Posted by Paddy Landau View Post
    I am in the UK, and so I have my Firefox spell-checker set to "English (United Kingdom)".

    However, frequently I find a word highlighted as misspelled, and discover that Firefox has reset my spell-checker to "English (Canadian)". (Frustratingly, it has just done it again!)

    This is only a minor irritation, of course, but how can I stop Firefox from doing this?
    Firefox spell-checker.png
    Code:
    Edit-Preferences-Content-Languages
    And delete the ones you don't want.

    You may also have to manually delete the unwanted Dictionary files from your system.

    Also in Firefox "about:config" look for the key "spellchecker.dictionary" and reset it (if necessary).

    Another solution is: https://support.mozilla.org/en-US/questions/953907
    Last edited by dcstar; March 23rd, 2013 at 07:16 AM.
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  4. #4
    Join Date
    May 2008
    Location
    United Kingdom
    Beans
    4,265
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Firefox spell-check keeps changing language

    Quote Originally Posted by dcstar View Post
    Edit-Preferences-Content-Languages
    That section already had what I wanted:
    Code:
    English/United Kingdom [en_gb]
    English [en]
    Quote Originally Posted by dcstar View Post
    Also in Firefox "about:config" look for the key "spellchecker.dictionary" and reset it (if necessary).
    That was en_CA, which explains the problem (but what set it to en_CA in the first place?). I reset it to en_GB. Strangely, restarting Firefox did not solve the problem, but restarting the computer did!

    So, that solved the problem, thank you. If it should resurface, I'll have a look at the other options you gave.
    Problems with WINE?
    Full Circle Magazine :: Confused "allot"? :: Cheap Linux stickers
    In my day, we had outdoors in which to run, play, and socialise. Now we have computers to do those.

  5. #5
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,505
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Firefox spell-check keeps changing language

    Quote Originally Posted by Paddy Landau View Post
    .........
    That was en_CA, which explains the problem (but what set it to en_CA in the first place?). I reset it to en_GB. Strangely, restarting Firefox did not solve the problem, but restarting the computer did!

    So, that solved the problem, thank you. If it should resurface, I'll have a look at the other options you gave.
    The latest versions of Linux Firefox also broke my Australian spelling settings, I'd say someone made a mistake........
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  6. #6
    Join Date
    May 2008
    Location
    United Kingdom
    Beans
    4,265
    Distro
    Ubuntu 12.04 Precise Pangolin

    Thumbs down Re: Firefox spell-check keeps changing language

    And it has just happened again, today! So weird!

    Fixing the spellchecker.dictionary in about:config fixed it. Again.

    Do you know if there is a bug reported for this?
    Problems with WINE?
    Full Circle Magazine :: Confused "allot"? :: Cheap Linux stickers
    In my day, we had outdoors in which to run, play, and socialise. Now we have computers to do those.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •