Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: keyboard layout choices does not appear in icon-bar

  1. #11
    Join Date
    Jul 2009
    Location
    CyberspacEastEngland
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: keyboard layout choices does not appear in icon-bar

    Thanx zika might do that

    I am just wondering whether i forgot to install something or other
    but from past installs i cannot remember adding anything; simply adding languages to Keyboard layout was always enough; no doubt it will all become clear soon one way or the other

    i surely cannot be the only guy trying to add layouts with fallback; wonder how the others are faring?
    Linux is Latin for off-the-beaten-track [◄►] ● Is there Voodoo in the machine?
    ShanArt ● Mark as SolvedXmms

  2. #12
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,854
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: keyboard layout choices does not appear in icon-bar

    Quote Originally Posted by shantiq View Post
    Thanx zika might do that

    I am just wondering whether i forgot to install something or other
    but from past installs i cannot remember adding anything; simply adding languages to Keyboard layout was always enough; no doubt it will all become clear soon one way or the other

    i surely cannot be the only guy trying to add layouts with fallback; wonder how the others are faring?
    There is a thread about that that I've started long ago... If I understand correctly, You are having trouble adding a new language/layout...? If so, You might want to search for that thread of mine... No solution, sadly, yet, that I've found...
    Last edited by zika; March 21st, 2013 at 06:20 PM.

  3. #13
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: keyboard layout choices does not appear in icon-bar

    This need some effort of that OP to understand that config change with the packages updating. Its the case about gnome-fallback with is deprecated and replaced by gnome-classic (gnome-shell sub DE). The keyboard icon was pushed by ibus, but again i says "was".
    Thats it, i've explained how the system have changed. Its up to that OP to accept it or not.

  4. #14
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: keyboard layout choices does not appear in icon-bar

    Until that bug is fixed, you can use setxkbmap. See this list to find which short description to use (in 12.04 LTS but maybe the same in 13.04)
    Code:
    less /usr/share/X11/xkb/rules/base.xml
    Code:
    setxkbmap gb
    Code:
    setxkbmap fr
    Code:
    setxkbmap ru
    Last edited by sudodus; March 21st, 2013 at 06:55 PM. Reason: in 12.04 LTS but maybe the same in 13.04

  5. #15
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,854
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: keyboard layout choices does not appear in icon-bar

    Quote Originally Posted by sudodus View Post
    Until that bug is fixed, you can use setxkbmap. See this list to find which short description to use (in 12.04 LTS but maybe the same in 13.04)
    Code:
    less /usr/share/X11/xkb/rules/base.xml
    Code:
    setxkbmap gb
    Code:
    setxkbmap fr
    Code:
    setxkbmap ru
    Or You could put all hat in one line and choose key to change between them...
    I use:
    Code:
    /usr/bin/setxkbmap -option lv3:ralt_switch,grp:sclk_toggle,grp_led:scroll,eurosign:5 rs,us,rs -variant latin, altwin:swap_lalt__lwin, caps:super

  6. #16
    Join Date
    Jul 2009
    Location
    CyberspacEastEngland
    Beans
    Hidden!
    Distro
    Ubuntu 13.10 Saucy Salamander

    keyboard layout indicator 13.04 gkrellm; gkrellm-xkb;

    ok thanx for these great suggestions [will investigate the commandline/hotkey solutions; they look excellent]




    just found another gui route here

    apparently been an issue for a while see


    keyboard layout gkrellm.png The trick or workaround is to install gkrellm-xkb, run gkrellm and turnoff all monitors except xkb [Thanx to Robotron for the idea]

    This is done quite easily; once loaded click on plugins and allow xkb; click on Builtins and untick them all one by one
    Position the applet where wanted and allow 'remember screen location' then to go and add to startup apps


    This is to me a perfectly satisfactory solution .
    Marked as solved [hhhhhmmm how to do this on new Forum?]
    Last edited by shantiq; March 22nd, 2013 at 10:17 PM.
    Linux is Latin for off-the-beaten-track [◄►] ● Is there Voodoo in the machine?
    ShanArt ● Mark as SolvedXmms

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •