Results 1 to 10 of 10

Thread: DVI Output + Onboard HDMI how to?

Hybrid View

  1. #1
    Join Date
    Mar 2013
    Beans
    5

    DVI Output + Onboard HDMI how to?

    Hello, im extremely new to Ubuntu, just installed it and i loaded the Nvidia Drivers for my GTS450 which has an non working HDMI output. In Windows i have extended the screen from my monitor to my Samsung TV. The LG Monitor is connected to my GTS450 DVI output and my TV is connected to my Motherboards HDMI output and it works just fine. How can i get this set-up in Ubuntu. Thanks in advance for your help. This is my first Thread in Ubuntu Forums.

  2. #2
    Join Date
    Apr 2007
    Location
    Kent, England
    Beans
    337
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: DVI Output + Onboard HDMI how to?

    My GT520 has to have the TV turned on and on the HDMI input before you bootup as it need to "see" the monitor at boot.
    In system tools Administration you will find "Nvidia X server setting" where you can set up the screens etc

  3. #3
    Join Date
    Mar 2013
    Beans
    5

    Re: DVI Output + Onboard HDMI how to?

    Thanks I looked there but it the thing is the HDMI in my GTS450 is dead so in windows i have to use my onboard HDMI output instead. I can extend my screen to the TV but not via the Nvidia Control Panel (Win). I have to do it via the normal menu (left click in background - properties). Is this possible in Ubuntu? 2 different video cards one ONboard HDMI output and a monitor via DVI and still extend the screens?

  4. #4
    Join Date
    Mar 2011
    Location
    19th Hole
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: DVI Output + Onboard HDMI how to?

    Hi and welcome to the forums.

    Quote Originally Posted by lolocoian View Post
    ...i have to use my onboard HDMI output instead... Is this possible in Ubuntu? 2 different video cards one ONboard HDMI output and a monitor via DVI and still extend the screens?
    The short answer is "no". Not with all of the eye candy at any rate. You may be able to kludge something together using Xinerama (I've never tried it), but you won't have compiz, therefore no Unity 3D. Linux support for spanning the DE across multiple video cards is not good. Spanning across the same video card works well but the choke point is multiple cards.

    If you want to pursue this further, you need to post far more info. Please read through this sticky and post the recommended output defining your hardware. However, I should alert you that it likely won't change the answer. With the price of video cards these days, why not just buy a new or used card that supports dual channels: DVI & HDMI? 512 MB is likely all you need unless you are a gamer. Probably available for us little as $20 on ebay.
    Newb: How far must I jump to clear the ledge halfway down?
    Guru: It's bad to jump off cliffs. Let's look at better options.
    Newb: Stop harping about "best practices" and just let me jump.


  5. #5
    Join Date
    Mar 2013
    Beans
    5

    Re: DVI Output + Onboard HDMI how to?

    Ok, i changed my video card to a GTS250 i have now set up the twinview and i have the monitor extended! but im missing audio output thru HDMI. and i want to trim the screen a bit so it fits just right. Any Ideas?

  6. #6
    Join Date
    Mar 2011
    Location
    19th Hole
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: DVI Output + Onboard HDMI how to?

    Will have to research the audio aspect as I funnel all audio through system audio rather than HDMI.

    Do you need twinview? Did you install the proprietary driver? If so, does your card support simply bridging your Desktop from one display to the next without twinview? This would be simpler, which is always better.

    By trimming screen, I take it that you mean the edges of your desktop are not visible due to TV overscan? If so, then the solution is to turn off overscan on your TV. Most TVs will have a setting to do this, but it is called different things by each manufacturer. On my Sharp it's called "dot-for-dot". On others it may be called "computer mode" or similar. You will have to read your TV docs to see.

    If this doesn't work, you can install the proprietary driver and use nvidia's overscan compensation mode in the N-Vidia Settings Manager app. Some drivers will have this option, some won't depending on your card and the driver you installed. If no such option, you can also try:
    Code:
    sudo apt-get install nvtv
    which might allow you to set overscan on (I've never used it, so you will have to go through the man page, learn and configure it yourself).
    Newb: How far must I jump to clear the ledge halfway down?
    Guru: It's bad to jump off cliffs. Let's look at better options.
    Newb: Stop harping about "best practices" and just let me jump.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •