Results 1 to 8 of 8

Thread: must install as root....?

  1. #1
    Join Date
    Mar 2013
    Beans
    6

    must install as root....?

    Hello,

    I am trying to get Ubuntu to play nice with the new Geforce GTX 690 graphics card.

    If there is another post for this, please just put it up. I know your time is valuable. I just didn't find one that fit for me.

    Here is a link to the 64 bit driver http://www.nvidia.in/object/linux-di...driver-in.html


    Here is a copy of what I put in my terminal....


    kiteboat@kiteboat-System-Product-Name:~/Desktop$ ./NVIDIA-Linux-x86_64-295.49.run
    Verifying archive integrity... OK
    Uncompressing NVIDIA Accelerated Graphics Driver for Linux-x86_64 295.49............................................ .................................................. .................................................. .........
    nvidia-installer: Error opening log file '/var/log/nvidia-installer.log' for writing (Permission denied); disabling logging.

    Then it tells me Error: Must be installed as root

    I don't know what I am doing enough to play with root by myself.

    What do I do?

  2. #2
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: must install as root....?

    The method of temporarily gaining "root" access generally recommended here on the forum is through the "sudo" command, as described here: https://help.ubuntu.com/community/RootSudo

    If you have any questions, feel free to ask.
    Forum DOs and DON'Ts
    Never assume that information you find using a search engine is up-to-date.

  3. #3
    Join Date
    Mar 2013
    Beans
    6

    Re: must install as root....?

    Thanks lisati

    I tried everything again and typed in "sudo" before it. Now I got the following....

    ERROR: You appear to be running an X server; please exit X before
    installing. For further details, please see the section INSTALLING
    THE NVIDIA DRIVER in the README available on the Linux driver
    download page at www.nvidia.com.

  4. #4
    Join Date
    Dec 2010
    Location
    Fukuoka, Japan
    Beans
    1,062
    Distro
    Kubuntu 14.04 Trusty Tahr

    Re: must install as root....?

    You need to kill x server first.
    http://askubuntu.com/questions/13105...t-the-x-server

    This will drop you into a command line where you can then install your new driver.

  5. #5
    Join Date
    Jan 2013
    Beans
    525

    Re: must install as root....?

    Wait, you need a more up to date driver. 295 is too old. Use 310 series instead.

  6. #6
    Join Date
    Mar 2013
    Beans
    6

    Re: must install as root....?

    Right. I am trying to kill x server. For some reason it is not regocinizing my username and password and I can't log in. I am putting in the same username and pword I used when I installed Ubuntu.
    Am I missing something? I am using the same username and password that I log into the computer when I start it up?

  7. #7
    Join Date
    Jun 2008
    Location
    South Africa
    Beans
    39
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: must install as root....?

    Should be yes, I would suggest that you go to a terminal while you are still in your normal session and type:

    Code:
    whoami
    just to make sure you have the right username.

  8. #8
    Join Date
    Mar 2013
    Beans
    6

    Re: must install as root....?

    thank you all. I fixed it. I just reformated my hard drives, started clean and installed the latest and greatest versions of everything needed. I'm good. Except now the sound doesn't work.......

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •