Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: [HOWTO:] Grub set it delay of 1 and cannot load xubuntu to fix it!

Hybrid View

  1. #1
    Join Date
    Aug 2011
    Location
    Australia
    Beans
    94
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Thumbs up [HOWTO:] Grub set it delay of 1 and cannot load xubuntu to fix it!

    Hi, I was messing with my grub a few weeks ago and I decided to set the delay to 1 which would give me enough time to quickly press an arrow and interfere with the timer. Unfortunately 1 might as well be 0 and my Grub which has Xubuntu and windows will always load windows. I am unable to run xubuntu and it had important files on it. Holding down either or both shifts or pressing escape will not do anything. No matter what, I cannot seem to load xubuntu. I have a usb with Xubuntu 12.04 boot thingo on it and I tried booting with xubuntu and modifying it. It did not work. I cannot access my files on xubuntu and I badly need them soon.

    Please help me as soon as possible.

    Thanks for any help,
    Josh.


    Thread has been solved!
    Here is the quote/tutorial that helped me:
    Quote Originally Posted by steeldriver View Post
    You would need to chroot into your installed system in order to update-grub from a live cd, I think:

    http://askubuntu.com/questions/14524...-from-a-livecd

    Otherwise even if you mount your installed system and modify its /etc/default/grub, that change wont be written into the bootloader
    Thanks a lot to all who helped, I hope this thread helps others in the future!

    Thanks,
    Josh
    Last edited by JoshuaMiller0; March 24th, 2013 at 12:59 AM. Reason: SOLVED!

  2. #2
    Join Date
    Sep 2012
    Location
    Gnome12o4/14o4
    Beans
    Hidden!

    Re: [Urgent!] Grub set it delay of 1 and cannot load xubuntu to fix it!

    What happens if you hold down the "Down Arrow" key during boot?

    You could also mount your HDD partition and edit /etc/default/grub using the live CD.

    http://ubuntuforums.org/showthread.php?t=1650021

  3. #3
    Join Date
    Aug 2011
    Location
    Australia
    Beans
    94
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: [Urgent!] Grub set it delay of 1 and cannot load xubuntu to fix it!

    Quote Originally Posted by ibjsb4 View Post
    What happens if you hold down the "Down Arrow" key during boot?

    You could also mount your HDD partition and edit /etc/default/grub using the live CD.

    http://ubuntuforums.org/showthread.php?t=1650021
    Holding down up or down arrow or hitting it at about 3 presses per seconds did not work. Nor did holding down shift while doing it, or any combination of anything.

    I used the live usb (cd) to "just boot" and I when I opened /etc/default/grub it had an unchanged version of the file with the delay set to the default of 10. Modifying this (with sudo update-grub) did not change anything.

    Bump.
    I accidentally erased my hard drive and windows in my first ever attempt at installing Ubuntu.

  4. #4
    Moose is offline Gee! These Aren't Roasted!
    Join Date
    Aug 2012
    Location
    Australia
    Beans
    Hidden!
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: [Urgent!] Grub set it delay of 1 and cannot load xubuntu to fix it!

    Delete the original file and then just edit the current file?

  5. #5
    Join Date
    Aug 2011
    Location
    Australia
    Beans
    94
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: [Urgent!] Grub set it delay of 1 and cannot load xubuntu to fix it!

    Quote Originally Posted by Moose View Post
    Delete the original file and then just edit the current file?
    I cannot find the original file (the one with the 1 second delay). When I type /etc/default/grub (or whatever) it opens a different grub config (with the default - 10 second delay.)

    Please tell me how I can find and delete or modify the original file (1 delay)
    I accidentally erased my hard drive and windows in my first ever attempt at installing Ubuntu.

  6. #6
    Join Date
    Sep 2012
    Location
    Gnome12o4/14o4
    Beans
    Hidden!

    Re: [Urgent!] Grub set it delay of 1 and cannot load xubuntu to fix it!

    And you did mount your HDD/partition in Nautilus and went to default/grub?

  7. #7
    Join Date
    Aug 2011
    Location
    Australia
    Beans
    94
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Exclamation Re: [Urgent!] Grub set it delay of 1 and cannot load xubuntu to fix it!

    Quote Originally Posted by ibjsb4 View Post
    And you did mount your HDD/partition in Nautilus and went to default/grub?
    Umm, I have no idea. Originally I opened the grub file using terminal and modified it and did sudo update-grub.

    I then did the same thing with nothing happening on xubuntu running off my usb. I don't know if I mounted anything, so I doubt it.

    Bump.
    I accidentally erased my hard drive and windows in my first ever attempt at installing Ubuntu.

  8. #8
    Join Date
    Aug 2011
    Location
    Australia
    Beans
    94
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: [Urgent!] Grub set it delay of 1 and cannot load xubuntu to fix it!

    Quote Originally Posted by JoshuaMiller0 View Post
    Umm, I have no idea. Originally I opened the grub file using terminal and modified it and did sudo update-grub.

    I then did the same thing with nothing happening on xubuntu running off my usb. I don't know if I mounted anything, so I doubt it.

    Bump.
    That looks like exactly what I need. Thanks, I will try this and get back to you (mark as solved hopefully...) as soon as I get home.

    Edit: Hopefully I can figure out where xubuntu is... (sda3...)
    I accidentally erased my hard drive and windows in my first ever attempt at installing Ubuntu.

  9. #9
    Join Date
    Apr 2012
    Beans
    5,402

    Re: Grub set it delay of 1 and cannot load xubuntu to fix it!

    You would need to chroot into your installed system in order to update-grub from a live cd, I think:

    http://askubuntu.com/questions/14524...-from-a-livecd

    Otherwise even if you mount your installed system and modify its /etc/default/grub, that change wont be written into the bootloader

  10. #10
    Join Date
    Aug 2011
    Location
    Australia
    Beans
    94
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Unhappy Re: Grub set it delay of 1 and cannot load xubuntu to fix it!

    Quote Originally Posted by steeldriver View Post
    You would need to chroot into your installed system in order to update-grub from a live cd, I think:

    http://askubuntu.com/questions/14524...-from-a-livecd

    Otherwise even if you mount your installed system and modify its /etc/default/grub, that change wont be written into the bootloader
    I gave this a shot and you wouldn't believe the bad luck I was having.

    1. I could not find my usb with xubuntu boot-loader on it
    2. I found a usb with Ubuntu boot-loader on it so I plugged it into the computer and got a xubuntu boot-loader installer running
    3. As I waited patiently I found that I was using an ancient USB 2.0 device in a USB 3.0 port: can you get any slower?!
    4. It finally finished and I booted my computer with it.
    5. I hit ctrl + alt + t and the explorer process broke
    6. My faulty USB shifted slightly and it disconnected, stopping the process from restarting or anything from working.
    7. I tried to shut down the computer safely and it ended up in an endless loop.
    8. I was forced to hold the power button down until it went off.
    9. The bootloader was then broken.


    I guess I better give this another shot...
    But USB is such a slow connection...
    I accidentally erased my hard drive and windows in my first ever attempt at installing Ubuntu.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •