Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Must of munged something in network connection

  1. #1
    Join Date
    Mar 2010
    Beans
    360

    Must of munged something in network connection

    Ubuntu 12.04 using the LXDE desktop. We have a mixed wired and wireless network here, and I prefer to give wired devices fixed IP addresses. Most of the machines are Windows and assigning fixed IP addresses on them is easy, but I've run into trouble doing so on this 12.04 box.

    I edited /etc/network/interfaces to read:
    Code:
    auto loiface lo inet loopback
    
    
    auto eth0
    iface eth0 inet static
            address 192.168.1.110
            netmask 255.255.255.0
            gateway 192.168.1.1
            dns-nameservers 8.8.8.8 192.168.1.1
    And rebooted the machine. The edit seems to have performed the desired function: the IP address is now 192.168.1.110. Ifconfig returns:
    Code:
    admin@CCD6:~$ ifconfig
    eth0      Link encap:Ethernet  HWaddr 00:13:20:c5:eb:0e  
              inet addr:192.168.1.110  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::213:20ff:fec5:eb0e/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:4548 errors:0 dropped:0 overruns:0 frame:0
              TX packets:2818 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:3462392 (3.4 MB)  TX bytes:419965 (419.9 KB)
    
    
    lo        Link encap:Local Loopback  
              inet addr:127.0.0.1  Mask:255.0.0.0
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:12 errors:0 dropped:0 overruns:0 frame:0
              TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:720 (720.0 B)  TX bytes:720 (720.0 B)
    But there used to be a little icon on the toolbar in the lower right corner, showing a plugged-in Ethernet connection, it's now gone. Network Connections doesn't show anything under the "Wired" tab. And right-clicking where the little icon used to be brings up:

    [x] Enable Network
    Connection Information
    Edit Connections

    "Connection Information" says "no valid active connections found"

    AND YET I am presently connected to the Internet else I could not send this.

    So clearly I've done a Bad Thing. Thoughts?
    Last edited by Rocket J Squirrel; March 20th, 2013 at 12:45 AM. Reason: To mark as "Solved"

  2. #2
    Join Date
    Jan 2006
    Location
    Not heaven... Iowa
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Must of munged something in network connection

    I've been away from the networking side for awhile. At least a few versions ago, Network Manager would not touch interfaces configured via /etc/network/interfaces. The interface still got configured, but NM played dumb. There should be an option to make NM deal w/ the interface.
    Another option: You should be able to set a fixed address via Network Manager.

    I presume it's a typo that
    auto lo
    iface lo inet loopback
    became
    auto loiface lo inet loopback
    Last edited by Iowan; March 19th, 2013 at 02:43 AM.
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad] [Sub-forum]
    IRC channel: #ubuntu-us-ia on irc.freenode.net

  3. #3
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

  4. #4
    Join Date
    Mar 2010
    Beans
    360

    Re: Must of munged something in network connection

    Yep, Edit Connections and do it via Network Manager.
    B-but, Edit Connections displays the same screen as Network Manager: Neither show anything under the "Wired" tab.

    I presume it's a typo thatauto lo
    iface lo inet loopback


    became
    auto loiface lo inet loopback
    Yup. When I paste things between the CODE tags, they often display (after submitting) with lf/cr's missing.

  5. #5
    Join Date
    Apr 2012
    Beans
    5,396

    Re: Must of munged something in network connection

    If you define an interface via /etc/network/interfaces, then it will disappear from the network manager applet - they are separate services, and the network-manager service is configured by default to ignore interfaces from the networking service ('[ifupdown] managed=false')

  6. #6
    Join Date
    Mar 2010
    Beans
    360

    Re: Must of munged something in network connection

    Steeldriver -- thanks for that explanation.

    Question: if a fellow wants to assign a static IP address, is there a way to do that in a way that doesn't cause NM to go "hands off"?

  7. #7
    Join Date
    Apr 2012
    Beans
    5,396

    Re: Must of munged something in network connection

    Yes - just go to Edit Connections... on the main menu --> select the connection you want the static address for (Wired or Wireless) --> Edit --> IPv4 Settings tab and change the drop down from Automatic (DHCP) to Manual - then add the desired static IP (and other info such as DNS if appropriate)

  8. #8
    Join Date
    Mar 2010
    Beans
    360

    Re: Must of munged something in network connection

    Yes - just go to Edit Connections... on the main menu --> select the connection you want the static address for (Wired or Wireless) --> Edit --> IPv4 Settings tab and change the drop down from Automatic (DHCP) to Manual - then add the desired static IP (and other info such as DNS if appropriate)
    Seriously? I don't know why I didn't consider that right away. I just Googled around and found various hand-edits for /etc/network/interfaces to force a static IP.

    Shoot. Okay, now that Network Manager no longer wants to have anything to do with managing the network, because I hand-edited /etc/network/interfaces, how do I get NM to forgive me and be willing to play again?

    How about just returning it to its original condition, reading
    Code:
    auto lo
    iface lo inet loopback

  9. #9
    Join Date
    Apr 2012
    Beans
    5,396

    Re: Must of munged something in network connection

    yes that should do it - you may need to restart the service(s) after reverting the file

    Code:
    sudo service networking restart
    sudo service network-manager restart
    (or just reboot)

  10. #10
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Must of munged something in network connection

    Quote Originally Posted by steeldriver View Post
    Yes - just go to Edit Connections... on the main menu --> select the connection you want the static address for (Wired or Wireless) --> Edit --> IPv4 Settings tab and change the drop down from Automatic (DHCP) to Manual - then add the desired static IP (and other info such as DNS if appropriate)
    Exactly.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •