Results 1 to 2 of 2

Thread: Samba and symlinks - 12.04

  1. #1
    Join Date
    Mar 2013
    Beans
    2

    Question Samba and symlinks - 12.04

    Hi,

    I've just been reading old forum posts on how to get symlinks working with samba. Found that I needed to edit the /etc/smb.conf file and add the following entries into the Global section:

    follow symlinks = yes
    wide links = yes
    unix extensions = no

    And yes, this did allow my windows box to access the symlink directories.

    I also read that there are security issues with enabling symlinks. Another post recommended moving the the first two entries to the specific directory share entries, which I did and the symlinks still worked.

    The problem I have found is that if I later use the system-config-samba gui application to make any changes then it comments out the line 'follow symlinks = yes' with a semi colon. The application does this even if it does not need to edit the smb.conf file for any other actions, such as when setting a samba user's password. Thus my symlinks become instantly unavailable again, requiring me to sudo uncomment those entries and restart the smbd.

    Is there any way I can prevent this from happening?

  2. #2
    Join Date
    Mar 2013
    Beans
    2

    Re: Samba and symlinks - 12.04

    It seems I got this slightly wrong:

    for me it was the 'wide links = yes' option that was requires as my symlinks were linking outside of the samba share directory.

    In contradiction to the documentation at the head of the smb.conf file, when commented out by a semicolon the option entry means that this is the default value. The manual verified that the default is 'follow symlinks = yes'. However 'wide links' is 'no', so I needed that.

    Andy

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •