Thanks very much for the assistance.

I have set the IPV6 setting to "ignore" from within the network manager gui, so I'm assuming that this is now disabled.
I have changed the MTU as suggested.
Both of these suggestions made no difference.

My original NIC (onboard) is as follows (output from lspci | grep Ethernet):
00:0a.0 Ethernet controller: NVIDIA Corporation MCP77 Ethernet (rev a2)


My second NIC (PCI card) has now been removed, but it is a 3Com chip on the card so I'm assuming that it uses a different driver to the onboard NIC.


I have installed and run mii-tool, but get an error as follows:
SIOCGMIIPHY on 'eth0' failed: Operation not supported


Additional information from ethtool:
Settings for eth0:
Supported ports: [ MII ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Supported pause frame use: No
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Full
Advertised pause frame use: No
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: MII
PHYAD: 3
Transceiver: external
Auto-negotiation: on
Supports Wake-on: g
Wake-on: g
Link detected: yes


So I don't know why I can't change the speed / duplex of the NIC using mii-tool.

Really stumped now