Results 1 to 7 of 7

Thread: Boot Help Please!

Threaded View

  1. #1
    Join Date
    Jun 2011
    Beans
    13

    Boot Help Please!

    No boot device found when trying to boot. I was getting the grub> prompt, but then I tried "Boot Repair" and now nothing. Boot Repair had me issue the following commands.:

    Code:
    sudo chroot "/mnt/boot-sav/sda2" dpkg --configure -a
    sudo chroot "/mnt/boot-sav/sda2" apt-get install -fy
    sudo chroot "/mnt/boot-sav/sda2" apt-get purge -y --force-yes grub*-common shim*
    sudo chroot "/mnt/boot-sav/sda2" apt-get install -y --force-yes grub-efi

    When done, it repsonded with:
    Boot successfully repaired.

    Please write on a paper the following URL:
    http://paste.ubuntu.com/5621586/
    Now I can't even get the grub prompt! I can get into my ubuntu drive from a live CD and the files look ok.

    One thing I noticed when doing the Boot Repair was this terminal message:
    Creating config file /etc/default/grub with new version
    Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables.
    Try 'modprobe efivars' as root.
    Fatal: Couldn't open either sysfs or procfs directories for accessing EFI variables.
    Try 'modprobe efivars' as root.
    Installation finished. No error reported.
    Setting up grub-efi (1.99-21ubuntu3.9) ...
    Please help! What should I try next? I'm a newbie so please be explicit! Thank you!
    Last edited by Tony T; March 19th, 2013 at 07:27 PM. Reason: fixed fonts, added code tags

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •