Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Gimp GIT version

  1. #1
    Join Date
    Oct 2010
    Beans
    140

    Gimp GIT version

    I've never had issues compiling software on any distro or windows/osx but gimp just does not want to be compiled...
    Has anyone successfully compiled gimp's git ver on ubuntu 13.04?

  2. #2
    Join Date
    Jun 2007
    Beans
    12,908

    Re: Gimp GIT version

    pretty simple, you just need newer gegl & babl.
    Am attaching the set of commands I use here, feel free to use as is or adjust install prefix.
    If adjusting prefix make sure to change all instances alike.
    (- I install all to /opt/gimp-git, not hard to create a .desktop & or alias to run from there

    If you happen to have a static ffmpeg in path then remove before build, can be returned after

    If any questions ask, some comment in attached

    Edit - had 1 small miss in attached - replaced (the ./configure on gegl if needed had wrong prefix, also adjusted checkinstall for pkgname
    (should have just posted in thread, started but the autosave was being a pita for some reason
    Attached Files Attached Files
    Last edited by mc4man; March 17th, 2013 at 09:20 AM.

  3. #3
    Join Date
    Oct 2010
    Beans
    140

    Re: Gimp GIT version

    Hey thanks man! I'll let you know if it works, I just got some other stuff to get installed.. (Getting DVD/Blu-ray playback was the first thing on my list since vlc 2.0 is borked without extra codecs)

  4. #4
    Join Date
    Jun 2007
    Beans
    12,908

    Re: Gimp GIT version

    I hope you got revised attached, was copying out of file from old install & decided to change prefix=, missed one...

  5. #5
    Join Date
    Jun 2007
    Beans
    12,908

    Re: Gimp GIT version

    Forgot something -
    If one wants they can keep both the repo & git version - in that case & if using checkinstall then change the pkgname -
    ex.
    Code:
    sudo checkinstall --backup=no --deldoc=yes --fstrans=no --deldesc=yes --delspec=yes --pkgversion=2.10 --pkgname=gimp-git

  6. #6
    Join Date
    Oct 2010
    Beans
    140

    Re: Gimp GIT version

    Yes, and gimp seems to be compiling this time around.
    But I've been hanging on "Copying files to the temporary directory..." for five minutes with gimp, that normal?

  7. #7
    Join Date
    Jun 2007
    Beans
    12,908

    Re: Gimp GIT version

    Quote Originally Posted by Rukiri View Post
    Yes, and gimp seems to be compiling this time around.
    But I've been hanging on "Copying files to the temporary directory..." for five minutes with gimp, that normal?
    5 min - no, never that long here
    if it doesn't complete soon then ctrl+c the terminal & try again - use the checkinstall command in post 5
    (or just use sudo make install

  8. #8
    Join Date
    Oct 2010
    Beans
    140

    Re: Gimp GIT version

    Everything installed correctly however I do not list gimp actually being installed...

  9. #9
    Join Date
    Jun 2007
    Beans
    12,908

    Re: Gimp GIT version

    Quote Originally Posted by Rukiri View Post
    Everything installed correctly however I do not list gimp actually being installed...
    see screen, I have the repo gimp & gimp-git installed

    Here I run from a launcher icon, if you need a .desktop, ask..
    Attached Images Attached Images

  10. #10
    Join Date
    Oct 2010
    Beans
    140

    Re: Gimp GIT version

    I think I found the problem and I probably just missed it as it's 2AM..
    Git version of babl seems to be 0.10 but gimp 2.10 requires 0.11, hmm, anyway to fix this?
    checking for BABL... no
    configure: error: Package requirements (babl >= 0.1.11) were not met:

    Requested 'babl >= 0.1.11' but version of babl is 0.1.10

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •