Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: Cant play videos with mplayer/mplayer2

  1. #11
    Join Date
    Jan 2010
    Location
    India
    Beans
    Hidden!
    Distro
    Ubuntu Mate 15.04 Vivid Vervet

    Re: Cant play videos with mplayer/mplayer2

    Code:
    tux@mypc:~$ df
    Filesystem     1K-blocks     Used Available Use% Mounted on
    /dev/sda4       89514184 12503560  72463552  15% /
    udev             1016700        4   1016696   1% /dev
    tmpfs             410200      804    409396   1% /run
    none                5120        0      5120   0% /run/lock
    none             1025496       84   1025412   1% /run/shm
    /dev/sda2       61337596 30270280  31067316  50% /media/E6B8B6F8B8B6C5F9

    Code:
    root@PartedMagic:~# e2fsck -f /dev/sda4
    e2fsck 1.41.14 (22-Dec-2010)
    Pass 1: Checking inodes, blocks, and sizes
    Pass 2: Checking directory structure
    Pass 3: Checking directory connectivity
    Pass 4: Checking reference counts
    Pass 5: Checking group summary information
    /dev/sda4: 221081/5685248 files (0.3% non-contiguous), 3482530/22735360 blocks
    Then tried playing again but same thing.
    Ubuntu Mate 15.04
    free
    showing high ram usage ? Read this
    When people say "you've changed " there's a 95% chance that you just stopped acting the way they wanted you to.

  2. #12
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Cant play videos with mplayer/mplayer2

    The file system looks good, it did not cause the problem. We still hope it is a software error. So boot again from an external drive, but not from the parted magic rescue drive, but from the Ubuntu install drive (ideally from a version 12.04.2 drive). Run a live session and install the nvidia driver into the live session (using jockey-gtk).

    I don't remember if it is necessary to restart the graphics (the x-session) to get the new driver active, but in that case, start a text screen with ctrl + alt + F1 and from there run

    Code:
    sudo service lightdm stop
    Code:
    sudo service lightdm start
    You will probably find the graphic screen with ctrl + alt + F7

    Try to run mplayer/mplayer2 with vdpau in this live session. If it works, you can be sure there is a software error in your installed system.

  3. #13
    Join Date
    Jan 2010
    Location
    India
    Beans
    Hidden!
    Distro
    Ubuntu Mate 15.04 Vivid Vervet

    Re: Cant play videos with mplayer/mplayer2

    @sudodus

    I have a xubuntu 12.04 cd with me so it booted in live mode & started jockey-gtk but strangely it didn't detect my card.
    Ubuntu Mate 15.04
    free
    showing high ram usage ? Read this
    When people say "you've changed " there's a 95% chance that you just stopped acting the way they wanted you to.

  4. #14
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Cant play videos with mplayer/mplayer2

    I'll try with my old install CD (not sub-version .2). So I will be off-line for a while.

  5. #15
    Join Date
    Jan 2010
    Location
    India
    Beans
    Hidden!
    Distro
    Ubuntu Mate 15.04 Vivid Vervet

    Re: Cant play videos with mplayer/mplayer2

    Quote Originally Posted by sudodus View Post
    I'll try with my old install CD (not sub-version .2). So I will be off-line for a while.
    Okay.
    Ubuntu Mate 15.04
    free
    showing high ram usage ? Read this
    When people say "you've changed " there's a 95% chance that you just stopped acting the way they wanted you to.

  6. #16
    Join Date
    Jan 2010
    Location
    India
    Beans
    Hidden!
    Distro
    Ubuntu Mate 15.04 Vivid Vervet

    Re: Cant play videos with mplayer/mplayer2

    I just booted in Win7, played a game, played the same HD videos in WMP. CPU usage ranged from 5-22% so it means it is utilizing pure video hd (the equivalent of vdpau).
    Ubuntu Mate 15.04
    free
    showing high ram usage ? Read this
    When people say "you've changed " there's a 95% chance that you just stopped acting the way they wanted you to.

  7. #17
    Join Date
    Dec 2006
    Beans
    7,230

    Re: Cant play videos with mplayer/mplayer2

    Try reinstalling your nvidia driver and vdpau. As a sidenote: You might actually find that if you have a reasonably fast cpu hardware acceleration from the GPU is not such a big deal, although gaming tends to be a deal breaker for this. I have quite a fast processor:

    Code:
    andrew@skamandros~$ uname -p
    AMD FX(tm)-8350 Eight-Core Processor
    and for video clips etc vdpau does not seem to be critical.
    You think that's air you're breathing now?

  8. #18
    Join Date
    Jun 2007
    Beans
    14,331

    Re: Cant play videos with mplayer/mplayer2

    Maybe ck. your vdpau status -

    sudo apt-get install vdpauinfo
    vdpauinfo

  9. #19
    Join Date
    Dec 2006
    Beans
    7,230

    Re: Cant play videos with mplayer/mplayer2

    Quote Originally Posted by sudodus View Post
    This alias works for me now with an up-to-date Ubuntu 12.04.2 running lubuntu-desktop
    Code:
    alias mplayervdpau='mplayer -vo vdpau -vc ffh264vdpau -lavdopts skiploopfilter=nonref -use-filename-title -fs'
    Which version of Ubuntu and the proprietary nvidia driver are you running?
    You might be interested in adding this to ~/.mplayer/config rather than running a bash alias? My own setting is reasonably conservative:

    Code:
    # If I use vdpau I prefer these video codecs:
    #--------------
    [vo.vdpau]
    vc=ffmpeg12vdpau,ffwmv3vdpau,ffvc1vdpau,ffh264vdpau,ffodivxvdpau,
    but you could add your own settings in as well. I do it this way as I do not necessarily want to run vdpau by default...
    You think that's air you're breathing now?

  10. #20
    Join Date
    Jan 2010
    Location
    India
    Beans
    Hidden!
    Distro
    Ubuntu Mate 15.04 Vivid Vervet

    Re: Cant play videos with mplayer/mplayer2

    I reinstalled Xubuntu. Vdpau is working now. Thanks to both.
    Ubuntu Mate 15.04
    free
    showing high ram usage ? Read this
    When people say "you've changed " there's a 95% chance that you just stopped acting the way they wanted you to.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •