Results 1 to 4 of 4

Thread: Firefox View Source change to Gedit won't work

  1. #1
    Join Date
    Mar 2013
    Beans
    5

    Firefox View Source change to Gedit won't work

    I have been trying unsuccesfully to change the default 'View Source' in Firefox to Gedit (to edit my web pages)
    I'm using Ubuntu 12.04 - please can anyone tell me where I've gone wrong?


    I entered about:config into the Firefox browser address bar, then scrolled down and double clicked -
    View-Source.editor.external to change its status to True

    Next, I double clicked the line underneath, i.e. View-Source.editor.path
    I entered: usr/bin/gedit
    (found by typing: which gedit into the Terminal)

    Alas: Firefox still does not recognise the change

    Please can anyone suggest what is wrong?

  2. #2
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Firefox View Source change to Gedit won't work

    Did you forget the leading "/" in the path.
    eg should be
    Code:
    /usr/bin/gedit
    Works here.

  3. #3
    Join Date
    Feb 2010
    Location
    WI USA
    Beans
    10,238
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Firefox View Source change to Gedit won't work

    I can only suggest restarting the browser if you have not. Make sure the setting didn't revert also.
    Infinite diversity in infinite combination.

    Ubuntu Documentation Search: Popular Pages
    Ubuntu: Security Basics
    Ubuntu: Manual

  4. #4
    Join Date
    Mar 2013
    Beans
    5

    Re: Firefox View Source change to Gedit won't work

    Quote Originally Posted by Frogs Hair View Post
    I can only suggest restarting the browser if you have not. Make sure the setting didn't revert also.


    Found my mistake! I inadvertantly put a space before the first slash of: /usr/bin/gedit

    Works fine now after restarting Firefox

    Thanks for the help.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •