Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Upgrade to 12.04... wireless not working...

  1. #11
    Join Date
    Mar 2010
    Location
    India
    Beans
    6,573
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Upgrade to 12.04... wireless not working...

    Uh.. oh.. just noticed something too obvious -
    Quote Originally Posted by etfjr View Post
    Code:
    **** NetworkManager.state ****
    
    [main]
    NetworkingEnabled=true
    WirelessEnabled=false
    WWANEnabled=true
    The highlighted part suggests to me that the wireless is not enabled in the nm drop down menu. Make sure "Enable Wireless" has a tick mark beside it.
    Last edited by varunendra; March 13th, 2013 at 04:31 AM.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

  2. #12
    Join Date
    Mar 2007
    Beans
    18

    Re: Upgrade to 12.04... wireless not working...

    Here's what I got when i tried that...

    I *think* my laptop has bluetooth, but I've NEVER used it, so I don't really know.


    Code:
    taylor@KA5NOM:~$ sudo modprobe -rfv iwl4965
    [sudo] password for taylor: 
    WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.backup, it will be ignored in a future release.
    rmmod /lib/modules/3.2.0-38-generic/updates/cw-3.6/iwl4965.ko
    rmmod /lib/modules/3.2.0-38-generic/updates/cw-3.6/iwlegacy.ko
    rmmod /lib/modules/3.2.0-38-generic/updates/cw-3.6/mac80211.ko
    rmmod /lib/modules/3.2.0-38-generic/updates/cw-3.6/cfg80211.ko
    taylor@KA5NOM:~$ sudo modprobe -v iwl-legacy bt_coex_active=Y
    WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.backup, it will be ignored in a future release.
    insmod /lib/modules/3.2.0-38-generic/updates/cw-3.6/cfg80211.ko 
    insmod /lib/modules/3.2.0-38-generic/updates/cw-3.6/mac80211.ko 
    insmod /lib/modules/3.2.0-38-generic/kernel/drivers/net/wireless/iwlegacy/iwl-legacy.ko bt_coex_active=Y
    FATAL: Error inserting iwl_legacy (/lib/modules/3.2.0-38-generic/kernel/drivers/net/wireless/iwlegacy/iwl-legacy.ko): Invalid argument
    taylor@KA5NOM:~$ sudo modprobe -v iwl4965 11n_disable=1
    WARNING: All config files need .conf: /etc/modprobe.d/alsa-base.backup, it will be ignored in a future release.
    insmod /lib/modules/3.2.0-38-generic/updates/cw-3.6/iwlegacy.ko 
    insmod /lib/modules/3.2.0-38-generic/updates/cw-3.6/iwl4965.ko 11n_disable=1
    taylor@KA5NOM:~$

  3. #13
    Join Date
    Mar 2007
    Beans
    18

    Re: Upgrade to 12.04... wireless not working...

    I can't find a tick box anywhere for this. There's no networking icon in the system tray and when I go in to the Settings menu, it says I must click the Administrator button, but it's greyed out...

    UGH...
    Taylor

  4. #14
    Join Date
    Mar 2007
    Beans
    18

    Re: Upgrade to 12.04... wireless not working...

    Quote Originally Posted by varunendra View Post
    Uh.. oh.. just noticed something too obvious -


    The highlighted part suggests to me that the wireless is not enabled in the nm drop down menu. Make sure "Enable Wireless" has a tick mark beside it.
    OK... out of desperation, I did a direct edit of this file and changed the value to true and did a reboot... now all is working fine with the wireless connection (I'm wireless right now...)

    There's still no (wireless) networking icon in the system tray, but that seems minor right now...
    Taylor

  5. #15
    Join Date
    Mar 2010
    Location
    India
    Beans
    6,573
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Upgrade to 12.04... wireless not working...

    Quote Originally Posted by etfjr View Post
    OK... out of desperation, I did a direct edit of this file and changed the value to true and did a reboot... now all is working fine with the wireless connection (I'm wireless right now...)
    Great!
    Lesson to myself : Never ignore minor or the obvious!

    By the way, aren't you the first user on the installation (admin)?

    Sometimes in my laptop, the nm-applet menu becomes unresponsive ("..click me anywhere you like, I won't do a thing.." type), in that case, I simply kill it from System Monitor, then run it again with-

    Alt+F2 > nm-applet

    Although the proper way is -
    Code:
    sudo service network-manager restart
    or
    Code:
    sudo service networking restart
    ..but these don't work for me, only killing > starting again does.
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •