Page 1 of 3 123 LastLast
Results 1 to 10 of 21

Thread: Administrator right to connect to wireless on 12.10

  1. #1
    Join Date
    Mar 2007
    Location
    fort frances.on.ca
    Beans
    31
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Administrator right to connect to wireless on 12.10

    I setup a user that doesn't have administrator rights on a laptop. When that user tries to connect to a wireless network, they get prompted for my password. How can they connect to a wireless network without making them admin?

  2. #2
    Join Date
    Nov 2004
    Location
    Saint Petersburg, Russia
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Administrator right to connect to wireless on 12.10

    have check "allow other users to connet"?

  3. #3
    Join Date
    Mar 2007
    Location
    fort frances.on.ca
    Beans
    31
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Administrator right to connect to wireless on 12.10

    No, I don't want a user to make global settings. That would need more rights than they have.

  4. #4
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Administrator right to connect to wireless on 12.10

    Quote Originally Posted by LLigetfa View Post
    No, I don't want a user to make global settings. That would need more rights than they have.
    I think you misunderstood what aim suggested.

    It is just a setting for a network to make (only) it available for all users. It does not extend their rights anymore than making them able to use that particular network.

    In the nm-applet drop-down menu, click "Edit Connections.." > goto "Wireless" tab > double-click the network you want to make accessible for all > in the bottom left corner of the settings box, put a tick in the checkbox that says "Available to all users..".
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

  5. #5
    Join Date
    Mar 2007
    Location
    fort frances.on.ca
    Beans
    31
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Administrator right to connect to wireless on 12.10

    The particular wireless SSID that my non-admin user wants to connect to is not on the list because it has never been connected to. The laptop is back in my office and the SSID is at my user's house. When he tries to connect at his house, he gets a "System policy prevents modification of network settings for all users" and he is prompted for my password which I'm not prepared to give him, nor am I prepared to go to his house with him so that I can connect and then make available to all users.

    I don't want him modifying settings for all users. If I did, I would just make him an admin. I just want him to be able to connect to his home SSID without admin rights.

    I found this bug report that suggests that the SSID can be manually entered but when I try it wants a keyring setup and it is way too complicated of a work-around for my users. All they (and I) want is to choose from the list of SSIDs.
    https://bugs.launchpad.net/ubuntu/+s...t/+bug/1077982

  6. #6
    Join Date
    Mar 2007
    Location
    fort frances.on.ca
    Beans
    31
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Administrator right to connect to wireless on 12.10

    So... nobody knows? Is this a problem only in 12.10? I don't understand how this could go unresolved for so long if that is the case.

    Should I give up on 12.10 and try 12.04? Can anyone say if this won't be a problem in 12.04?

  7. #7
    Join Date
    Apr 2012
    Beans
    6,179

    Re: Administrator right to connect to wireless on 12.10

    I've struggled with this several times in the past, just made another attempt and there does seem to be at least one workaround

    1. If you just select one of the available networks from the nm-applet list and try to connect to it, a non-privileged user will get a popup saying "System policy prevents modification of networks for all users". The only option is to 'Cancel'. This seems to be because the default for any connection creation operation is 'Available for all users' which implies write permission to the /etc/NetworkManager directory

    2. Likewise if you select Edit connections --> Wireless --> Add, the dialog box comes up with the 'Available to all users' box checked - and greyed out! With this box checked, it is impossible for a non-privileged user to save the new connection.

    3. The 'Available to all users' box only becomes editable after you type something into the SSID box - you can then uncheck it and fill in the SSID and any Wireless Security tab / IPv4 / IPv6 details

    4. You should then be able to go back and select the SSID from the list, and it *should* connect - if not, make sure the 'Connect automatically' box is checked and then try disabling and re-enabling wireless

    I just tried this as an unprivileged user on my laptop running 12.04 and it does seem to work - yes it's very confusing and ugly, even the developers seem confused by it --> https://bugs.launchpad.net/ubuntu/+s...er/+bug/964705

    You will find another workaround on the web that involves modifying the network-manager polkit file - however I *think* that method allows unprivileged users to modify *any* connection (not just to add their own) and possibly allows them to see any stored wireless passphrases.

  8. #8
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Administrator right to connect to wireless on 12.10

    Have you tried to search for "group management" in Linux?

    I didn't find time to do so but I am sure there must be an existing group for network users or a way to create such a group.

    I know that there exists a "dip" user group that allows users to use dial up devices like modem, but I'm not sure it can do the same for wireless interface. But you may try that (I have no wireless networks around to try myself) -
    Code:
    sudo adduser <user id> dip
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

  9. #9
    Join Date
    Mar 2007
    Location
    fort frances.on.ca
    Beans
    31
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: Administrator right to connect to wireless on 12.10

    I don't want workarounds. I don't want to elevate a user to be able to make 'Available to all users'.

    Is this issue a regression that started with 12.04? Should I consider an older version? Should I consider another distro?

    Essentially what I need to work is brain-dead simple wireless with limited powers. Also need Citrix Receiver to work flawlessly. These laptops may go from one user to another so the previous user's wireless security settings should not be visible 'to all users'. Users should not have enough rights to bork up settings.

    CorpIT will not support them and if my users pester them for support (which they will) they will come back on me hard. I cannot support them either so I need to demonstrate that my time is not squandered on them otherwise I'd just make the user admin and re-image the laptop every time it gets borked or returned to me. If I fail at this, the alternative is to toss them in the waste bin.

  10. #10
    Join Date
    Mar 2010
    Location
    India
    Beans
    8,175
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Administrator right to connect to wireless on 12.10

    Quote Originally Posted by LLigetfa View Post
    Essentially what I need to work is brain-dead simple wireless with limited powers.
    A quick lookup turned up this -
    Connect to wireless and ethernet networks
    This right is gained by adding the user to the "netdev" group.
    ....
    ....
    The "netdev" group can administer wicd and wpasupplicant.

    The "netdev" group can set the avahi host name using DBus.

    The "netdev" group can administer Bluetooth devices.
    (from : https://wiki.ubuntu.com/Security/Pri...ernet_networks)

    Try it on a test user and let us know if it does what you want -
    Code:
    sudo adduser <test user id> netdev
    Varun
    Help others by marking threads as [SOLVED], if they are. (See how)
    Wireless Script | Use Code Tags
    Am I not replying your post? This is why.

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •