Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: Unity not loading after nvidia drivers installation

Hybrid View

  1. #1
    Join Date
    Sep 2005
    Location
    Portugal
    Beans
    23
    Distro
    Dapper Drake Testing/

    Unity not loading after nvidia drivers installation

    Hi.

    I've messed up my ubuntu 13.04.
    I've installed nvidia drivers with this commands (found on a STEAM guide):

    apt-get install nvidia-experimental-310
    apt-get install libgl1-mesa-glx:i386

    But now unity does not load. After login I only get the wallpaper, nothing more.
    I already purged this packages and tried to reinstall ubuntu-desktop but I still get the same problem.

    Any ideas?

  2. #2
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Unity not loading after nvidia drivers installation

    use synaptic to purge the installed nvidia packages, drop the xorg.conf too if it exist, then install nvidia-313-updates

  3. #3
    Join Date
    Sep 2005
    Location
    Portugal
    Beans
    23
    Distro
    Dapper Drake Testing/

    Re: Unity not loading after nvidia drivers installation

    Nothing
    Any more ideas?

  4. #4
    Join Date
    Sep 2005
    Location
    Portugal
    Beans
    23
    Distro
    Dapper Drake Testing/

    Re: Unity not loading after nvidia drivers installation

    Tried to reinstall unity and ubuntu-desktop and nothing.
    Tried to reset unity, but I'm getting an error:

    dconf reset -f /org/compiz/

    Error spawning command line 'dbus-launch --autolaunch= (...): Child process exited with code 1


    Have some errors on xsession-error file:
    compiz (core) - Error: Plugin 'opengl' not loaded.
    (...)
    I/O warning : failed to load external entity "/home/myuser/.compiz/session/(...)

  5. #5
    Join Date
    Sep 2005
    Location
    Portugal
    Beans
    23
    Distro
    Dapper Drake Testing/

    Re: Unity not loading after nvidia drivers installation

    How can I solve this opengl errors on compiz?
    How can I have unity back?

    Need help please

  6. #6
    Join Date
    Nov 2007
    Beans
    57

    Re: Unity not loading after nvidia drivers installation

    Ctrl-Alt-t
    type ccsm
    Enable Unity Plugin

  7. #7
    Join Date
    Oct 2006
    Beans
    20

    Re: Unity not loading after nvidia drivers installation

    Quote Originally Posted by wribeiro View Post
    Ctrl-Alt-t
    type ccsm
    Enable Unity Plugin
    Thanks!

  8. #8
    Join Date
    Sep 2005
    Location
    Portugal
    Beans
    23
    Distro
    Dapper Drake Testing/

    Re: Unity not loading after nvidia drivers installation

    Still nothing

  9. #9
    Join Date
    Jun 2010
    Beans
    5

    Re: Unity not loading after nvidia drivers installation

    1. I purge all nvidia-*.
    2. Reboot
    3. Login
    4. Launch gnome-terminal
    5. Install ccsm
    6. Run ccsm
    7. Enable Unity Plugin
    8. Resolv conflicts with keys

  10. #10
    Join Date
    Mar 2006
    Beans
    4,373
    Distro
    Ubuntu Development Release

    Re: Unity not loading after nvidia drivers installation

    I got unity working again , heres how . I installed the nvidia 304 updates and the nvidia settings updates ( I don't know if this had anything to do with it ) , I reinstalled unity rebooted and loged into unity ( ubunty default ) still no top bar and launcher , then I brought up ccsm and enabled the unity plugin , it said it conflicted with 2 gnome settings and asked to disable them I clicked disable them and unity came up working . I logged out of unity and into gnome-shell and it also seems to be normal . I logged out of gnome-shell and back into unity and it is still working so it may be as simple as reinstalling unity and letting it disable the 2 things it asks to in ccsm .
    if it ain't broke you haven't tweaked it enough

Page 1 of 3 123 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •