Results 1 to 5 of 5

Thread: Switching windows

  1. #1
    Join Date
    Apr 2007
    Beans
    5

    Switching windows

    good evening everyone,

    I've installed 12.10 on Macbook2,1 with 1GB ram. Unity was working but due to hardware restrictions I had to install gnome-sessions-fallback and going back to previous gnome.

    in this environment it's usable but I can't have the Switching Windows Shortcut working. When I press the Alt+Tab the windows are not switching. If I open the Keyboard settings, in the shortcuts->navigation I have Alt+Tab selected. I tried changing with different combinations but none of them is working.

    Any ideas?

    Thank you
    Regards
    Davide

  2. #2
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: Switching windows

    Are you using classic gnome with or without desktop effects? Try without effects and you may find everything works as expected.

    If you are not using unity you don't really need compiz anyway.
    DISTRO: Xubuntu 14.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

  3. #3
    Join Date
    Feb 2007
    Location
    West Hills CA
    Beans
    9,115
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Switching windows

    Alt-tab will switch between several windows open in the same workspace. Control-Alt-Arrow (left or right) will switch the workspace to the left or right.
    -------------------------------------
    Oooh Shiny: PopularPages

    Unumquodque potest reparantur. Patientia sit virtus.

  4. #4
    Join Date
    Apr 2007
    Beans
    5

    Re: Switching windows

    Quote Originally Posted by ajgreeny View Post
    Are you using classic gnome with or without desktop effects? Try without effects and you may find everything works as expected.

    If you are not using unity you don't really need compiz anyway.
    thanks ajgreeny. Switching to "No effects" at all solved the issue... Strange though

  5. #5
    Join Date
    Oct 2008
    Beans
    3,509

    Re: Switching windows

    There are a couple of switchers in compiz.
    Unity uses the one in the unity plugin for compiz.

    The unity plugin for compiz is disabled in the gnome classic session and therefore no switcher.
    You need to enable the old switcher in ccsm.
    If the old switcher does not show in ccsm, install the compiz-plugins package.
    If you don't like or use the other stuff provided by compiz, just do as ajgreeny said.
    Attached Images Attached Images
    Last edited by stinkeye; March 12th, 2013 at 05:15 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •