Results 1 to 4 of 4

Thread: dpkg error, unable to update

  1. #1
    Join Date
    Mar 2011
    Beans
    72

    dpkg error, unable to update

    Hello I am unable to update my pc

    I keep getting this error

    dpkg: error: parsing file '/var/lib/dpkg/available' near line 10037 package 'libavcodec-extra-53:amd64':
    field name ``This' must be followed by colon
    Error in function:


    Hope someone can help

    John

  2. #2
    Join Date
    Sep 2012
    Location
    12o4/14o4
    Beans
    Hidden!

    Re: dpkg error, unable to update

    Looks like you can just do what it says and insert a colon.

    Code:
    gksudo gedit /var/lib/dpkg/available
    Or dpkg/available has a backup. You can try using it.

    Code:
    sudo mv /var/lib/dpkg/available /var/lib/dpkg/available.broken && sudo mv /var/lib/dpkg/available-old /var/lib/dpkg/available

  3. #3
    Join Date
    Feb 2013
    Beans
    Hidden!

    Re: dpkg error, unable to update

    The easiest way to cure this is
    Code:
    sudo dpkg --clear-avail
    /var/lib/dpkg/available will be re-created on the next run of apt-get update

  4. #4
    Join Date
    Sep 2012
    Location
    12o4/14o4
    Beans
    Hidden!

    Re: dpkg error, unable to update

    Quote Originally Posted by schragge View Post
    The easiest way to cure this is
    Code:
    sudo dpkg --clear-avail
    /var/lib/dpkg/available will be re-created on the next run of apt-get update
    Yep, that work perfect

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •