Results 1 to 8 of 8

Thread: Unable to upgrade from 11.10 to 12.04LTS

  1. #1
    Join Date
    May 2010
    Beans
    7

    Unable to upgrade from 11.10 to 12.04LTS

    Hello,
    I have been trying to upgrade from 11.10 to 12.04 but i keep getting these error messages

    W:Failed to fetch http://gb.archive.ubuntu.com/ubuntu/...source/Sources 404 Not Found
    , W:Failed to fetch http://gb.archive.ubuntu.com/ubuntu/...source/Sources 404 Not Found
    , W:Failed to fetch http://gb.archive.ubuntu.com/ubuntu/...source/Sources 404 Not Found
    , W:Failed to fetch http://gb.archive.ubuntu.com/ubuntu/...source/Sources 404 Not Found
    , E:Some index files failed to download. They have been ignored, or old ones used instead.


    My first Ubuntu installation was 9.10(Karmic Koala) and I have always done upgrades till my current version 11.10(Oneiric Ocelot)
    I think there is no more support for some Karmic packages and this is affecting my upgrade.
    Can anyone help ?

  2. #2
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,694
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unable to upgrade from 11.10 to 12.04LTS

    If you are currently on oneiric your sources should point to it, not karmic. Yes, the karmic repos are closed. But you shouldn't have any sources for karmic anyway.

    Try disabling these repos, or if you need them than change them to oneiric from karmic.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  3. #3
    Join Date
    May 2010
    Beans
    7

    Re: Unable to upgrade from 11.10 to 12.04LTS

    How do i disable repos.
    I am quite new at this and will be grateful if you could walk me through the process.

  4. #4
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,694
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unable to upgrade from 11.10 to 12.04LTS

    If I'm not mistaken, in 11.10 you need to open Update Manager and it will show all the default repos. Third-party repos might be in the second or third tab, not sure right now.

    Another alternative, which will show them better, is opening in the gedit text editor the file /etc/apt/sources.list. It contains all repos. Open terminal and execute:
    Code:
    gksu gedit /etc/apt/sources.list
    That will open the text file and in there are all of them. Compare them with the error message and you can disable the ones you want to disable by putting the # symbol at the start of the line. Everything after the # is ignored. That way you can easily disable things, and later enable them if you want to by removing the #. Save and close the file. Then in terminal run:
    Code:
    sudo apt-get update
    It should run with no errors. And you should be able to upgrade to 12.04 LTS or install any software without problems.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  5. #5
    Join Date
    May 2010
    Beans
    7

    Re: Unable to upgrade from 11.10 to 12.04LTS

    Thanks i did it and the updates started but i got another error

    Failed to fetch http://ubuntu.datahop.net/ubuntu/poo...ntu2.2_all.deb Size mismatch

    Can you help?

  6. #6
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,694
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unable to upgrade from 11.10 to 12.04LTS

    The file might be wrong or corrupted there. Try another server. Simply change the update server, reload the sources and try again.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

  7. #7
    Join Date
    May 2010
    Beans
    7

    Re: Unable to upgrade from 11.10 to 12.04LTS

    still the same.

  8. #8
    Join Date
    Nov 2009
    Location
    Segur De Calafell, Spain
    Beans
    11,694
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Unable to upgrade from 11.10 to 12.04LTS

    Have no clue. Try googling this type of error, maybe it would help if you remove/purge the program (package) and try to install it later.
    Darko.
    -----------------------------------------------------------------------
    Ubuntu 12.04 LTS 64bit & Windows 7 Ultimate 64bit

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •