Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: Wifi problems: Asus x401a, ra5390, rt2800pci

  1. #11
    Join Date
    Apr 2007
    Beans
    47

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    Just turned off b/g only and set router to b/g/n mixed. My connection dropped immediately. Returned it to b/g only and it connected at 65% and appears stable.
    If this was only a movie, I could re-write the ending.

  2. #12
    Join Date
    Apr 2007
    Beans
    47

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    My connection is stable at 65% for over 2 hours now. I think we can call it fixed.
    Thanks chili555. You have really saved the day on this one.

    The key seems to be that there is a problem handling b/g/n mixed parameters on a router. Once my router was forced to use b/g only I can get a good connection.


    Is there any way to set the driver to only work at g speed even if the router has n? That would make work and public routers available to this laptop.
    If this was only a movie, I could re-write the ending.

  3. #13
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,234
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    Is there any way to set the driver to only work at g speed even if the router has n?
    Some drivers support this but I haven't yet found it for rt2800pci. Still looking.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  4. #14
    Join Date
    Apr 2007
    Beans
    47

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    Thanks chili555. You've been great. There is no support anywhere else that's nearly as good.
    Let me know if you find a way to make force rt2800pci into line
    If this was only a movie, I could re-write the ending.

  5. #15
    Join Date
    Oct 2013
    Beans
    1

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    super big pain in the ass but this 200 dollar laptop flies with a kind of old vertex2 ssd

    the wireless absolutely sucked till I got the driver from ralink... there is some retarded file
    2011_1007_RT5390_RT5392_Linux_STA_V2.5.0.3_DPO_v2. bz2.bz2 that you have to search forever to find

    then I think you tar -xvf that

    then find this file
    rt5592sta_fix_64bit_3.8.patch

    and put that in the root of the extracted folder

    then you
    patch -p1 < rt5592sta_fix_64bit_3.8.patch

    then also in the extracted folder
    edit os/linux/config.mk and find the line below and make sure it looks like that
    HAS_NATIVE_WPA_SUPPLICANT_SUPPORT=y

    then
    sudo make
    sudo make install

    then add these lines to the bottom of /etc/modprobe.d/blacklist.conf
    #asus wireless... do sudo modprobe rt5390sta
    blacklist rt2800pci
    blacklist rt2800lib
    blacklist rt2x00usb
    blacklist rt2x00pci
    blacklist rt2x00lib
    blacklist rt2860sta
    blacklist rt3090sta

    then restart... and after you are done with all that your wireless will not disconnect anymore BUT IT WILL BE SLOW AS **** if you have the router i have or something like it... dual band 1200ac linksys. So you need to go into your router and look in the wireless settings on the 24ghz band... look for something like "channel width". Change it from auto to 20mhz only. Once I did this I have a full strength connection and I can scp files at around 7 megs/sec... it used to go at around 800k

    I attached the driver source with the patch and config.mk already done.

    Good luck
    Attached Files Attached Files
    Last edited by mattcsl; January 9th, 2014 at 08:36 AM.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •