Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Wifi problems: Asus x401a, ra5390, rt2800pci

  1. #1
    Join Date
    Apr 2007
    Beans
    47

    Wifi problems: Asus x401a, ra5390, rt2800pci

    I need help with my wireless connection after my new install of Mint 14 64bit.

    Here's my set up:
    Asus x401a
    Mint 14-64 updated
    Ralink 5390
    driver rt2800pci
    positioned < 8 ft from router

    Symptoms:
    1. sees my router and neighbors
    2. sees my router after startup at 72%, hp next to it shows 98%
    3. tries to autoconnect, fails, asks for password, fails, etc. - may repeat endlessly
    4. occasionally connects - loads slowly, shows 65% power, then 42%, then 25%, begins to ask for password again, endless repeat
    5. hp laptop next to Asus is stable & downloading quickly on same router
    6. wired connection is stable
    7. no other problems with the install so far

    What I've tried:
    1. double checked password
    2. rebooted router
    3. tried 32bit live cd Mint 14
    4. tried suggestions from "Ralink 5390 / Compaq persario..." in Networking & Wireless forum to download & install rt2860 driver, that gave better power readings but goes into kernel panic under load - clean re-install afterwards
    5. tried OpenSuse 64 which gave higher power readings and more stability, but cuts out at more than 12 ft from router

    Using commands from other threads my output is:

    bill@Liveoak ~ $ lspci -nn | grep 0280
    02:00.0 Network controller [0280]: Ralink corp. RT5390 Wireless 802.11n 1T/1R PCIe [1814:5390]

    bill@Liveoak ~ $ lsmod | grep rt2
    rt2800pci 18528 0
    rt2800lib 58685 1 rt2800pci
    crc_ccitt 12667 1 rt2800lib
    rt2x00pci 14475 1 rt2800pci
    rt2x00lib 54891 3 rt2800pci,rt2800lib,rt2x00pci
    mac80211 539908 3 rt2800lib,rt2x00pci,rt2x00lib
    cfg80211 206566 2 rt2x00lib,mac80211
    eeprom_93cx6 13302 1 rt2800pci

    I'm a regular Linux user, but don't know how to work under the hood. It's more 'monkey see, monkey do'.

    Thanks for your help.
    Last edited by BeardedOne; March 9th, 2013 at 10:02 PM. Reason: mark it solved
    If this was only a movie, I could re-write the ending.

  2. #2
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,234
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    The driver rt2800pci is tricky. The first fix I'd try is in the router. Open the administration pages and change the encryption mode to WPA2 only; many routers offer a WPA and WPA2 mixed mode and many Linux drivers are confused by it.

    Next, I'd turn off N speeds. Please see attached. In this example I'd set 802.11-n-mode to OFF. Some other routers offer a choice between 802.11B and G or 802.11B, G and N. We'd love to try B and G only.

    Next, I'd temporarily hook up an ethernet cable and install the latest rt2800pci module:
    Code:
    sudo apt-get install linux-backports-modules-cw-quantal-generic
    sudo modprobe -r rt2800pci
    sudo modprobe rt2800pci
    Last, you might try a temporary driver parameter:
    Code:
    sudo modprobe -r rt2800pci
    sudo modprobe rt2800pci nohwcrypt=Y
    It would be helpful to try and report on one at a time so that all of us, including the searchers, learn the shortcut.
    Attached Images Attached Images
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  3. #3
    Join Date
    Apr 2007
    Beans
    47

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    Tried the update and got

    bill@Liveoak ~ $ sudo apt-get install linux-backports-modules-cw-quantal-generic
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package linux-backports-modules-cw-quantal-generic
    If this was only a movie, I could re-write the ending.

  4. #4
    Join Date
    Apr 2007
    Beans
    47

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    Set router to b/g only
    Set router to WPA2/PSK only
    If this was only a movie, I could re-write the ending.

  5. #5
    Join Date
    Apr 2007
    Beans
    47

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    Tried:
    sudo modprobe -r rt2800pci
    sudo modprobe rt2800pci nohwcrypt=Y

    wifi shows 65% (down from 75%), can't connect, asks for password, repeats
    If this was only a movie, I could re-write the ending.

  6. #6
    Join Date
    Apr 2007
    Beans
    47

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    Oops, forgot to reboot the router.

    Rebooted router, settings taking effect.

    wifi shows 61% and is stable

    Let's see if this works longterm. It's connected before only to drop out later.
    If this was only a movie, I could re-write the ending.

  7. #7
    Join Date
    Apr 2007
    Beans
    47

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    wifi continues to be stable at ~60%. I'll go grab some lunch and see if it holds.

    Thanks for your help. I'll let you know how it works out.
    If this was only a movie, I could re-write the ending.

  8. #8
    Join Date
    Mar 2013
    Beans
    30

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    apt-get install wicd

  9. #9
    Join Date
    Aug 2005
    Location
    West of the Animas
    Beans
    20,234
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    Quote Originally Posted by fiodev View Post
    apt-get install wicd
    In my opinion, absolutely not. YMMV.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  10. #10
    Join Date
    Apr 2007
    Beans
    47

    Re: Wifi problems: Asus x401a, ra5390, rt2800pci

    OK, I'm back with the burgers and wifi is still up, showing 67%, and appears stable after more than 30 minutes (a new record). Just ran Youtube so load isn't a problem.

    Let's try to figure out what the fix actually was.
    The driver update looked like it didn't go through, so that wasn't it. (Thought I'd love to have the latest driver.)
    The parameter commands didn't change the symptoms, so that wasn't it. At least not by itself.
    The change seems to have occured after I set the router to b/g only and WPA2/PSK only.

    A further problem: This is a laptop. What happens when I take this to work and want to turn off everyone's n speed? (I'm already the weird guy that uses Linux. I really don't want to hear about how this wouldn't be a problem if I was using Windows). Is there a way to set my wifi to only use b/g and WPA2, whether the router is set that way or not?

    Thanks.
    If this was only a movie, I could re-write the ending.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •