Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: fontspacing problem in terminal etc after upgrade

  1. #1
    Join Date
    Apr 2006
    Location
    Sweden
    Beans
    51
    Distro
    Ubuntu Development Release

    Question fontspacing problem in terminal etc after upgrade

    After upgrade from 12.10 to 13.04 i get this weird fontproblem, no matter wich font i use (fonts in firefox/chrome looks good tough). Any ideas how to fix? Same problem if I create a new local user with a clean homedirectory

    Last edited by Cloud79; March 14th, 2013 at 12:29 PM.

  2. #2
    dino99's Avatar
    dino99 is offline Ubuntu addict and loving it
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: fontspacing problem in terminal etc after upgrade

    from nautilus, you should now only have .fontconfig folder, so i suppose the oldish .fonts.conf (or so, i does not remember how it was) is confusing the system. Simply delete or rename the old "fonts" setting file(s)

  3. #3
    Join Date
    Apr 2006
    Location
    Sweden
    Beans
    51
    Distro
    Ubuntu Development Release

    Re: fontspacing problem in terminal etc after upgrade

    No that doesn't seem to be it. I have tried with a new user with (blank slate), same problem. This is OS related not user

  4. #4
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: fontspacing problem in terminal etc after upgrade

    You have obviously chosen a custom font as the tick box to use system font is not selected, even though I think it may be what the system normally uses anyway, but have you tried using a different font for the terminal?
    DISTRO: Xubuntu 14.04-64bit --- Code-tags --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

  5. #5
    Join Date
    Apr 2006
    Location
    Sweden
    Beans
    51
    Distro
    Ubuntu Development Release

    Re: fontspacing problem in terminal etc after upgrade

    Yes i have tried monospace, ubuntu mono etc. It isn't just the terminal font that has problems. Maybe a reinstall is the only solution

  6. #6
    Join Date
    Feb 2013
    Beans
    Hidden!

    Re: fontspacing problem in terminal etc after upgrade

    Hmm, looks like your terminal uses proportional sans serif font instead of monospaced one. Weird. What does fc-match Monospace show?

  7. #7
    Join Date
    Apr 2006
    Location
    Sweden
    Beans
    51
    Distro
    Ubuntu Development Release

    Re: fontspacing problem in terminal etc after upgrade

    linus@linux8:~$ fc-match Monospace
    DejaVuSansMono.ttf: "DejaVu Sans Mono" "Book"

  8. #8
    Join Date
    Feb 2013
    Beans
    Hidden!

    Re: fontspacing problem in terminal etc after upgrade

    I presume DejaVu Sans Mono is present on your system. Try
    Code:
    dpkg -l ttf-dejavu\*
    ls /usr/share/fonts/truetype/ttf-dejavu
    sudo fc-cache -r
    fc-match Monospace file
    Then re-login.
    Last edited by schragge; March 8th, 2013 at 12:43 PM.

  9. #9
    Join Date
    Apr 2006
    Location
    Sweden
    Beans
    51
    Distro
    Ubuntu Development Release

    Re: fontspacing problem in terminal etc after upgrade

    Sorry, same problem. I have nvidia graphics (proprietary driver) used, could it be this to blame in 13.04?

    linus@linux8:~$ dpkg -l ttf-dejavu\*
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
    |/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
    ||/ Name Version Architecture Description
    +++-=============================-===================-===================-================================================== ==============
    ii ttf-dejavu 2.33-3ubuntu2 all Metapackage to pull in ttf-dejavu-core and ttf-dejavu-extra
    ii ttf-dejavu-core 2.33-3ubuntu2 all Vera font family derivate with additional characters
    ii ttf-dejavu-extra 2.33-3ubuntu2 all Vera font family derivate with additional characters
    linus@linux8:~$ ls /usr/share/fonts/truetype/ttf-dejavu
    DejaVuSans-BoldOblique.ttf DejaVuSans-ExtraLight.ttf DejaVuSans.ttf DejaVuSerifCondensed.ttf
    DejaVuSans-Bold.ttf DejaVuSansMono-BoldOblique.ttf DejaVuSerif-BoldItalic.ttf DejaVuSerif-Italic.ttf
    DejaVuSansCondensed-BoldOblique.ttf DejaVuSansMono-Bold.ttf DejaVuSerif-Bold.ttf DejaVuSerif.ttf
    DejaVuSansCondensed-Bold.ttf DejaVuSansMono-Oblique.ttf DejaVuSerifCondensed-BoldItalic.ttf
    DejaVuSansCondensed-Oblique.ttf DejaVuSansMono.ttf DejaVuSerifCondensed-Bold.ttf
    DejaVuSansCondensed.ttf DejaVuSans-Oblique.ttf DejaVuSerifCondensed-Italic.ttf
    linus@linux8:~$ sudo fc-cache -r
    linus@linux8:~$ fc-match Monospace file
    :file=/usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono.ttf

  10. #10
    Join Date
    Aug 2012
    Beans
    242
    Distro
    Ubuntu Development Release

    Re: fontspacing problem in terminal etc after upgrade

    Do you have gnome-tweak-tool or any similar tool installed? If so, have you tried checking the fonts settings?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •