Results 1 to 2 of 2

Thread: 12.10 Memory leaks: Firefox, Xorg... compiz

  1. #1
    Join Date
    Jan 2005
    Beans
    243

    Angry 12.10 Memory leaks: Firefox, Xorg... compiz

    Hi everybody, I've been using ubuntu for 6 years now, and I've been "fighting" many bugs both on my Laptop and Desktop. I've debugged, reported and helped devs debug quite a few of them.

    This time I want to take the passenger seat, cause I'm tired of this (and I'm also very busy writing a thesis).

    I can't get my head around the fact that I have a quad core hyperthreading cpu with 9GB of ram and it runs so slow after a few days...

    The reasons are probably memory leaks in Firefox and Xorg, and some kind of cpu loop in compiz. Please see attached screenshots.

    This is after a boot, having opened firefox with all its 15 tabs, everything is OK:
    normal ram usage.jpg

    These are after 7 days of usage without restart. Firefox tabs are not the same, but they are not much different either.
    Look at the Memory usage in the first one, and CPU in the 2nd.
    after_7days_ram.jpgafter_7days_cpu.jpg after_7days_resources.jpg

    Restarting firefox. loading the same tabs:
    after_7days_ram_ff_restarted.jpg

    So:
    • Restarting firefox fixes its memory problem but this is not a good solution, and it doesn't solve the other problems.
    • Restarting the system "fixes" all the problems but this is not a good solution either!


    Any ideas about what causes it would be appreciated!

    System is 12.10 64-bit, upgraded from 12.04, fully updated. Firefox is 20.0, Compiz 0.9.8.6.

    This is my graphics driver:
    Code:
    # fglrxinfo
    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: ATI Radeon HD 4800 Series        
    OpenGL version string: 3.3.11672 Compatibility Profile Context
    Thanks,
    Chris

  2. #2
    Join Date
    Jan 2005
    Beans
    243

    Re: 12.10 Memory leaks: Firefox, Xorg... compiz

    Folow-up:
    New report, 3 days after restart, only FF seems to experience memory problems:
    after_3_days)_RAM.jpg
    Only 1 window open, 11 tabs, no videos or other heavy flash that I know of.

    Compiz seems to be a bit misbehaving on CPU usage...:
    after_3_days_CPU.jpg

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •