Results 1 to 6 of 6

Thread: Wireless trouble with asus-56e. how to disable/edit iwlwifi module?

  1. #1
    Join Date
    Mar 2013
    Beans
    3

    Wireless trouble with asus-56e. how to disable/edit iwlwifi module?

    Quote Originally Posted by bouchigo View Post
    I did this, but it won't stick (not permanent).

    Every time I reboot I have to use these two commands, otherwise I can't connect:

    sudo modprobe -r iwlwifi

    sudo modprobe iwlwifi bt_coex_active=0

    There are no conflicting files in /etc/modprobe.d, I already checked that.

    Any suggestions???

    Thanks


    Hi! I am a completely new to Linux, I have my ASUS u56-e with the same problems - Wireless networks are appearing but the computer refuses to connect. I've been working through the solutions in this forum and I'm stuck - here is my situation.

    When I type

    sudo modprobe -r iwlwifi

    into the terminal, I get:

    FATAL: Module iwlwifi is in use.

    So, I tried to disable iwlwifi, and this happens:

    alex@alex-U56E:~$ sudo rmmod -f iwlwifi
    libkmod: ERROR ../libkmod/libkmod-module.c:753 kmod_module_remove_module: could not remove 'iwlwifi': Resource temporarily unavailable
    Error: could not remove module iwlwifi: Resource temporarily unavailable

    I tried unchecking the "Enable WiFi" options in the networking menu, but to no avail.

    Any ideas for how to get this working for me?

  2. #2
    Join Date
    Mar 2013
    Beans
    3

    Wireless trouble with asus-56e. how to disable/edit iwlwifi module?

    Hi! I am a completely new to Linux, I have my ASUS u56-e, with a intel wimax-6150+ wireless card with a common problem - Wireless networks are appearing but the computer refuses to connect. I've been working through the solutions in this forum and I'm stuck. This solution is supposed to work:








    sudo modprobe -r iwlwifi


    sudo modprobe iwlwifi bt_coex_active=0


    gksu gedit /etc/modprobe.d/iwl.conf


    options iwlwifi bt_coex_active=0


    and to ensure fast internet do the same:


    sudo rmmod -f iwlwifi
    gksu gedit /etc/modprobe.d/iwlwifi-disable11n.conf


    options iwlwifi 11n_disable=1




    but I get stuck:


    When I type


    sudo modprobe -r iwlwifi


    into the terminal, I get:


    FATAL: Module iwlwifi is in use.


    So, I tried to disable iwlwifi, and this happens:


    alex@alex-U56E:~$ sudo rmmod -f iwlwifi
    libkmod: ERROR ../libkmod/libkmod-module.c:753 kmod_module_remove_module: could not remove 'iwlwifi': Resource temporarily unavailable
    Error: could not remove module iwlwifi: Resource temporarily unavailable






    I tried unchecking the "Enable WiFi" options in the networking menu, but to no avail.


    Any ideas for how to get this working for me?


    Thanks,
    Alex

  3. #3
    Join Date
    Oct 2009
    Location
    Reykjavík, Ísland
    Beans
    9,470
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Wireless trouble with asus-56e. how to disable/edit iwlwifi module?

    Please don't double-post.
    Merged.
    About problems due to upgrading
    Bringing old hardware back to life.
    Please visit Quick Links -> Unanswered Posts

  4. #4
    Join Date
    Mar 2013
    Beans
    3

    Re: Wireless trouble with asus-56e. how to disable/edit iwlwifi module?

    I just stuck with the first one I tried. Should I try a different one? I'm using Ubuntu 11.04.
    Last edited by mbsch; March 8th, 2013 at 06:09 PM.

  5. #5
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: Wireless trouble with asus-56e. how to disable/edit iwlwifi module?

    Thread moved to Networking & Wireless

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    20,224
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Wireless trouble with asus-56e. how to disable/edit iwlwifi module?

    alex@alex-U56E:~$ sudo rmmod -f iwlwifi
    libkmod: ERROR ../libkmod/libkmod-module.c:753 kmod_module_remove_module: could not remove 'iwlwifi': Resource temporarily unavailable
    Error: could not remove module iwlwifi: Resource temporarily unavailable
    You probably want:
    Code:
    sudo modprobe -r iwlwifi
    gksu gedit /etc/modprobe.d/iwl.conf




    and to ensure fast internet do the same:


    sudo rmmod -f iwlwifi
    gksu gedit /etc/modprobe.d/iwlwifi-disable11n.conf


    options iwlwifi 11n_disable=1

    I'd put it in just one file:
    Code:
    gksudo gedit /etc/modprobe.d/iwlwifi.conf
    Add a single line:
    Code:
    options iwlwifi bt_coex_active=N 11n_disable=1
    The parameter bt_coex_active is boolean, not an integer. See modinfo iwlwifi.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •