Results 1 to 4 of 4

Thread: Fix broked dependencies in KDE

  1. #1
    Join Date
    Aug 2009
    Beans
    1

    Fix broked dependencies in KDE

    Hi.

    I'm new to Ubuntu but not to Linux in general (I'm an openSUSE user used to zypper and rpm, not apt-get and deb).

    At work I've been given a machine that has been upgraded from the previous LTS release to 12.04 LTS. It had only the Ubuntu desktop installed. I started with installing KDE with the following command:

    Code:
    sudo apt-get install kde-full
    I then proceeded with upgrading KDE to the latest 4.10 with the following commands

    Code:
    sudo add-apt-repository ppa:kubuntu-ppa/backports
    sudo apt-get update
    sudo apt-get upgrade
    I wasn't satisfied with the result however and wanted to downgrade to the default KDE version in 12.04 LTS so I did the following:

    Code:
    sudo apt-get install ppa-purge
    sudo ppa-purge ppa:kubuntu-ppa/backports
    sudo apt-get autoremove
    I think I also removed the ppa source list in directory /etc/apt/sources.list.d when the above commands had finished but I'm not shure, it's not there now anyhow.

    But now I'm stuck with an unusable KDE. If I try to reinstall the package kde-full to get a full default KDE environment I get the following error:

    Code:
    mikspr@rhino:/etc/apt/sources.list.d$ sudo apt-get install kde-full
    [sudo] password for mikspr: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    Some packages could not be installed. This may mean that you have
    requested an impossible situation or if you are using the unstable
    distribution that some required packages have not yet been created
    or been moved out of Incoming.
    The following information may help to resolve the situation:
    
    The following packages have unmet dependencies:
     kde-full : Depends: kde-plasma-desktop (>= 5:71~pre15ubuntu12.4) but it is not going to be installed
                Depends: kde-plasma-netbook (>= 5:71~pre15ubuntu12.4) but it is not going to be installed
                Depends: kdeartwork (>= 4:4.8.2) but it is not going to be installed
                Depends: kdeplasma-addons (>= 4:4.8.2) but it is not going to be installed
                Recommends: kde-standard (>= 5:71~pre15ubuntu12.4) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.
    mikspr@rhino:/etc/apt/sources.list.d$
    I've tried a number of different things but nothing works. I need some help to move forward.

    Regards, Micke.

  2. #2
    Join Date
    Jan 2013
    Location
    East Yorkshire
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Fix broked dependencies in KDE

    I know this isn't helpful, but I did the same thing on my 12.04 Kubuntu desktop.
    Once I had 4.10 installed, I had a number of plasma crashes, so decided to do a "ppa purge".
    This screwed up my desktop big time.
    Ended up doing a complete re-install.
    That might be your best option.

  3. #3
    Join Date
    Sep 2012
    Location
    Gnome12o4/LXQt14o4
    Beans
    Hidden!

  4. #4
    Join Date
    Dec 2007
    Beans
    43

    Re: Fix broked dependencies in KDE

    try sudo apt-get install -f

    That will tell APT to try to repair any packages error it can find.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •