Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: (SOLVED) Missing thread? How To Disable OS_PROBER In Grub?

  1. #1
    Join Date
    Nov 2009
    Location
    Virginia
    Beans
    Hidden!
    Distro
    Ubuntu

    (SOLVED) Missing thread? How To Disable OS_PROBER In Grub?

    Back a couple of years ago I posted a thread in here titled "It's Grub Again" and the discussion was how to stop Grub from installing on my Windows drives on a multi-boot system. Another member here showed me how to disable OS-PROBER and that took care of my problem and over the last couple of years I've used that thread to modify all 3 of my systems to get rid of Grub controlling boot selection.

    So here I am installing a clean copy of 12.04 on what use to be a Mint 12 box and now I can't find that post??

    So can someone tell me again how to stop Grub's OS-PROBER from looking for Windows drives to mess up?

    Thanks,

    Ken
    Last edited by ken0069; March 9th, 2013 at 03:12 AM. Reason: SOLVED
    Stuff doesn't just happen, it's usually caused by something!

  2. #2
    Join Date
    Jul 2005
    Location
    England
    Beans
    13,506

    Re: MISSING THREAD??? How To Disable OS_PROBER In Grub??

    I'm not sure I completely understand what you are trying to do but I presume you are using the windows bootloader system to boot into Ubuntu, and not grub; or that is what you want to happen. If not, how do you manage to boot to ubuntu when grub is not controlling the boot selection?

    If I am correct, I think you should be able to put grub on the ubuntu partition instead of the MBR of the first disk, where it is installed by default, by choosing Something Else at disk preparation stage of the installation.

    Also to stop grub searching for and finding other OSs, you can remove the execute flag from the executable file with command
    Code:
    sudo chmod -x /usr/bin/os-prober
    DISTRO: Xubuntu 12.04-64bit --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

  3. #3
    Join Date
    Nov 2009
    Location
    Virginia
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: MISSING THREAD??? How To Disable OS_PROBER In Grub??

    Thanks for your reply.

    I've had problems in the past when Grub got installed on my Windows drives and I do not want that to happen again, ie, Windows wouldn't boot without the Linux drive being connected to the system. Since I don't want Windows to be dependent on Linux I disable the os-prober after the initial install of Ubuntu without the Windows drive connected. That way NOTHING from Ubuntu/grub gets installed on that Windows drive.

    So Grub does get installed and only sees Ubuntu so there's no grub menu that comes up at boot up. I change boot drives in BIOS and boot to whichever drive I want.

    So I'll try your code to see if that will stop Grub from trying to install on the Windows drive.

    Thanks,

    Ken
    Stuff doesn't just happen, it's usually caused by something!

  4. #4
    Join Date
    Nov 2009
    Location
    Virginia
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: MISSING THREAD??? How To Disable OS_PROBER In Grub??

    BAD NEWS! Didn't work and I lost that Windows load and all the data on that drive yet again?? I'm done for the night. Will regroup and post more details in the morning! Grub has been the curse of my life where Windows is concerned!!
    Stuff doesn't just happen, it's usually caused by something!

  5. #5
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: MISSING THREAD??? How To Disable OS_PROBER In Grub??

    Quote Originally Posted by ken0069 View Post
    Back a couple of years ago I posted a thread in here titled "It's Grub Again" and the discussion was how to stop Grub from installing on my Windows drives on a multi-boot system. Another member here showed me how to disable OS-PROBER and that took care of my problem and over the last couple of years I've used that thread to modify all 3 of my systems to get rid of Grub controlling boot selection.

    So here I am installing a clean copy of 12.04 on what use to be a Mint 12 box and now I can't find that post??

    So can someone tell me again how to stop Grub's OS-PROBER from looking for Windows drives to mess up?

    Thanks,

    Ken
    Here's your thread: http://ubuntuforums.org/showthread.php?t=1850660
    Forum DOs and DON'Ts
    Never assume that information you find using a search engine is up-to-date.

  6. #6
    Join Date
    Feb 2007
    Beans
    192

    Re: Missing thread? How To Disable OS_PROBER In Grub?

    By removing execute permissions from individual files in the /etc/grub.d/ folder disables them. As I use only a custom grub2 and theme, I always remove the permissions from 30_os-prober (and memtest just because...) through root nautilus OR 'sudo chmod -x /etc/grub.d/30_os-prober'.
    Clevo/Sager i7-2670 | 8gb ram | ATI 6970 | SSD drive | [I] Ubuntu: 14.04 / 13.10 /

  7. #7
    Join Date
    Aug 2006
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: MISSING THREAD??? How To Disable OS_PROBER In Grub??

    Quote Originally Posted by ken0069 View Post
    Thanks for your reply.

    I've had problems in the past when Grub got installed on my Windows drives and I do not want that to happen again, ie, Windows wouldn't boot without the Linux drive being connected to the system. Since I don't want Windows to be dependent on Linux I disable the os-prober after the initial install of Ubuntu without the Windows drive connected. That way NOTHING from Ubuntu/grub gets installed on that Windows drive.

    So Grub does get installed and only sees Ubuntu so there's no grub menu that comes up at boot up. I change boot drives in BIOS and boot to whichever drive I want.

    So I'll try your code to see if that will stop Grub from trying to install on the Windows drive.

    Thanks,

    Ken
    Disabling the OS probber wouldn't affect where Grub is installed in any way. Either change the default location (/dev/sda) to something else, or disconnect the hdd with Windows when installing Ubuntu.

  8. #8
    Join Date
    Jun 2009
    Location
    Chicago Suburbs
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Missing thread? How To Disable OS_PROBER In Grub?

    + on mikewhatevers comments

    If you just do a a default install of Ubuntu it installs grub to sda which usually is the Windows drive. With multiple hard drives you need to use Something else or manual install. Then you get the option on where to install grub2's boot loader.
    Install to external drive. Also any second drive.
    Installer version has not changed much so still a good guide except I do not recommend the separate /boot for most systems. Older systems may need it. And some with very large / (root) partitions. BIOS/MBR not for UEFI
    http://www.linuxbsdos.com/2012/07/23...2-hard-drives/

    Grub also remembers where to re-install on major updates. You can check if that is your sda drive or sdb drive, but it will be drive model not sda or sdb.

    #To see what drive grub2 uses see this line - grub-pc/install_devices:
    sudo debconf-show grub-pc
    sudo grub-probe -t device /boot/grub

    #to get grub2 to remember where to reinstall on updates:
    sudo dpkg-reconfigure grub-pc
    #Enter thru first pages,spacebar to choose/unchoose drive, enter to accept, do not choose partitions
    For info on UEFI boot install & repair:
    http://ubuntuforums.org/showthread.php?t=2147295
    Please use Thread Tools above first post to close thread when/if answered completely.







  9. #9
    Join Date
    Nov 2009
    Location
    Virginia
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: MISSING THREAD??? How To Disable OS_PROBER In Grub??

    Quote Originally Posted by mikewhatever View Post
    Disabling the OS probber wouldn't affect where Grub is installed in any way. Either change the default location (/dev/sda) to something else, or disconnect the hdd with Windows when installing Ubuntu.
    Yup, I always disconnect other drives when installing Ubuntu or anything else for that matter. Ask me how I learned that one!

    OK so after working on that Windows XP drive most of the afternoon yesterday and part of today I finally got the partition tables rebuilt and it's booted up now and seems to be working fine! It's been exciting times around here for the last 24 hours and this is my FIRST successful partition table repair ever on a Windows load!! I mean even Ubuntu couldn't read that drive!!

    And I think I figured out what happened as I did NOT run the update grub command after I did the initial chmod command in terminal. I just rebooted with the Windows drive connected and it was all down hill from there!

    Hopefully it will be ok now but I'll wait until tomorrow before I mark this one solved.

    Thanks for the help ppl,

    Ken
    Stuff doesn't just happen, it's usually caused by something!

  10. #10
    Join Date
    Jul 2005
    Location
    England
    Beans
    13,506

    Re: Missing thread? How To Disable OS_PROBER In Grub?

    Just to make things easier for you next time (I hope), note that you do not need to remove or disconnect the windows drive when you install Ubuntu; it is very much easier if you simply choose the "Something Else" option at disk preparation stage (formatting of partitions etc etc). At the bottom of that page the installer asks you where you want the bootloader files (grub) to be installed. Just make sure you choose the same disk that you have installed Ubuntu to (/dev/sdb usually if you have two disks, note not a partition such as /dev/sdb1), and you can then simply choose to boot from the second hard disk from your BIOS setup.

    If you do that, the windows bootloader will remain untouched on sda, but windows only, of course, will boot from the windows bootloader if you use sda as the first boot-device. Grub will be on sdb, and there will then be no need to disable os_prober, as you will then be able to boot either OS from grub, if sdb is your first boot-device.
    DISTRO: Xubuntu 12.04-64bit --- Boot-Repair --- Grub2 wiki & Grub2 Basics --- RootSudo

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •