Results 1 to 6 of 6

Thread: Not able to install Apache and PHP

  1. #1
    Join Date
    Mar 2013
    Beans
    9

    Not able to install Apache and PHP

    Hello Members,I am Bipin Vishwakarma not that sound in programming, but I am not able to install Apache2 and PHP in my Ubuntu 12.04.I run the command "sudo apt-get install apache2" and got and error somthing like "E: Sub-process /usr/bin/dpkg returned an error code (1)"and after that I am getting something like that


    ----------------------------------------------------------------------------------------
    bipin@bipin-VPCYB25AG:~$ sudo apt-get install apache2
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    apache2 is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
    1 not fully installed or removed.
    Need to get 0 B/5,765 kB of archives.
    After this operation, 0 B of additional disk space will be used.
    Do you want to continue [Y/n]? y
    dpkg: error processing libqtwebkit4:i386 (--configure):
    package libqtwebkit4:i386 is not ready for configuration
    cannot configure (current status `half-installed')
    Errors were encountered while processing:
    libqtwebkit4:i386
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    bipin@bipin-VPCYB25AG:~$

    -------------------------------------------------------------------------------------------
    plz friends helpthanx in advance.
    Last edited by bipinvish; March 6th, 2013 at 07:50 PM. Reason: Formating

  2. #2
    Join Date
    Sep 2011
    Location
    Dixie
    Beans
    53
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Not able to install Apache and PHP

    Hey there Bipinvish,

    I have had different install problems with apache on a cent OS server that required recompiling php with the apache package.


    with ubuntu, first try:


    sudo apt-get purge apache2
    then try:


    sudo apt-get install apache2
    and see if that helps.


    also, you will need to add a repository first, here is a link on how to do that. http://www.howtogeek.com/howto/ubunt...ies-on-ubuntu/


    hope that helps,


    -Pierce

  3. #3
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Not able to install Apache and PHP

    Try

    Code:
    sudo dpkg --configure -a
    and if that doesn't fix it, run

    Code:
    sudo rm -r /var/cache/apt/archives/*
    sudo apt-get update
    sudo apt-get install apache2
    GNU/Linux Notes || Linux Command Line Learning Resources

    Copy.com offers 15 GB free cloud storage plus 5 GB for both of us when you follow this referral link.

  4. #4
    Join Date
    Mar 2013
    Beans
    9

    Re: Not able to install Apache and PHP

    Quote Originally Posted by pierceTN View Post
    Hey there Bipinvish,

    I have had different install problems with apache on a cent OS server that required recompiling php with the apache package.


    with ubuntu, first try:




    then try:




    and see if that helps.


    also, you will need to add a repository first, here is a link on how to do that. http://www.howtogeek.com/howto/ubunt...ies-on-ubuntu/


    hope that helps,


    -Pierce

    Again I am getting something like that
    What is that "error code (1)"


    root@bipin-VPCYB25AG:~# sudo apt-get purge apache2
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages will be REMOVED:
    apache2*
    0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
    1 not fully installed or removed.
    Need to get 0 B/5,765 kB of archives.
    After this operation, 29.7 kB disk space will be freed.
    Do you want to continue [Y/n]? y
    (Reading database ... 177409 files and directories currently installed.)
    Removing apache2 ...
    dpkg: error processing libqtwebkit4:i386 (--configure):
    package libqtwebkit4:i386 is not ready for configuration
    cannot configure (current status `half-installed')
    Errors were encountered while processing:
    libqtwebkit4:i386
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    root@bipin-VPCYB25AG:~#

  5. #5
    Join Date
    Sep 2011
    Location
    Dixie
    Beans
    53
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Not able to install Apache and PHP

    Did you try adding the repository?

    -
    Pierce

  6. #6
    Join Date
    Mar 2013
    Beans
    9

    Re: Not able to install Apache and PHP

    I visited the link you give for adding repository. And as guided I go to the Source.list file, but I am not able to locate the mentioned DEB lines.
    should I have to add those lines manually ?
    And I have the 64-bit version of Ubuntu 12.04

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •