Hi,
I am trying to create a network to replace the RM Windows network in my ICT department as it is not fit for purpose as far as teaching computer science is concerned.

I'm trying to set the network up as follows...

I will have a server (with Edubuntu on), lets call it "VLE" (it has 2 network interfaces) in my office which will act as:
  • internet gateway (to internet provided through standard school network via eth0)
  • Single sign on server / file server etc. so all login authentication and files are stored on this machine

There will be a single Cat 6 bus link via eth1 to a switch and in turn a server (lets call it "Fred" for now) in a classroom. That has Edubuntu also and LTSP.
Fred has a number of (currently 1 for testing) Raspberry Pi computers running Berryterminal connected in a gigabit ethernet star ...
Students can log into Fred but get their files etc from VLE.
In due course I will add a second classroom with a second server ("Bernie"?).

I have to have a single cat 6 cable linking VLE in office to Fred in room 1 to Bernie in room 2 because I can only get away with a small amount of drilling, cant use the existing RM network and can only afford a smallish amount of kit.

I want each classroom to have it's own application server because I can make a faster network topology in each room, I believe this will be better for serving x-graphics whereas internet and file access should (hopefully) be fine when shared across a single cat 6 link. Also, each room could have 30 users at a time. For my purposes it would be easier to make 3 (there are 3 rooms in total) smaller scale applications servers than one big ultra powerful one that can handle 90 clients at once.

So, to cut to the chase I'm having a few snags.

So far I've successfully connected to an edubuntu server with a berryterminal. That's easy.
However, I've tried to set up VLE as an internet gateway. Remember it's connected to my own network via eth1 and to the school internet via eth0.

I used 'network manager' on VLE to make "Wired connection 2" on eth1 "shared to other computers" via 'method'

On Fred I have added gateway 192.168.0.254 to /etc/network/interfaces and restarted.

ip route show | grep default | awk '{print $3}'
returns
192.168.0.254


However, I still dont seem to be able to share the internet from VLE as a gateway. (I havent even tried to get started on the difficult stuff yet either!)

Where am I going wrong?

Many thanks