Hi all,

I just run sudo apt-get install g++ on terminal with the permission. But it's not working and kind of a messages listed (sorry i'm new to this and I don't know the exact terchnical term) and end up with something like this,

gvfs-fuse is already the newest version.
xorg-docs-core is already the newest version.
libgnome-bluetooth8 is already the newest version.
xserver-xorg-video-nouveau-lts-quantal is already the newest version.
gir1.2-appindicator3-0.1 is already the newest version.
gstreamer0.10-alsa is already the newest version.
python-gconf is already the newest version.
gstreamer0.10-tools is already the newest version.
libgphoto2-port0 is already the newest version.
libglib2.0-0 is already the newest version.
gir1.2-peas-1.0 is already the newest version.
python-configglue is already the newest version.
gnome-session-bin is already the newest version.
libgomp1 is already the newest version.
usb-creator-gtk is already the newest version.
libgnome-desktop-3-2 is already the newest version.
software-properties-gtk is already the newest version.
libcupsimage2 is already the newest version.
growisofs is already the newest version.
gnome-power-manager is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
its_bigb@its_bigb-VirtualBox:~$
Can anybody please comment on this.