Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Ethernet port not registering

  1. #11
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,875
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ethernet port not registering

    My suggestion? Installing the -25 kernel? I thought alx was working; or was that the compiled version? Did the install go without error or warning? Any clues in dmesg?
    Code:
    dmesg | grep -i -e warn -e error
    Do you think reinstalling from scratch would be worth a try?
    Why??

    Network Manager is not designed to manage two competing ethernet connections. I'd detach the ethernet from the Realtek, attach one to the Atheros and reboot.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

  2. #12
    Join Date
    Aug 2006
    Location
    Emigrant, MT
    Beans
    79

    Re: Ethernet port not registering

    Ok, I got mine working, here's what I did.

    Detaching and removing the Realtek didn't work on it's own. After I removed it, running ifconfig just showed the lo device. Running ifconfig -a showed the Atheros device named p4p1 and disabled. I edited /etc/network/interfaces, which still had the Realtek interface named p6p1 listed. I changed p6p1 to p4p1, rebooted, and all works perfectly now. I'm not sure why it named the interfaces like that, but it works.

    Thanks again for your help, hopefully what worked for me will also help the other guy having issues with this chipset.

  3. #13
    Join Date
    Oct 2010
    Beans
    110
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Ethernet port not registering

    I decided to just reinstall Ubuntu to get the USB ports working and get back to where I was. Any other suggestions on getting the Ethernet port to work would be nice, but if I don't get it working it's not that big of a deal because this is mainly a travel laptop, so I'll generally be tethering my phone to it for Internet (via USB), or using wireless networks. It'd still be nice to have Ethernet working just in case I ever want it though. Thanks for trying at least.

    And yes my installation went without errors/warnings, but I'm not sure what all was and was not working, I'm pretty new to Ubuntu. Been using it for maybe 2 years but still not that familiar with the 'behind the scenes' stuff.
    Last edited by ShadowVegan; March 5th, 2013 at 04:40 AM.

  4. #14
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,875
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Ethernet port not registering

    Quote Originally Posted by ShadowVegan View Post
    I decided to just reinstall Ubuntu to get the USB ports working and get back to where I was. Any other suggestions on getting the Ethernet port to work would be nice, but if I don't get it working it's not that big of a deal because this is mainly a travel laptop, so I'll generally be tethering my phone to it for Internet (via USB), or using wireless networks. It'd still be nice to have Ethernet working just in case I ever want it though. Thanks for trying at least.

    And yes my installation went without errors/warnings, but I'm not sure what all was and was not working, I'm pretty new to Ubuntu. Been using it for maybe 2 years but still not that familiar with the 'behind the scenes' stuff.
    I firmly believe the best and easiest approach is linux-image as above.
    "Oh, Ubuntu, you are my favorite Linux-based operating system" --Dr. Sheldon Cooper, Ph.D.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •