Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Sudo password for user

  1. #1
    Join Date
    Mar 2013
    Beans
    9

    Sudo password for user

    Hey,

    I was trying to install steam for ubuntu and the terminal says that steam need to install additional packages (libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386) but it asks for a password, which, I don't have. Is it a default password? this message appears everytime I try to use the Terminal.

    Thanks in advance.

  2. #2
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,877
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Sudo password for user

    It is password that You've chosen when installing Ubuntu, for that user...

  3. #3
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Sudo password for user

    Quote Originally Posted by betinhoweck View Post
    Hey,

    I was trying to install steam for ubuntu and the terminal says that steam need to install additional packages (libgl1-mesa-dri:i386, libgl1-mesa-glx:i386, libc6:i386) but it asks for a password, which, I don't have. Is it a default password? this message appears everytime I try to use the Terminal.

    Thanks in advance.
    Welcome to the Ubuntu Forums

    The sudo password is the same as the log in password for the user, provided the user has the privilege to run superuser processes.

    In other words, if your user account is enabled to use sudo, you can use your normal password. Otherwise you must ask your system administrator, if you can get superuser (alias root) privileges.

  4. #4
    Join Date
    Mar 2013
    Beans
    9

    Re: Sudo password for user

    Well, I am supposed to be the administrator, and the password i chose during installation was "123" but it is not working. I've tried to edit it in the accounts settings but it keeps asking a password for permission.

    I'm sorry for being such a noob

    Thanks for fast reply

  5. #5
    Join Date
    Jul 2012
    Location
    Dhaka
    Beans
    259
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Sudo password for user

    If you want to change the account setting, then you also have to enter your password. After giving the correct password, you'll be able to change the user settings.

  6. #6
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Sudo password for user

    If your password is not working, you can reset it according to this link

    http://www.psychocats.net/ubuntu/resetpassword


    I think you need at least 6 characters (and it should not be a word in a dictionary), better with at least 8 characters and at least one non-alphanumeric character (not a-z,A-Z,0-9).

  7. #7
    Join Date
    Mar 2013
    Beans
    9

    Re: Sudo password for user

    I have ubuntu dual-boot with windows 7, and I can't see any recovery mode in the boot menu...

  8. #8
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Sudo password for user

    Quote Originally Posted by betinhoweck View Post
    I have ubuntu dual-boot with windows 7, and I can't see any recovery mode in the boot menu...
    Please list the alternatives in your boot menu! (Is it a grub menu or a Windows boot menu?)

    Is it dual boot or wubi install?

  9. #9
    Join Date
    Mar 2013
    Beans
    9

    Re: Sudo password for user

    the alternatives are:
    Windows 7
    Ubuntu
    It is a windows like menu and I've installed Ubuntu through Wubi.

  10. #10
    Join Date
    Nov 2011
    Location
    /dev/root
    Beans
    Hidden!

    Re: Sudo password for user

    Quote Originally Posted by betinhoweck View Post
    the alternatives are:
    Windows 7
    Ubuntu
    It is a windows like menu and I've installed Ubuntu through Wubi.
    I haven't run Wubi, but I guess that Ubuntu is booted from that first Windows menu, and maybe via a hidden grub menu. If this is the case maybe you can try pressing the shift key after selecting Ubuntu according to the tip in the Psychocats link.
    First, you have to reboot into recovery mode.

    If you have a single-boot (Ubuntu is the only operating system on your computer), to get the boot menu to show, you have to hold down the Shift key during bootup.
    If no go,
    1. Backup your /etc/default/grub file
    Code:
    cp -p /etc/default/grub /etc/default/grub.0
    2. Edit your /etc/default/grub file. Change the line
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
    to
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="recovery nomodeset"
    3. Run
    Code:
    sudo update-grub
    and reboot

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •