Results 1 to 4 of 4

Thread: Pressing 'D' key minimizes to desktop over xrdp in ubuntu 12.1

  1. #1
    Join Date
    Mar 2013
    Beans
    2

    Pressing 'D' key minimizes to desktop over xrdp in ubuntu 12.1

    I've read numerous threads about this same issue with earlier versions of Ubuntu but unfortunately the solution presented in every thread I've read hasn't worked. Most of these threads point to the "Hide all normal windows and set focus to the desktop" keyboard shortcut as the culprit. When I set my corresponding "Hide all normal windows" keyboard shortcut to 'disabled' nothing changes. Per another thread (http://ubuntuforums.org/showthread.php?t=1595871) I also tried to find some shortcuts via gconf-editor but the /apps/metacity directory does not contain a 'global_keybindings' entry, nor does my '
    /var/lib/gconf/debian.defaults/%gconf-tree.xml
    ' file contain a 'show_desktop' entry. If anyone know the cause of this issue or has any suggestions on where to find other keyboard shortcuts setting locations related Ubuntu 12.1 or xrdp I'd greatly appreciate it.

  2. #2
    Join Date
    Mar 2013
    Beans
    2

    Re: Pressing 'D' key minimizes to desktop over xrdp in ubuntu 12.1

    Ok I solved my problem. Rather than looking it gconf as many answers for older versions of ubuntu have suggested, the solution was to use dconf instead. The keyboard shortcuts in question were stored in org.gnome.settings-daemon.plugins.media-keys

    See this thread for more details: http://askubuntu.com/questions/26056.../217310#217310

  3. #3
    Join Date
    May 2013
    Beans
    1

    Re: Pressing 'D' key minimizes to desktop over xrdp in ubuntu 12.1

    Same problem, more information and fixes for 13.04. My situation is using Ubuntu as VM and then using XRDP to connect. Had to use gnome-fallback.

    There is a new / different place in dconf where it holds the dreaded "show_desktop" parameter. Here is how to fix it for all users:
    1. Create a file as root called /etc/dconf/db/gdm.d/fixshow_desktop.d with the following in it:
    [org/gnome/desktop/wm/keybindings]
    show_desktop=''


    2. Run sudo dconf update so that dconf can read the changes. Users will have to logout / login to see the change.


    This should fix the problem. This is the same as every user going into System Setting | Keyboard |Shortcuts or dconf editor and going down the org->gnome->desktop->wm->keybindings tree.
    Last edited by LinuxTomB; May 9th, 2013 at 01:16 AM.

  4. #4
    Join Date
    Mar 2007
    Location
    Moldova
    Beans
    48
    Distro
    Kubuntu 7.04 Feisty Fawn

    Re: Pressing 'D' key minimizes to desktop over xrdp in ubuntu 12.1

    THANK YOU!! This was driving me insane, apparently this is an old bug that had a workaround for a long time that no longer works. THESE solutions actually do work in Ubuntu 13.04.

    I'm not sure which one solved it as I tried both, maybe both are necessary. REBOOT was required; dconf update and logout-login DID NOT do the trick.

    Quote Originally Posted by LinuxTomB View Post
    There is a new / different place in dconf where it holds the dreaded "show_desktop" parameter. Here is how to fix it for all users:
    1. Create a file as root called /etc/dconf/db/gdm.d/fixshow_desktop.d with the following in it:
    [org/gnome/desktop/wm/keybindings]
    show_desktop=''


    2. Run sudo dconf update so that dconf can read the changes. Users will have to logout / login to see the change.
    Quote Originally Posted by sudoNebula View Post
    Ok I solved my problem. Rather than looking it gconf as many answers for older versions of ubuntu have suggested, the solution was to use dconf instead. The keyboard shortcuts in question were stored in org.gnome.settings-daemon.plugins.media-keys

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •