Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Sound problems (poor 5.1 sound, low mic volume)

  1. #1
    Join Date
    Mar 2007
    Beans
    8

    Sound problems (poor 5.1 sound, low mic volume)

    Hey there. I've installed Ubuntu 12.10 and I find that great! ( I'm a Windows user - if there will be DoTA 2 for linux, I'll say bye bye to windows )
    But I have some problem with sound card. It may be because I don't know how to set it up right. The sound card is Xonar D1. I enabled 6 channels by editing that alsa config file (can't remember the right name, I'm on windows now - you know which file ) and the test from the mixer is working (the one when you click on each speaker), except for the subwoofer. I hear a...thing, but that's not bass. If I'll have to, I'll record the sound which subwoofer makes when I hit his icon on the mixer I played with alsamixer, too, but no luck to get the subwoofer make the correct sound (low frequencies, just....rustling sound).
    Also, I know from Windows that with WMP I can hear 5.1 effect in 5.1 .mkv movies. Didn't noticed that effect in Ubuntu.
    Now with the microphone. I installed Skype for Ubuntu, but when I get a call, the other person can't hear me only if I shout on the microphone (so it is correctly installed - working good under Windows). What can I do in this situation?
    Thank you.
    Last edited by caracalsef; March 5th, 2013 at 01:07 AM.

  2. #2
    Join Date
    Jul 2005
    Beans
    18

    Re: Sound problems (poor 5.1 sound, low mic volume)

    Hi,
    With Skype you may be able to fix the issue by open a terminal and typing:

    gstreamer-properties

    A window will open with output and input options. Under input, select Plugin: ALSA -- Advanced Linux Sound Architecture, then under Device, change it from default to whatever the system has picked up (there may be more than one, so experiment). Close the window.

    In the terminal, type:

    alsamixer

    Try raising the microphone volume. In Skype, under preferences--audio select ALSA as the default input. Try a test call to see if it worked. You may get feedback, so turn your speaker output down just in case.

    If that doesn't help, I'm sure others will be able to direct you to the proper solution. Good luck.

  3. #3
    Join Date
    Mar 2007
    Beans
    8

    Re: Sound problems (poor 5.1 sound, low mic volume)

    Thank you for your try midfingr

    Unfortunately, that didn't helped I made the settings in gstreamer-properties.

    In skype, at sound devices I have only "PulseAudio server (local)" at Microphone, Speakers and Ringing. There's nothing else to choose from.

    In alsamixer I have set +12 dB Gain. I also have a square with a text under that says "<Mic Boost>", but I can't change anything and in the square I have "MM".

    L.E.: I think I got it. That MM means it's muted so I must hit M key to unmute. Now Mic Boost is on and with +20dB Gain. I resolved this problem Now only remain the one with 5.1 sound effect and subwoofer "lack of bass"
    Last edited by caracalsef; March 4th, 2013 at 01:27 AM.

  4. #4
    Join Date
    Jul 2005
    Beans
    18

    Re: Sound problems (poor 5.1 sound, low mic volume)

    Hi,
    It's good to see you've resolved the mic issue. Thank you for the update.

    I have problems with 5.1 surround; using onboard audio. The only time I can get it working is when using Arch Linux and OSS (Open Sound System). When using ALSA and Pulse, I just leave it at stereo. I wish I could help you out.

    A long shot. Maybe take a look at this article? -- http://drona.csa.iisc.ernet.in/~uday...nd-pulse.shtml It's probably outdated however.

  5. #5
    Join Date
    Mar 2007
    Beans
    8

    Re: Sound problems (poor 5.1 sound, low mic volume)

    I solved the 5.1 audio, too. A guy in romanian Ubuntu forums posted a daemon.conf and I just replaced it with mine Now everything is OK!

    Thank you for support. Here's the config file

    Code:
    # This file is part of PulseAudio.
    #
    # PulseAudio is free software; you can redistribute it and/or modify
    # it under the terms of the GNU Lesser General Public License as published by
    # the Free Software Foundation; either version 2 of the License, or
    # (at your option) any later version.
    #
    # PulseAudio is distributed in the hope that it will be useful, but
    # WITHOUT ANY WARRANTY; without even the implied warranty of
    # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
    # General Public License for more details.
    #
    # You should have received a copy of the GNU Lesser General Public License
    # along with PulseAudio; if not, write to the Free Software
    # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
    # USA.
    
    ## Configuration file for the PulseAudio daemon. See pulse-daemon.conf(5) for
    ## more information. Default values are commented out.  Use either ; or # for
    ## commenting.
    
    ; daemonize = no
    ; fail = yes
    ; allow-module-loading = yes
    ; allow-exit = yes
    ; use-pid-file = yes
    ; system-instance = no
    ; local-server-type = user
    ; enable-shm = yes
    ; shm-size-bytes = 0 # setting this 0 will use the system-default, usually 64 MiB
    ; lock-memory = no
    ; cpu-limit = no
    
    high-priority = yes
    nice-level = -11
    
    realtime-scheduling = yes
    ; realtime-priority = 5
    
    ; exit-idle-time = 20
    ; scache-idle-time = 20
    
    ; dl-search-path = (depends on architecture)
    
    ; load-default-script-file = yes
    ; default-script-file = /etc/pulse/default.pa
    
    ; log-target = auto
    ; log-level = notice
    ; log-meta = no
    ; log-time = no
    ; log-backtrace = 0
    
    # resample-method = speex-float-7
    resample-method =  src-sinc-medium-quality
    # resample-method = src-sinc-best-quality
    enable-remixing = yes
    enable-lfe-remixing = yes
    
    flat-volumes = no
    
    ; rlimit-fsize = -1
    ; rlimit-data = -1
    ; rlimit-stack = -1
    ; rlimit-core = -1
    ; rlimit-as = -1
    ; rlimit-rss = -1
    ; rlimit-nproc = -1
    ; rlimit-nofile = 256
    ; rlimit-memlock = -1
    ; rlimit-locks = -1
    ; rlimit-sigpending = -1
    ; rlimit-msgqueue = -1
    ; rlimit-nice = 31
    ; rlimit-rtprio = 9
    ; rlimit-rttime = 1000000
    
    default-sample-format = s24le
    default-sample-rate = 48000
    default-sample-channels = 6
    default-channel-map = front-left,front-right,rear-left,rear-right,front-center,lfe
    
    default-fragments = 2
    default-fragment-size-msec = 5
    
    ; enable-deferred-volume = yes
    deferred-volume-safety-margin-usec = 1
    ; deferred-volume-extra-delay-usec = 0

  6. #6
    Join Date
    Jul 2005
    Beans
    18

    Cool Re: Sound problems (poor 5.1 sound, low mic volume)

    Awesome!! Thank you for letting me know.

    I made some progress too. Turns out the connections at the back were incorrect; took hours to figure them out.

    Also. The script. Is that the default.pa or the other system script? In any case, I was messing around with something similar, but I completely broke pulseaudio -- lol! Good thing I made a backup so alls well.

    Here's something to type in the console for a speaker test:

    Code:
    speaker-test  -c6 -l1 -twav

  7. #7
    Join Date
    Mar 2007
    Beans
    8

    Re: Sound problems (poor 5.1 sound, low mic volume)

    Code:
    Also. The script. Is that the default.pa or the other system script?
    I didn't understood the question...sorry.
    Now I have other thig that bug me. I can get a clear sound when watching youtube clips, but when I play a movie, sometimes the sound goes to high. And overall volume is to low. I mean, if I set speakers to a volume to hear good in youtube, in movies I can't hear almost anything (except for high volume on some parts of the movie). If I set the proper volume for movies, if I play a youtube clip, the volume is WAY to high!

  8. #8
    Join Date
    Jul 2005
    Beans
    18

    Re: Sound problems (poor 5.1 sound, low mic volume)

    No worries about the question. I saw that it was a daemon config file.

    That sounds like a common problem everyone has. It has to do with going from stereo to a surround mix and other variations. To be sure however, are voices in movies hard to hear? You turn up the volume. a loud part happens and you're blasted out of the room? That's not just computers, but on legacy equipment as well.

    What player(s) do you use to watch movies? i.e. VLC, Totem, other? VLC offers a lot of sound customization for example.

    EDIT: Here's one example for adjusting volume in VLC Player: http://www.instantfundas.com/2012/06...-loud-use.html
    Last edited by midfingr; March 7th, 2013 at 10:14 PM. Reason: extra info

  9. #9
    Join Date
    Mar 2007
    Beans
    8

    Re: Sound problems (poor 5.1 sound, low mic volume)

    I use smplayer to watch movies and I think all of them are 6 channels.

    Yes, that was the problem. Low voices and then...BOOM, some loud scene from the movie

    I kinda solved this by checking normalize volume box in smplayer options. It was ticked by default, but I unchecked it

    Well, so far I like Ubuntu and I'm 3 days without windows )

  10. #10
    Join Date
    Jul 2005
    Beans
    18

    Re: Sound problems (poor 5.1 sound, low mic volume)

    Smplayer, excellent media software. I use that as well.

    One movie notorious for that is Matrix. If you have a copy, try getting that balanced out.

    Congrats on your days with Ubuntu/Linux! So, did you completely trash Windows?

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •