Page 3 of 3 FirstFirst 123
Results 21 to 26 of 26

Thread: "Gave up waiting for root device"

  1. #21
    Join Date
    Feb 2013
    Beans
    Hidden!

    Re: "Gave up waiting for root device"

    Well, this is what I get on my system (Debian wheezy):
    Code:
    $ uname -a
    Linux infa64imgs 3.2.0-4-amd64 #1 SMP Debian 3.2.35-2 x86_64 GNU/Linux
    $ zcat /boot/initrd.img-`uname -r`|cpio -it|egrep '/(scsi/[lms]|fusion/)'|sort
    60856 blocks
    lib/modules/3.2.0-4-amd64/kernel/drivers/message/fusion/mptbase.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/message/fusion/mptfc.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/message/fusion/mptsas.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/message/fusion/mptscsih.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/message/fusion/mptspi.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/libfc
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/libfc/libfc.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/libiscsi.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/libiscsi_tcp.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/libsas
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/libsas/libsas.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/libsrp.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/lpfc
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/lpfc/lpfc.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/megaraid
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/megaraid.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/megaraid/megaraid_mbox.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/megaraid/megaraid_mm.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/megaraid/megaraid_sas.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/mpt2sas
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/mpt2sas/mpt2sas.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/mvsas
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/mvsas/mvsas.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/mvumi.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/scsi_debug.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/scsi_mod.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/scsi_tgt.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/scsi_transport_fc.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/scsi_transport_iscsi.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/scsi_transport_sas.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/scsi_transport_spi.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/scsi_transport_srp.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/scsi_wait_scan.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/sd_mod.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/ses.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/sg.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/sr_mod.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/stex.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/st.ko
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/sym53c8xx_2
    lib/modules/3.2.0-4-amd64/kernel/drivers/scsi/sym53c8xx_2/sym53c8xx.ko
    Last edited by schragge; March 5th, 2013 at 10:39 AM.

  2. #22
    Join Date
    May 2010
    Location
    uk
    Beans
    8,221
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: "Gave up waiting for root device"

    Hi

    At the busy box prompt, does pressing

    Code:
    ctrl + d
    continue the boot cycle ?

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  3. #23
    Join Date
    Jan 2013
    Beans
    16

    Re: "Gave up waiting for root device"

    Just got back; I'll be sure to read through everything that was posted and keep you updated.

    UPDATE:

    I just ran into an IDE DVD reader; I'm going to burn several different distros and see if I have any luck with it.
    Last edited by TheAdmiralty; March 6th, 2013 at 11:06 PM.

  4. #24
    Join Date
    Jan 2013
    Beans
    16

    Re: "Gave up waiting for root device"

    It boots.

    I'll describe what I did, because it seems to have really been an issue of trying to do something the LiveOS wasn't intended to do.

    I completely gutted the hard drive bays on this, and removed the Fujitsu drive entirely. I then shifted the remaining two Cheetah drives upward and jumped them to ID0 and ID1. Secondly, I added an IDE DVD-ROM drive and booted it off of a DVD burnt with Zorin. Booted into the Installation menu and installed on the first drive.

    On restart, it passed the default GRUB menu, went through the splash screen, and stopped at BusyBox. [ctrl] + [d] caused it to repeat itself. I rebooted, and changed the GRUB boot line to include root=/dev/sda1 noapic rootdelay=120

    It actually booted to the desktop.

    This is just my relatively uneducated assumption, but it would appear that it isn't possible to get a reliable installation from a LiveOS fron IDE, over an LSI controller, and onto a SCSI drive.
    I still have problems, but they're nothing software related, or fixable at the moment (IE, not enough graphical power). I'll go try it again to make sure that wasn't a fluke. As long as it's repeatable, I'll go edit the GRUB config and make it permanent; will also probably set it to skip over the GRUB delay altogether if possible.
    Last edited by TheAdmiralty; March 7th, 2013 at 03:30 AM.

  5. #25
    Join Date
    May 2010
    Location
    uk
    Beans
    8,221
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: "Gave up waiting for root device"

    Hi

    I'm glad you got it working

    Does it still boot if you remove the noapic kernel option ?

    Kind regards
    If you believe everything you read, you better not read. ~ Japanese Proverb

    If you don't read the newspaper, you're uninformed. If you read the newspaper, you're mis-informed. - Mark Twain

  6. #26
    Join Date
    Jan 2013
    Beans
    16

    Re: "Gave up waiting for root device"

    Just tested it, and yes, it will boot without noapic. The two kernel options that are needed are root=/dev/sda1 and rootdelay=120.

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •