Results 1 to 6 of 6

Thread: No sound on T.V when I hook up my laptop to it via HDMI

  1. #1
    Join Date
    Feb 2013
    Beans
    14

    No sound on T.V when I hook up my laptop to it via HDMI

    The sound only comes from my laptop how do I make it so that it comes from my T.V?

  2. #2
    Join Date
    Aug 2007
    Location
    US
    Beans
    914
    Distro
    Ubuntu Development Release

    Re: No sound on T.V when I hook up my laptop to it via HDMI

    After you hook up to the hdmi cable, you need to go to System Settings -> Sound -> Output (tab) and on the left where it says 'play sound through' make sure the hdmi option is selected and the output volume set to 100% (it should set the volume for you).
    Please mark completed threads as [SOLVED], which lets us find solutions faster!

  3. #3
    Join Date
    Jun 2009
    Location
    Somewhere with hills
    Beans
    172
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: No sound on T.V when I hook up my laptop to it via HDMI

    Make sure your GPU/laptop supports that function to begin with. Newer AMD video cards (6xxx and greater) have audio chips built in the card and should automatically. Nvidia, I think, has the drivers pass your audio signals from the audio chip through the Nvidia video card. I don't know if that driver function is supported in the Linux. This is all on based on a small amount of research so don't take it as a straight fact.
    ♫♪♫ You just keep on trying till you run out of cake ♪♫♪

  4. #4
    Join Date
    Feb 2013
    Beans
    14

    Re: No sound on T.V when I hook up my laptop to it via HDMI

    Quote Originally Posted by I8NY View Post
    Make sure your GPU/laptop supports that function to begin with. Newer AMD video cards (6xxx and greater) have audio chips built in the card and should automatically. Nvidia, I think, has the drivers pass your audio signals from the audio chip through the Nvidia video card. I don't know if that driver function is supported in the Linux. This is all on based on a small amount of research so don't take it as a straight fact.
    It works when I use Windows 7

  5. #5
    Join Date
    Feb 2013
    Beans
    14

    Re: No sound on T.V when I hook up my laptop to it via HDMI

    Quote Originally Posted by ptn107 View Post
    After you hook up to the hdmi cable, you need to go to System Settings -> Sound -> Output (tab) and on the left where it says 'play sound through' make sure the hdmi option is selected and the output volume set to 100% (it should set the volume for you).
    I don't have the sound setting.

  6. #6
    Join Date
    Mar 2006
    Location
    Rumplestiltskin, Cal.
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No sound on T.V when I hook up my laptop to it via HDMI

    You may have to add your user name to the sound group. If that isn't helpful, all I have is this:

    http://ubuntuforums.org/showthread.php?t=1885240

    which is very thorough.
    AMD Athlon II X4 620, 4gig ddr2-800, m/b MSI K9N6PGM2, 1T SATA, EVGA 9500GT, Brother MFC-240C prntr, LG DVD-rom GSA-H55N

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •