Results 1 to 10 of 11

Thread: SAMSUNG Series 3 NP365E5C-XXXXX laptops

Threaded View

  1. #1
    Rebelli0us is offline Extra Foam Sugar Free Ubuntu
    Join Date
    Feb 2008

    SAMSUNG Series 3 NP365E5C-XXXXX laptops

    These have AMD A-Series Trinity APUs, dual-core or quad. Mine is Series 3 NP365E5C-S01US A8-4500M with Radeon HD 7640G.

    I have success:

    Windows 8 (preinstalled) worked fine. I kept it long enough to update the BIOS, then deleted it. W8 had some kind of GPT partition, I had to use gparted to obliterate it.

    Windows 7 (both Pro & Enterprise) works fine, but has intermittent suspend failure. I plan to delete it soon. I will post my driver install procedure later, for anybody interested.

    Ubuntu 12.10, worked fine, though I had a hard time navigating the OS’s UI.

    Linux Mint 14 MATE, everything works, Suspend/Resume S3 very reliable. Touchpad mouse is fully supported, including 2-figer scrolling.

    I have not encountered the so-called “brick” BIOS bug that makes these laptops inoperable. In BIOS "boot" options I disabled "secure boot", and in Advanced tab disabled “Fast BIOS Mode”. In “OS mode selection” I have “UEFI and legacy”, but “CSM” worked too.

    BIOS Version : P05ABF
    Date : 01/29/2013

    For me the best news is that all 4 USB ports are bootable (USB 2.0 and 3.0). That means you can boot any OS from a UHS-I flash drive at 80+ MB/sec and have as many portable OS sticks as you want. Nice security feature too in case your laptop gets stolen.

    Problems so far:

    -- In Power Options, I have “When power button is pressed” set to “Suspend” but it shuts down instead.

    -- Some of the Fn shortcuts don’t work properly. Display Brightness Fn+F2/F3 and sound volume adjustment Fn+F7/F8 mess up the keyboard stack and you basically have to reboot. I think it has something to do with Windows/Linux differences in Key_Up/Key_Down event handling. F1, F11, F12 don’t work either, generate some nasty key codes and you have to reboot. Fn+F5 enable/disable touchpad works, I wish there was a way to auto-disable touchpad when an external mouse is connected.

    BTW, on startup F10 brings up the boot menu (undocumented), but does not list all available boot devices.

    Color temperature of the LCD display is way off to the cool side, but problem solved (see attached)

    More soon. . .
    Attached Images Attached Images


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts