Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Internet problems - avahi / .local domain

  1. #11
    Join Date
    Feb 2013
    Beans
    24

    Re: Internet problems - avahi / .local domain

    Thank you for your help everyone!

    All solved now - as it happens, moved apartment recently and the phone socket here gives no such problem! - we're not paying for internet here or last place (Korea's a bit funny like that) - so its a case of so far so good!

    Incidentally, you kind folks were much more helpful than the system76 support guy I was in contact with, so consider yourselves professional!

    Cheers all,

    Gareth.

  2. #12
    Join Date
    May 2007
    Location
    Perth, Australia
    Beans
    113
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Internet problems - avahi / .local domain

    Hey guys,
    Sorry to bring this old thread back from the grave. However Gareth seems to be having the same issues that I'm having.
    I'm running Ubuntu 13.10 on a Mid 2010 MacBook Pro.

    This pops us for then disappears after a few seconds. It's no biggie, but it's kinda annoying.

    Any clues as to how I could fix it?

    Merry Christmas
    Last edited by b3n0; December 24th, 2013 at 04:20 AM. Reason: Fixing image
    Every fight is a food fight when you’re a cannibal.
    -- Demetri Martin

  3. #13
    Join Date
    Dec 2009
    Beans
    5,454

    Re: Internet problems - avahi / .local domain

    Count yourself thankful that you didn't get the recommended notification:
    Avahi detected that your currently configured local DNS server serves
    a domain .local. This is inherently incompatible with Avahi and thus
    Avahi disabled itself. If you want to use Avahi in this network, please
    contact your administrator and convince him to use a different DNS domain,
    since .local should be used exclusively for Zeroconf technology.
    It's unfortunate that Linux can't follow Apple's lead on this thing. OSX goes through a similar detection mechanism with Bonjour ( it's name for Avahi ) and does something intuitively simple: hostname.local is handled by Bonjour and server.domain.local is handled by the DNS server. Problem solved.

    Anywho, the most often recommended solution is to go into /etc/default/avahi-daemon and change the "1" in "AVAHI_DAEMON_DETECT_LOCAL=1" to a "0". That will indeed remove the error message but the proponents of this method seen to ignore the very caution stated in the file itself in doing so:
    # 1 = Try to detect unicast dns servers that serve .local and disable avahi in
    # that case
    , 0 = Don't try to detect .local unicast dns servers, can cause
    # troubles on misconfigured networks

    AVAHI_DAEMON_DETECT_LOCAL=1
    It's unfortunate in your case since you are a mac user and Avahi / Bonjour is a way for both these modern operating systems to find each other on the local network without a lot of fuss.

    You can change your DNS server to OpenDNS as DuckHook suggested, change ".local" to ".alocal" so there is no interference with your ISP's DNS server ( I have no idea how to make that change in OSX since it's not an issue there ), disable the check in /etc/default/avahi-daemon, or live with the error message. The error message should only happen once on start up - right?
    Last edited by Morbius1; December 24th, 2013 at 03:35 PM.

  4. #14
    Join Date
    May 2007
    Location
    Perth, Australia
    Beans
    113
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Internet problems - avahi / .local domain

    Hey,
    Yep, just on start up or login. I followed that tutorial but it hasn't fixed it.
    Every fight is a food fight when you’re a cannibal.
    -- Demetri Martin

  5. #15
    Join Date
    Oct 2009
    Location
    Elgin, IL USA
    Beans
    2,534
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Internet problems - avahi / .local domain

    Do you have anything in your /etc/hosts file that contains a .local domain, or does your router somehow use that for a LAN domain? I used to use .local as a LAN domain in /etc/hosts or local DNS, but many years ago SuSE strongly suggested not to use "local" as a domain due to conflict with something else (which I thought was multicasting, but maybe it was Apple zeroconfig).

    Avahi can be handy for some things and is installed by default in Ubuntu. For example if I want to connect to another computer on my LAN with unknown dynamic IP (especially a Raspberry Pi with avahi-daemon installed) I can connect to it by its hostname.local, for example: ssh raspberry-pi.local or http://raspberry-pi.local/ if running apache.

    Zeroconfig is a little flaky in Windows though, because if you install Apple Bonjour in Windows, I think PuTTY can find other computers by hostname.local, but Internet Explorer or Firefox need to have it settings modified to NOT to use a default DNS search domain, nor search the internet if it thinks a domain is missing, and only use the hostname without .local to find a LAN web server by zeroconfig/avahi.
    i5 650 3.2 GHz, 8 GB, nvidia GTX 550 Ti 32" 1080p | i7-4700, 8 GB, Intel HD 4600/nvidia GTX 765M 15.6" 1080p | etc.

  6. #16
    Join Date
    Jun 2012
    Beans
    1

    Re: Internet problems - avahi / .local domain

    My computer and OS
    Dell Vostro 1015
    Ubuntu 12.04LTS
    uname -a Linux 3.2.0-57-generic #87-Ubuntu SMP

    Four days ago I was informed that an update to this software was available and I
    should run the update.

    During the launching of the Update Manager I was aware of, but did not carefully
    read, a warning of some kind regarding this software and updating my computer.

    After updating Avahi my laptop will not connect to my wireless network. It will
    connect to other wireless networks but not the one I have at home.

    When I attempt to connect using the Ubuntu connection icon I get the following message.

    "Your current network has a .local domain which is not recommended and
    incompatible with the Avahi network service discovery. The service has
    been disabled."

    I can ping my router and DSL modem. I can not connect with my
    web browser or connect to my e-mail through Thunderbird

    Following the advise on this thread I ran

    ifconfig|grep 'inet addr'

    and got inet addr: 127.0.0.1 Mask: 255.0.0.0
    inet addr: 10.0.0.4 Bcast: 10.0.0.255 Mask: 255.255.255.0

    host -t SOA local

    return from this command

    local has address 192.168.1.250

    I have browsed through my hosts file and do not find any entry related to
    '.local' or the IP 192.168.1.250.

    How can I find out if my ISP is 'giving' me the .local?

    Thanks.

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •